Solved

iis plugin for weblogic timeout

Posted on 2010-09-05
4
1,813 Views
Last Modified: 2013-12-10
folks

from my application running on weblogic i run queries but eventually they time-out and i get kicked out of the application, my weblogic cluster runs via the iis plugin and along with the lost multicast messages i also get the following error in my iis plugin log

Tue Aug 24 09:20:17 2010 <16812826596072> *******Exception type [CONNECTION_REFUSED] (Error connecting to host 149.177.182.141:80) raised at line 1732 of ..\nsapi\.\URL.cpp
Tue Aug 24 09:20:17 2010 <16812826596072> Exception occurred for backend host '149.177.182.141/80/80' while error while connecting to : 'CONNECTION_REFUSED [os error=0, line 1732 of ..\nsapi\.\URL.cpp]: Error connecting to host 149.177.182.141:80'
Tue Aug 24 09:20:17 2010 <16812826596072> Failed to connect to the general server 149.177.182.141:80:80, mark it BAD
Tue Aug 24 09:20:20 2010 <16812826596072> Error in delayed connection(), error 10061
Tue Aug 24 09:20:20 2010 <16812826596072> *******Exception type [CONNECTION_REFUSED] (Error connecting to host 149.177.182.142:80) raised at line 1732 of ..\nsapi\.\URL.cpp
Tue Aug 24 09:20:20 2010 <16812826596072> Exception occurred for backend host '149.177.182.142/80/80' while error while connecting to : 'CONNECTION_REFUSED [os error=0, line 1732 of ..\nsapi\.\URL.cpp]: Error connecting to host 149.177.182.142:80'
Tue Aug 24 09:20:20 2010 <16812826596072> Failed to connect to the general server 149.177.182.142:80:80, mark it BAD
Tue Aug 24 09:20:23 2010 <16812826596072> Error in delayed connection(), error 10061
Tue Aug 24 09:20:23 2010 <16812826596072> *******Exception type [CONNECTION_REFUSED] (Error connecting to host 149.177.182.148:80) raised at line 1732 of ..\nsapi\.\URL.cpp
Tue Aug 24 09:20:23 2010 <16812826596072> Exception occurred for backend host '149.177.182.148/80/80' while error while connecting to : 'CONNECTION_REFUSED [os error=0, line 1732 of ..\nsapi\.\URL.cpp]: Error connecting to host 149.177.182.148:80'
Tue Aug 24 09:20:23 2010 <16812826596072> Failed to connect to the general server 149.177.182.148:80:80, mark it BAD
Tue Aug 24 09:20:25 2010 <16812826596072> request [/maximo] did NOT process successfully ..................
Tue Aug 24 09:22:27 2010 <16812826597463> Error in delayed connection(), error 10061
Tue Aug 24 09:22:27 2010 <16812826597463> *******Exception type [CONNECTION_REFUSED] (Error connecting to host 149.177.182.149:80) raised at line 1732 of ..\nsapi\.\URL.cpp
Tue Aug 24 09:22:27 2010 <16812826597463> Exception occurred for backend host '149.177.182.149/80/80' while error while connecting to : 'CONNECTION_REFUSED [os error=0, line 1732 of ..\nsapi\.\URL.cpp]: Error connecting to host 149.177.182.149:80'
Tue Aug 24 09:22:27 2010 <16812826597463> Failed to connect to the general server 149.177.182.149:80:80, mark it BAD


can anybody advise on this for me?

rgrds

rutger
0
Comment
Question by:rutgermons
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
4 Comments
 
LVL 8

Expert Comment

by:allen-davis
ID: 33608801
The default port for WebLogic is usually 7001.  Are you trying to connect to the servers on port 80?  If so, have you changed the listen port on the managed servers to be 80 instead of 7001?
If you look at the managed server configuration, confirm the IP address and port for the managed servers and then from a web browser on the IIS box, try to hit each server individually and confirm they can be reached from the IIS box.  This will help you rule out connectivity as part of your issue.
0
 

Author Comment

by:rutgermons
ID: 33634168
ports are fine and the iis plugin is on the same server as the admin console which can read all the managed servers successfully

should i change my multicast address?
0
 
LVL 8

Accepted Solution

by:
allen-davis earned 500 total points
ID: 33652985
It seems strange that you are getting errors connection to this host:
error --  Failed to connect to the general server 149.177.182.141:80:80

Can you check and make sure you don't have the ip and port listed somewhere in the iis plugin where it is just expecting a host name or confirm that you don't have ":80:80" in the config file somewhere?

I think if the issue was multicast, you'd see issues with session replication but not failures in connecting.

As a troubleshooting step, what happens when you try to open this in a browser? 149.177.182.149:80
0
 

Author Closing Comment

by:rutgermons
ID: 33788715
ok answer, I solved the problem myself by setting the wlstimout settings
0

Featured Post

Optimize your web performance

What's in the eBook?
- Full list of reasons for poor performance
- Ultimate measures to speed things up
- Primary web monitoring types
- KPIs you should be monitoring in order to increase your ROI

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the developers using Tomcat find it easy to configure the datasource in Server.xml and use the JNDI name in the code to get the connection.  So the default connection pool using DBCP (or any other framework) is made available and the life go…
There are numerous questions about how to setup an IBM HTTP Server to be administered from WebSphere Application Server administrative console. I do hope this article will wrap things up and become a reference for this task. You need three things…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question