Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 650
  • Last Modified:

php zencart setup

Hello,

I just installed zencart on a hosting server and I get a page that says this,

This is a technical file included in your template package for security reasons.

Please refer to technical documentation for the correct path to your template index file.


see for yourself  http://www.larafabrics.com/

Unfortunately, I have to put the index.php at the end for it to show up: http://www.larafabrics.com/index.php

Please help!
Thanks
0
Isaac
Asked:
Isaac
3 Solutions
 
darren-w-Commented:
Hi,

It says it requires the path to the template index file, I believe this is a different file to what you are using?

Darren
0
 
NeoAshuraCommented:
Im guessing with your error the files are not in the correct place... Please make sure ALL your content is in one of the following folders, it will be one of these that your host has selected where all your website content is served from.. these are as follows...

 "www" or "public_html" or "htdocs" or "httpdocs" or "wwwroot" folder. These are the common folder names for what is referred to as the "webroot", which is where all website content is served from.

Make sure your work is in one of these folders and try again. Also please make sure on your FTP you have given it all 777 access to the folders.

Hope this helps

Mark
0
 
Scott MadeiraCommented:
A couple comments on your setup.

For your file protections you don't want to have them set at 777.  Directories for Zen Cart should be 755 and files should be 644.

Also, for security reasons you may want to consider changing the name of your admin directory to something other than "admin."  Something like larafab_admin would be better.

Here is a link to Zen Cart security recommendations.  I had a site hacked one time because I failed to follow these:

http://www.zen-cart.com/wiki/index.php/Important_Site_Security_Recommendations

0
 
IsaacSharePoint Client Side DeveloperAuthor Commented:
I'm not closing the question but assigning points
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now