Solved

Unable to automatically attach incoming Outlook 2007 e-mails to ACT! 2010 history

Posted on 2010-09-06
20
1,710 Views
Last Modified: 2012-05-10
Hi, I followed the following article:

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=23020&p_created=1217875219&p_sid=gM3Zg*8k&p_accessibility=0&p_redirect=&p_lva=&p_sp=cF9zcmNoPTEmcF9zb3J0X2J5PSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MTI5MiwxMjkyJnBfcHJvZHM9MCZwX2NhdHM9JnBfcHY9JnBfY3Y9JnBfc2VhcmNoX3R5cGU9YW5zd2Vycy5zZWFyY2hfbmwmcF9wYWdlPTEmcF9zZWFyY2hfdGV4dD1lbWFpbCBoaXN0b3J5&p_li=&p_topview=1

Quick attach inside Outlook 2007 works just fine. However when creating the rule, nothing happens. The test sender is indeed in the ACT! address book. I send an e-mail to the client. She receives the email but nothing in history.

I also noticed that the instructions in the above article for ACT! 2009 / 2010 want you to choose "Date, time, and Subject text". Where as ACT! 2008 allows you to use the "entire e-mail as attachment". When using Quick Attach, the attachments for the email are not included in history. Is there a way to make it so everything is included?
0
Comment
Question by:BarryRobbins76
  • 13
  • 7
20 Comments
 
LVL 7

Expert Comment

by:50cal
ID: 33612131
Hi,

If you copy all the data out of
C:\Users\<Username>\AppData\Roaming\ACT\ACT for Windows <version>\HistoryQueue  (Vista and 7).

and then test receiving an email from the sender, it should create a .MSG and .XML file in the above directory.

50cal.
0
 

Author Comment

by:BarryRobbins76
ID: 33612141
I apologize, I should have mentioned the OS is XP 32-bit SP3.
0
 
LVL 7

Expert Comment

by:50cal
ID: 33612151
No Worries,

The XP directory is C:\Documents and Settings\<USERNAME>\Application Data\ACT\ACT for Windows <Version>\HistoryQueue

50cal.
0
 

Author Comment

by:BarryRobbins76
ID: 33612166
Is this something I would just do for testing purposes and then copy all the contents back in? Or is this a way to "reset" the history queue to try to get things working again?
0
 
LVL 7

Expert Comment

by:50cal
ID: 33612174
You can delete them if you so desire, but I was suggesting to move them out for testing. Basically when you file an email Act takes a copy of the .MSG (email) and creates an .XML file which contains the filing instructions and places them both in the history queue.
A process called act.outlook.service.exe then reads the xml file and tries to file the .msg file into act, if the contact does not exist in the database then it is stored in holding... it then tries to re-attach them periodically... so if the contact is not created the history queue can become quite large.

I am suggesting this so you can see if the process is creating the file ready to be stored or if it is not creating a file at all.

50cal.
0
 

Author Comment

by:BarryRobbins76
ID: 33612234
Ok sounds good, when I am able to test in the afternoon, I will let you know the outcome of that step. Thanks for your help thus far.
0
 

Author Comment

by:BarryRobbins76
ID: 33613499
Ok so I deleted the files in the historyqueue folder. I sent an e-mail to her account with Outlook and ACT opened. No new files were created. I double checked that my email address was indeed added to her ACT contacts. Any ideas?
0
 

Author Comment

by:BarryRobbins76
ID: 33613533
I am also wondering if it is normal when creating the Custom action "ACT! - Auto attach e-mail to ACT! contact history", under rules in Outlook, for the 'Action Value' to show look something like 37ee4c13-369c-4ba7....
after selecting the db name.  Also could checking the box 'Make history private' have something to do with them not showing up?

0
 

Author Comment

by:BarryRobbins76
ID: 33613577
So here's the deal so far. I setup the rule to put a flag next to e-mails from senders in the ACT! address book. It did not do this. This leads me to believe that is is not recognizing senders from the ACT! address book. Maybe it is not properly talking to that book. However I am able to see it in Outlook.
0
 
LVL 7

Expert Comment

by:50cal
ID: 33613581
Hey,

If its not creating any entry then its more than likely not working.
If you highlight the same email that should be filed by rule and click quick attach does it record?

50cal.
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 

Author Comment

by:BarryRobbins76
ID: 33613586
Yes it does.
0
 
LVL 7

Expert Comment

by:50cal
ID: 33613591
If the history is recording as private only the record owner and administrators can see the history item. Are you sure you didn't miss it going into the queue before it filed? and are you the owner/administrator?

50cal.
0
 

Author Comment

by:BarryRobbins76
ID: 33613603
I also did check the queue and did not see it there. I don't think Outlook is processing the rule properly.
0
 

Author Comment

by:BarryRobbins76
ID: 33613607
I also checked to see if it was filed and it was not.
0
 

Author Comment

by:BarryRobbins76
ID: 33613615
Ok so this is interesting. When I forced the rule to run on the Inbox the messages attached successfully. For some reason it is just not processing the rule when the messages arrive.
0
 
LVL 7

Expert Comment

by:50cal
ID: 33613619
Have you got it set to "Apply this rule when the Message Arrives....
and in <yourdatabase>.pad

etc etc?

50cal.
0
 

Author Comment

by:BarryRobbins76
ID: 33613641
It says "Apply this rule after the message arrives". There is an option that says 'Check messages when they arrive" in the rules wizard when I create a new rule.


Underneath this it says:
Step2: edit the rule description (click an underlined value)
"Apply this rule after the message arrives"

Because of this the final rule says "Apply this rule after the message arrives".
0
 

Author Comment

by:BarryRobbins76
ID: 33613671
0
 

Accepted Solution

by:
BarryRobbins76 earned 0 total points
ID: 33613856
Ok so I figured it out by looking at this:

http://www.experts-exchange.com/Software/Office_Productivity/Groupware/Outlook/Q_25215033.html?sfQueryTermInfo=1+10+2007+30+automat+outlook+rule

The client is using an Outlook connector with MSN, however, this was not set as the 'default'. Even though email messages were arriving in the msn addresses inbox, the rules were being processed for a pst file that was set to 'default'. Once I set the msn account (probably an OST file) to the default, closed and opened Outlook, the rule processes automatically as e-mails arive.

Thanks for your help. If anything you helped get walk me through the steps to realize that Outlook was the issue and not Act.
0
 
LVL 7

Expert Comment

by:50cal
ID: 33613859
Glad you got it sorted :-).

50cal.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Best way to segregate branch information 6 530
Importing .DBF File SQL Server 2008 64 Bit 17 1,980
ACT 2000 DBF to ACT 2012 3 1,262
Sage ACT error: The SQL database instance is unavailable 52 5,006
As most of my regular readers and followers know, I do a lot of on-line technical support as well as providing support services to our resellers and ACT! Certified Consultants and one of the things I notice is that I regularly need to ask users the …
ACT LINK FOR PEACHTREE WON’T LINK PROBLEM       It always seems that when you upgrade Act or Peachtree Quantum in versions 2009, 2010, 2011, or 2012 then try to relink them it fails. Following the linking instructions-  Go to the peachtree tab in …
Along with being a a promotional video for my three-day Annielytics Dashboard Seminor, this Micro Tutorial is an intro to Google Analytics API data.
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now