?
Solved

Outlook 2007/2010 Keeps asking for Equifax certificate

Posted on 2010-09-06
6
Medium Priority
?
1,306 Views
Last Modified: 2012-05-10
I have installed a UCC certificate into Exchnage 2010. OWA works fine. when I use Outlook Anywhare connecting to my mail with RPC/HTTP, I keep getting a reuest to trust a certifcate and import. When I do the import it says that it was sucessfull, however the next ime I use outlook anywher the same issues happems. See JPG
1.jpg
2.jpg
0
Comment
Question by:PaulMcDonogh1
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
6 Comments
 
LVL 8

Accepted Solution

by:
pvlier earned 2000 total points
ID: 33612282
Hi, as you can see on your posted images the certificate is issued to '*.wadns.net'. When outlook connects to your server is uses the 'autodiscover''  feature to collect information about your server. The autodiscover URL is set to 'autodiscover.smms.ac.za'. This name is not on the certificate (*.wadns.net) and therefore you get an error that the certificate is found but the name is not correct.
If this is an UCC certificate then you should be able to add alternative names to the certificate. Add 'autodiscover.smms.ac.za' to your certificate, install this new certificate and the error will go away.
Otherwise here are other options for your situation (scenario 4):
http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx
0
 

Author Comment

by:PaulMcDonogh1
ID: 33957451
No luck closing
0
 
LVL 8

Expert Comment

by:pvlier
ID: 33959162
Did you understand what I posted? This is a name-on-the-certificate-problem where the name on the certificate doesn't match the domainname that it is installed on. The proof is in the screenshots.
0
 
LVL 8

Expert Comment

by:pvlier
ID: 33973424
Please let me know if the problem still exists. You have multiple options to fix this problem, depending on the server(s) configuration. You need to make sure the correct name exists on the certificate (you can have a certificate with multiple names) or redirect the autodiscover in dns to the correct server so outlook can see it needs to validate another name. Both options can fix the problem. I would go with the first option and purchase a multi-domainname-certificate (called UCC) because that is the most accepted solution for devices like phones, handhelds, etc
0

Featured Post

Need protection from advanced malware attacks?

Look no further than WatchGuard's Total Security Suite, providing defense in depth against today's most headlining attacks like Petya 2.0 and WannaCry. Keep your organization out of the news with protection from known and unknown threats.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
Since pre-biblical times, humans have sought ways to keep secrets, and share the secrets selectively.  This article explores the ways PHP can be used to hide and encrypt information.
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question