Solved

Moved Outlook 2010 to new Exchange 2010 Server via .PST - Autocomplete didn't transfer

Posted on 2010-09-06
30
1,385 Views
Last Modified: 2012-05-10
I setup a new profile in Outlook 2010 for a new exchange server. I then imported all of my email, contacts, etc. into it via a .PST file. However my Autocomplete contacts no longer work.

Apparently autocomplete is now stored in the "Suggested Contacts" section of your contacts. Looking there, all of my autocomplete contacts are present. However Outlook isn't using them. It has somehow started over from scratch with a new, blank list, which i cannot find anywhere.
0
Comment
Question by:_Ryan_
  • 10
  • 9
  • 7
  • +2
30 Comments
 
LVL 92

Expert Comment

by:John Hurst
ID: 33612727
These were stored in the .NK2 file, which is stored in various locations depending on OS. That didn't get moved so autocomplete starts from scratch. ... Thinkpads_User
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33612732
Do you have 2 suggested contacts folders?
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33612738
Outlook 2010 doesn't use NK2 files it uses suggested contacts instead and they are stored within the Exchange mailbox.
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 

Author Comment

by:_Ryan_
ID: 33612743
No, I only have 1 Suggest Contacts folder. I have no idea where it's putting the new contacts.

From my understanding the .nk2 file is no longer used. I'm still using the same Outlook 2010, so I don't think that will help.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 33612757
My bad. I moved the Outlook .NK2 file from a prior version of Outlook. ... Thinkpads_User
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33612775
Can you try going to File then options under contacts uncheck the suggested contacts option click OK then go back and then re-check it.
0
 
LVL 4

Expert Comment

by:bigg_oil
ID: 33612856
Windows XP
Go to drive:\Documents and Settings\user\Application Data\Microsoft\Outlook.

Windows Vista
Go to drive:\user\AppData\Local\Microsoft\Outlook.

find a file named profilename.nk2 copy this file to a selected location, copy this file back to the location in the new computer. Make sure that the profilename remains the same on new computer.

this folder might be hidden so youll have to change the folder options to show hidden folders

there is also a program called NK2Edit. that can help with the process.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33612876
Bigg_oil,
Please read the rest of the thread before posting.

This has already been discussed.  There is no Nk2 file with Outlook 2010
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 33612884
bigg_oil - There is no NK2 file in Outlook 2010. It was changed to Suggested Contacts. I made that mistake earlier in this thread. ... Thinkpads_User
0
 
LVL 13

Expert Comment

by:markusdamenous
ID: 33612911
http://clintboessen.blogspot.com/2010/05/how-to-import-nk2-files-into-outlook.html

Found a link that may be of use.  Talks about a command line switch for Outlook 2010 called /importnk2.
0
 

Author Comment

by:_Ryan_
ID: 33612998
Hi Everyone. NK2 files are no longer used in Outlook 2010, so that doesn't help.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 33613048
Hello _Ryan_
Take a look at the following article about installing an export add-in and then see if that may assist exporting from the prior installation:

http://www.addictivetips.com/windows-tips/office-outlook-2010-import-and-export/

I don't quite understand why the suggested contacts did not come over. .... Thinkpads_User
0
 

Author Comment

by:_Ryan_
ID: 33613073
Hi Thinkpads_User,

Thank you for the link. That's actually what I did to get all of my old email and contacts over to my new Exchange account. It seems like this must be a glitch in Outlook 2010. However I'm really surprised that no one else has run into this problem before.
0
 

Author Comment

by:_Ryan_
ID: 33613083
Demazter, I tried your suggestion, however that didn't fix it.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 33613187
The export add-in is coming from codeplex.com and is Beta 2 at this point, so it may well be a glitch. Both of my machines are now Outlook 2010 (upgraded in both cases from Outlook 2007) and the upgrade brought over my suggested contacts as part of the upgrade.

However, I have no practical way to test the Beta software as I have no other Outlook 2010 installation to bring it into. .... Thinkpads_User
0
 

Author Comment

by:_Ryan_
ID: 33613375
It seems like there should be a simple registry edit to specify the location of the contacts folder to use, or something like that.

I checked out the Microsoft KB and no solution is posted there. I did find another person online that posted this same issue and was able to get it fixed, however he didn't know what he did to fix it because he was being told what to do by a support engineer.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33613442
If you right click on Suggested Contacts and select properties what does it say the location is?

I have searched my entire registry and cannot find any reference to this.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 33613455
It does not say. Rather it just says it is part of my email (which is in the standard folder). ... Thinkpads_User
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33613478
Sure, I am trying to find out if the authors points to the old mailbox still?
Worth a shot.
0
 

Author Comment

by:_Ryan_
ID: 33613544
I checked around some more, and I found that  suggested contacts is not used to store autocomplete data. From IT Pro website:

"Outlook 2010 changes the location of the AutoComplete Cache. It’s no longer an .nk2 file but is now a hidden folder within an Exchange Mailbox or a .pst file, depending on the account type in Outlook.:

I verified this by clearing my suggested contacts. No effect on autocomplete. I then sent a new email, the address did get saved into my suggested contacts folder. However deleting that email address from Suggested Contacts had no effect on autocomplete. The address was still available. Likewise, if you delete an email from autocomplete, by click on the x to the right of the address as you type it, that doesn't remove it from suggested contacts.

So, there must be some new , hidden location within my mailbox that stores autocomplete. What jerk at Microsoft decided it would be better to hide this from us? And, why even have a Suggested Contacts folder and then not use it to control auto complete.  
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 33613563
Well, according to this post http://www.addictivetips.com/microsoft-office/nk2edit-edit-outlook-autocomplete-address-cache-file/ the nkedit tool can indeed modiy the Outlook 2010 autocomplete.

Worth a go?
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 33613568
>>>> What jerk at Microsoft decided it would be better to hide this from us?

Yes. They keep using focus groups of 2 persons with no computing knowledge what to do, and then assume all of us are morons and there is no need to provide any useful tools any more.

Sorry for the rant, but I can see client problems with this down the road. ... Thinkpads_User
0
 

Author Comment

by:_Ryan_
ID: 33613592
I tried it. I have no NK2 files on my PC, so it has nothing to open. However it seems like a program like that would be needed to backup autocomplete data in Outlook 2010.

So it seems that once you give up your NK2 file by upgrading to Outlook 2010, there is no way to backup your autocomplete after that if you are using exchange. This is particularly bad for people how are using hosted exchange. If you change from one provider to another, you have to start over from scratch.  

I did find a way to delete all autocomplete data (see below), but no way to back it up.
http://www.groovypost.com/howto/microsoft/disable-clear-outlook-2010-auto-complete-cache/ 

0
 
LVL 4

Expert Comment

by:bigg_oil
ID: 33613719
0
 

Author Comment

by:_Ryan_
ID: 33613952
I actually tried following the steps on that video, and that doesn't work either!

I was able to find an old NK2 file from a year ago, before I upgraded. I then proceeded to follow the instructions exactly as stated in the video, which are also on Microsoft's website (see link below).

The problem here is when I click Start > Run and type in  "Outlook /importnk2" i get the following error:
"Cannot start Microsoft Outlook. The command line argument is not valid...."

What in the world? How does that not work?

I also tried "outlook.exe /importnk2" which I copied and pasted from here:  
http://support.microsoft.com/kb/980542

I tried this both on my laptop (32-bit Windows 7), as well as my desktop (64-bit Windows 7).

Does anyone know, does this feature not work on the Outlook 2010 Beta? I couldn't find anything to that effect. Man, what a mess!

By the way Thinkpads, I totally agree. Microsoft products keep getting geared more and more towards newbs, to the point that now power users cannot use or support their stuff. At least before you could at least get help from a pro or find a solution online.
0
 

Author Comment

by:_Ryan_
ID: 33613961
I guess what I'll have to do is uninstall Office 2010, install Office 2007, import the NK2 file, and then re-upgrade to Office 2010. Any thoughts?
0
 
LVL 92

Accepted Solution

by:
John Hurst earned 500 total points
ID: 33613974
I would do that only if you have lost actual contacts because they were only in autocomplete and not in contacts. I take care to keep actual contacts I need and of course, these move with the Outlook PST file.

If you have all your contacts, I would just let autocomplete fix itself. It doesn't take very long before you are functioning normally.

Also, if this is a retail copy of Outlook (Office), then Microsoft supports it for a year. If a Corporate license, they still support. In this situation, I would open a case with them.

... Thinkpads_User
0
 

Author Closing Comment

by:_Ryan_
ID: 33641413
Solution was only a work around.
0
 
LVL 92

Expert Comment

by:John Hurst
ID: 33641722
Thank you, thanks for the points and for the update. .... Thinkpads_User
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now