Solved

Issue with Exchange 2010 instalation

Posted on 2010-09-06
25
1,991 Views
Last Modified: 2012-05-10
My iniital problem started with not being able to log into Exchange  either via Console or Shell. This issue is below:

VERBOSE: Connecting to Exchange.server.local

Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.

So in an attemp to uninstall and reinstall the WinRM for IIS Feature a second issue occured componding the install. I was able to uninstall the Feater WinRM fo IIS but during the reinstall process after reboot I get the following error message:

"Attempt to install WinRM IIS Extension failed with error code 0x80070057. The parameter is incorrect."

Have tried stopping several services to get this reinstalled, but to no avail.

Tried reinstalling with "Windows6.0-KB968930-x64.msu" but it replies back that this does not apply to your system.

Looking for some assistance.

Thanks!
0
Comment
Question by:LSolt
  • 16
  • 8
25 Comments
 

Author Comment

by:LSolt
ID: 33613599
To further help this along...

There is a Windows Remote Management service running. I have tried stopping and initiating Feature WinRM IIS Extension installation which fails. Also tried stopping IIS Admin and WWW services at the same time with no luck.

Interesting enough though I still get the same error message when I load the Exchange Powershell:

VERBOSE: Connecting to Exchange.Server.local

Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid.

Which means that the problem appears not to have gotten worse... I think...
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33613613
c:\exchangesetup\exchangesetup.log

please upload that file.
0
 

Author Comment

by:LSolt
ID: 33613691
Hey There!

Here is the log. Thanks!
ExchangeSetup.log
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 28

Expert Comment

by:sunnyc7
ID: 33613708
Are you trying to install Exchange 2010 in a SBS 2003 domain ?

SBS2003SRVR.DOMAIN.local

[09/06/2010 19:54:51.0109] [1] [ERROR] This computer is configured as a bridgehead server for 2 routing group connector(s) in the organization. These must be moved or deleted before Setup can continue.
---
Can you give a background to this case:
What type of domain - how many AD's.
Is this a migration or a straight installation of exchange 2010
What migration guides are you following ?

thanks
0
 

Author Comment

by:LSolt
ID: 33613728
We had an SBS2003 which we are moving away from. Installed two 2008 DC and added to the domain. Migrated DNS and DHCP successfully. The Exchange 2010 with designed to be the new home for all the users. Once installed and operational was going to move mailboxes over to it and then uninstall Exchange 2003 from SBS2003.

I have not done a DCPromo on SBS2003 yet.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33613741
Your global catalog is still on SBS 2003
What guide did you follow ?

Check this guide by demazter
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2881-Migrate-Small-Business-Server-2003-to-Exchange-2010-and-Windows-2008-R2.html

I think winRM is the least of your worries.
0
 

Author Comment

by:LSolt
ID: 33613744
LOL! That was the guide I am following.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33613746
Primary reason @ least of your worries: > these kinda migrations are not supported by microsoft.
So you have to go with some guide by someone who has done it / tested it repeatedly and was successful.

Demazter's guide is the only document that comes to my mind.

Luckily - if you click request attention / ping demazter here - he will join this thread.
http://www.experts-exchange.com/M_2355264.html

0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33613749
I'd say ping demazter. He is really really good with migrations.
And he wrote the book :)
0
 

Author Comment

by:LSolt
ID: 33613766
I could do a DCPromo on the SBS2003, but I am not sure what that will help. I left it there just to confirm some of the GPO worked.
0
 

Author Comment

by:LSolt
ID: 33613768
Appreciate that.

Thanks,
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33613773
Did you install PowerShell first ?
0
 

Author Comment

by:LSolt
ID: 33613779
yes
0
 

Author Comment

by:LSolt
ID: 33613785
The install went fine. It was getting access to the it after the install.
0
 
LVL 13

Expert Comment

by:lastlostlast
ID: 33613821
The setup logs show errors and the setup ending prematurely... If you are sure that the setup completed succussfully then have a look at http://msexchangeteam.com/archive/2010/02/04/453946.aspx for issues with EMC...

Also, apart from the EMC issue have you noticed any other issues with the new server?
0
 

Author Comment

by:LSolt
ID: 33613865
There is some concern that the Domain Administartor account has Send priviliges as BES is installed on the SBS2003 and is using Administrator to connect. That traditionally is an issue and was one of the reasons we are installing Exchange on a separate box.
0
 

Author Comment

by:LSolt
ID: 33614226
Update on where we are.

Uninstalled Powershell 2.0 and WinRM 2.0 as they were part of an optional upgrade. That removed WinRM IIS Extension Feature all together. Then reinstalled the Optional upgrade of PS 2.0 and WinRM 2.0. Install was successful.

After install WinRM IIS Extension Features was available but still would not install. Think this might be a Red Hearing as it really did not change my error message.

Second Update:

Created a new user account called ExchangeAdmin and added it to the local server administartor group. Then used the Delegate Wizard in System Manager to make ExchangeAdmin a Full Administrator. Logged into Exchange 2010 server and attempted PS launch and received the same error message trying to connect to exchange server.... Argh!
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33614253
just out of curiosity - are you using the domain admin of SBS to install Ex 2010 ?
If not - can you try that / Create an enterprise admin in SBS group and then use that to install?

0
 

Author Comment

by:LSolt
ID: 33614269
Also noticed the recommendation #2 from the post earlier:  

http://msexchangeteam.com/archive/2010/02/04/453946.aspx 

discussed a section on adding WSMan to the <globalModules>. Completed that with no change in condition.

Noted that the Module section in IIS Virtual directory of PowerShell is not opening. Stating that there is a problem with the config file. I have attached the Web.Config file which looks OK to me. But at this point I have no idea.
2. If the WSMan module entry is missing from the global modules section of the C:\Windows\System32\Inetsrv\config\ApplicationHost.config file, as follows: 

<globalModules>
           <add name="WSMan" image="C:\Windows\system32\wsmsvc.dll" />

This will result in the WSMan module displaying as a Managed module on the PowerShell virtual directory. 

To correct this, make sure that the WSMan module has been registered (but not enabled) at the Server level, and has been enabled on the PowerShell virtual directory

Open in new window

web.config
PS-Module-Error.png
0
 

Author Comment

by:LSolt
ID: 33614275
yes, I am using the Domain Administartor account for the install. Since I have not found a way to uninstall Exchange 2010 (tried but it would not get past prereqs to actually allow uninstal) nor have I found a way to manually try to reinstall the Exchange application.

Thought/hoped the use of a new Exchange Admin account would yield better results than it did...
0
 

Author Comment

by:LSolt
ID: 33614510
Have narrowed the issue down to the WinRM IIS Extensions not being installed.

After the successful uninstall during all reinstall attempts I get an error stating that the parameter is incorrect.

The error is when OCSetup executes, I have narrowed it down to this log entry:

1556: 2010-09-06 21:25:26.243 [Provider]                  About to run: 'ocsetup.exe WAS-WindowsActivationService;WAS-ProcessModel;WAS-ConfigurationAPI;IIS-WebServerRole;IIS-WebServerManagementTools;Microsoft-Windows-Web-Services-for-Management-IIS-Extension /quiet'

1556: 2010-09-06 21:25:26.330 [Provider]                  ...done. Status: 87, Message: 'The parameter is incorrect'

1556: 2010-09-06 21:25:26.330 [Provider]                  Exit code: 87

1556: 2010-09-06 21:25:26.331 [Provider]                  Skipped configuration of 'CoreOobOptionalComponent2' because install operation failed.
0
 

Accepted Solution

by:
LSolt earned 0 total points
ID: 33614639
Ran them individually now and they all completed successfully....

ocsetup.exe WAS-WindowsActivationService
ocsetup.exe WAS-ProcessModel
ocsetup.exe WAS-ConfigurationAPI
ocsetup.exe IIS-WebServerRole  
ocsetup.exe IIS-WebServerManagementTools  
ocsetup.exe Microsoft-Windows-Web-Services-for-Management-IIS-Extension  
0
 

Author Comment

by:LSolt
ID: 33614697
Making progress...

After reboot here is the error we are now getting on Powershell:

Connecting to remote server failed with the following error message : The WinRM client received an HTTP server error status (500)
0
 

Author Comment

by:LSolt
ID: 33614712
OMG!!! It is now working!!! That was ultra-painful!!!
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33614725
LSolt thanks for coming back here and providing updates. I was out for the evening and came back now.

I am glad it worked out for you.

thanks
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This process describes the steps required to Import and Export data from and to .pst files using Exchange 2010. We can use these steps to export data from a user to a .pst file, import data back to the same or a different user, or even import data t…
Find out what you should include to make the best professional email signature for your organization.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question