Solved

IIS 7.5 SFTP Windows Server not allow list command to work

Posted on 2010-09-06
2
1,888 Views
Last Modified: 2013-12-09
I have set up a SFTP Server on a Windows 2008 Standard. I can use coreftp to actually connect to the ftp site, however I don't have full functionality.

You can log into the account, it accepts the password, it goes through various command successfully however it doesn't work for the LIST command, it eventually times out.

I can see the active session in IIS so it is working. I can even create a directory within the ftp site, without seeing it. So write access is fine to the directory. It's just not allow the list command to work. I have checked to ensure the ID has full control of the directory.

Here is a view of the process.


220 Microsoft FTP Service  
AUTH SSL  
234 AUTH command ok. Expecting TLS Negotiation.  
TLSv1, cipher TLSv1/SSLv3 (AES128-SHA) - 128 bit
USER domain\user
331 Password required for domain\user.  
PASS **********  
230 User logged in.  
SYST  
215 Windows_NT  
PWD  
257 "/" is current directory.  
Keep alive off...
PWD  
257 "/" is current directory.  
PBSZ 0  
200 PBSZ command successful.  
PROT P  
200 PROT command successful.  
PASV  
227 Entering Passive Mode (69,91,140,122,19,141).  
LIST  
Connect socket #13000 to 69.91.140.122, port 5005...

Then it hangs and eventually times out.

Any Ideas?

0
Comment
Question by:gcastong
2 Comments
 
LVL 30

Accepted Solution

by:
Brad Howe earned 500 total points
Comment Utility
The issue is most likely caused by your firewall in regards to Active vs. Passive FTP Data Connections.
I would start by loging into your webserver and connecting to the FTP locally via command line. Should this connect, then a firewall most likely is causing the issue.
Next, disable your firewall on the server and try again.
 http://blogs.iis.net/jaroslad/archive/2007/09/29/windows-firewall-setup-for-microsoft-ftp-publishing-service-for-iis-7-0.aspx
Configure Passive ports for IIS 7.*
http://learn.iis.net/page.aspx/309/configuring-ftp-firewall-settings/
Cheers,
Hades666
0
 

Author Closing Comment

by:gcastong
Comment Utility
Hi there, thank you for the input, it was appreciated. The issue turned out to be a conflict with the passive ports on another SFTP Server running in the environment. We had to set the port usage to a different range, for each server, and then once that was done, NAT each seperate range back to the external facing router and all works like a charm.

Cheers
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now