Solved

2 vlans voice and data on 1 port

Posted on 2010-09-06
19
1,344 Views
Last Modified: 2012-05-10
hi, I am trying to deploy ip phones at one office. currently we have a service through a provider which services our phones and basically the computers are plugged in the back of the phones and the phones are plugged into the wall jacks. Both devices are on different vlans and this is what I am trying to accomplish as well with the new setup.
I have a Cisco 861w as my router and a cisco esw 520 poe as my switch.
I created 2 vlans on the router and want both vlans to be seen on a single switch port so that the phones will stay on one vlan and the PCs on a different one.
Does anyone have some good advice or documentation I can look to configure this for optimal performance? I understand QoS is a big factor here and will have to be configured.

Thanks
0
Comment
Question by:troubleshooter141
  • 6
  • 5
  • 4
  • +2
19 Comments
 
LVL 6

Accepted Solution

by:
wpharaon earned 250 total points
ID: 33615270
The port connecting the 861 router to the 520 switch, should be configured as trunk from both sides.
ESW 520 is a very user friendly switch, in configuration GUI, you select the port and assign the Data Vlan and the Voice Vlan for each of your access ports.
QoS configucation is not manual in 520, check Chapter 12 of the ESW 500 Administration Guide
http://www.cisco.com/en/US/docs/switches/lan/csbms/esw500/administration/guide/ESW_500_Administration_Guide.pdf
0
 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33616259
  1. QoS plays an important role where bandwidth is limited. This is usually the slowest and most congested link on your network, that is the WAN link which is usually about 50-100 times slower than your LAN links. Therefore having your queuing and classification correctly applied at the WAN interface has a much bigger affect on your voice quality.
  2. Normally, voip equipment marks the voice and data packets with proper TOS/DSCP/COS values. You need to make sure your marking and classification is consistent end-to-end throughout your network. For example if your voip device marks voice packets with TOS=3 then your WAN router must TOS=3 packets into priority queue. Your WAN service provider should do the same. So you need to mark your voice packets according to your service provider's requirements. This is sometimes ignored by network admins. You will experience the biggest delay in the WAN (congestion, long distances, slow links etc), so you have to make sure you mark your packets according to your WAN provider's requirements, otherwise you will not have any QOS on the WAN and your voice quality will greatly suffer. Having QOS in the LAN is recommended. However proper queuing becomes optional if you have plenty of bandwidth in the LAN.
The above are the most important fundamentals of QoS design. Having voice and data VLANs seperated just makes your life easier. You can deliver perfect voice quality without voice/data VLANS, but if you cannot design configure your WAN QOS correctly then your voice quality will suffer.
0
 
LVL 13

Expert Comment

by:luc_roy
ID: 33616505
QOS can complicate the situation quite a bit if you are not used to it.
I would make sure you have the network working prior to trying to implement QOS.  You need to enable or configure the following for your netork

1) Sub interfaces on the router (one for each vlan)
2) DHCP on the router for each interface (if you are using your router for DHCP)
3) VLAN's on your switch (I would use three if your router IOS supports it) 01 Admin, 20 Voice, 30 Data.
4) Configure one switchport for trunk and plug into router
5) Configure other switchports for voice and data vlans

thats it.  If the above items are new to you the I would use this template

http://articles.techrepublic.com.com/5100-10878_11-6136216.html

it will create the router config for you and it can even configure the QOS for you.
0
 
LVL 3

Author Comment

by:troubleshooter141
ID: 33617183
Thanks for your responses, they are quite helpful.
One more question:
How does the router determine what devices to put on the voice vlan and what devices to put on the data vlan?
0
 
LVL 13

Expert Comment

by:luc_roy
ID: 33617299
the host (or PC) uses the default vlan and the phones know how to look for the VOICE vlan.  If you do not have a voice vlan they will join the default vlan.  

If configured correctly the sub interfaces will guide the phones and PC's to the correct DHCP and vlans.  If you are no using DHCP on the router make sure you us an IP Helper to forward the DHCP requests to your DHCP server.  The template I posted above will help configure that.
0
 
LVL 3

Author Comment

by:troubleshooter141
ID: 33617487
thank you for the quick response...

I am not sure that I can configure subinterfaces on this router.
This is what I have configured on interface F0:

interface FastEthernet0
 switchport mode trunk
 switchport voice vlan 100
end


The router has 4 builtin switch ports and 1 WAN port. I tried configuring a subinterface for the trunking but either I don't know what I am doing or I am unable to.
Would my configuration be wrong? F0 will be the port connecting to GE1 on the esw 520 switch

Thanks
0
 
LVL 13

Expert Comment

by:luc_roy
ID: 33617519
try

interface FastEthernet0.10
     encapsulation dot1q 10
     ip address [IP] [mask]
     no shutdown
     exit

interface FastEthernet0.20
     encapsulation dot1q 20
     ip address [IP] [mask]
     no shutdown
     exit

interface FastEthernet0.30
     encapsulation dot1q 30
     ip address [IP] [mask]
     no shutdown
     exit
0
 
LVL 13

Expert Comment

by:luc_roy
ID: 33617527
the ip address needs to be the default gateway
0
 
LVL 3

Author Comment

by:troubleshooter141
ID: 33618011
It won't allow me to add a subinterface:

Summit(config)#interface FastEthernet 0.10
                         ^
% Invalid input detected at '^' marker.

Summit(config)#interface FastEthernet0.10
                         ^
% Invalid input detected at '^' marker.

Also, it won't take an ip address on an interface other than a vlan or the wan interface. Interface 0-3 will not take an ip address. Basically I created the VLANs and then added the interfaces to the specific vlan but I wasn't sure how to approach the trunk.

Summit(config-if)#ip address 10.19.1.1 255.255.255.0
% IP addresses may not be configured on L2 links FastEthernet1
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33618095
  • If you are using vlan 100, the command to put your subinterface into VLAN 100 is>
interface fastethernet 0.100
encapsulation dot1q 100
  • On the ESW520 switch, GE1 will be configured as dot1q trunk.
  • On your phone menus, there should be a setting for Voice VLAN number if your phone supports it.

0
 
LVL 13

Expert Comment

by:luc_roy
ID: 33618100
what IOS do you have?  Does it support vlan's?
0
 
LVL 3

Author Comment

by:troubleshooter141
ID: 33618170
it doesn't like FastEthernet0.100 either:

Summit(config)#int fastEthernet 0.100
                   ^
% Invalid input detected at '^' marker.

Summit(config)#int fastEthernet0.100
                   ^
% Invalid input detected at '^' marker.


The IOS is 12.4(22r)YB5
And yes it supports vlans. I have VLAN 1 and VLAN 100 configured
0
 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33618377
Try that>
int fast 0
no switchport

then try to create your int fast 0.100 etc.
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 33619122
kindly show us
show ip int br
sh int status

in case you are not able to make subinterfaces
u can make the interface as dot1q trunk and create SVI Vlan interfaces
0
 
LVL 6

Expert Comment

by:wpharaon
ID: 33619203
after reviewing your steps
go to the following:
default interface FastEthernet0
interface FastEthernet0
   switchport mode trunk
  no shut
int vlan (VLAN NUMBER)
  description (NAME)
  ip add (IP) (MASK)
int vlan (VLAN NUMBER)
  description (NAME)
  ip add (IP) (MASK)
0
 
LVL 5

Assisted Solution

by:BooSTid
BooSTid earned 250 total points
ID: 33632363
I'm 99% certain that none of the 8xx series Cisco routers allow multiple inside networks... hence not allowing subinterfaces.

This is an intended feature limitation. You don't see capability to route multiple inside networks on the same device until the 18xx.

You can make vlan's all day long, but you can't create subinterfaces to assign them to. You essentially get one interface, or one bridged interface for the wireless.
0
 
LVL 9

Expert Comment

by:Alex Bahar
ID: 33632725
Subinterfaces are supported on some of the 800 routers, but it depends on the software and hardware. So only some of the models and some of the software supports it.

I confirm that it works on 870 routers with Advanced IP Services Cisco IOS Software Image . http://www.cisco.com/en/US/prod/collateral/routers/ps380/ps6200/prod_qas0900aecd8028a982_ps380_Products_Q_and_A_Item.html
I suggest you don't get stuck with this missing feature. You do not need it, in order to provide QoS on the WAN, which is where you definitely need QoS.
You can simply use and access list to match your voice subnet ip addresses, and put that class into the priority queue. Even if you do not use seperate VLANs, you can still identify your voip traffic quite easily.
Because your router does not offer you all the advanced features available on higher end devices, I suggest you keep it simple and configure the absolute minimum to provide your qos by following the example below. If you like to fine tune everything and create seperate classes for RTP, voice control (H323 SIP etc), interactive data, bulk internet etc. You can grow the configuratioon from the following simple example.
access list 10 permit x.x.x.x x.x.x.x    ---> Match the ip addresses of your voice devices
class-map VOIP_ALL
 match access-group 10

policy-map policy1
 class VOIP_ALL
   priority XXX     ---> Put all of your voip traffic in priority queue with max size XXX kbps
 class class-default
  fair-queue   --> all other traffic goes here
 

 
0
 
LVL 13

Expert Comment

by:luc_roy
ID: 33632901
advanced IP services is not an option for that router.
0
 
LVL 3

Author Closing Comment

by:troubleshooter141
ID: 33648965
I ended up using the config I shared above. It seems to work. I didn't really have to worry about QoS on the router because the Voice service provider will be taking care of this on their router.
Thaks for all your responses they were very helpful.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
If you are thinking of adopting cloud services, or just curious as to what ‘the cloud’ can offer then the leader according to Gartner for Infrastructure as a Service (IaaS) is Amazon Web Services (AWS).  When I started using AWS I was completely new…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now