• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 341
  • Last Modified:

Remote terminal connection

Hi,

I can't get onto an Exchange\File server via remote terminal connection. The error is 'the rpc server is unavailable' I've googled a few solutions that seem to focus on one of the services going down. That's fair enough, my problem is I'm around 1,000 km away so really want a solution that avoids physical intervention. I can ping the server and remote to other network devices on the same network. Users aren't reporting issues, so my first guess is it’s an isolated service that has gone down and needs to be restarted.
0
JP53
Asked:
JP53
5 Solutions
 
Gianpiero RossiSystem AdministratorCommented:
look at the netlogon service it should be paused. (i had this issue before). To check it you have to log in in console mode.
0
 
davorinCommented:
If RPC is not working, you probably have no access also thru computer management from other computer in that network.
As you said, it could be stopped service or maybe firewall rules that blocks your access.
Can you ask some of users there to run for you some of remote access tools like team viewer quicksupport or ISL light or VNC?
0
 
Krzysztof PytkoActive Directory EngineerCommented:
Do you have ILO board on your server? If so, you can try to use it for server connection
0
When ransomware hits your clients, what do you do?

MSPs: Endpoint security isn’t enough to prevent ransomware.
As the impact and severity of crypto ransomware attacks has grown, Webroot has fought back, not just by building a next-gen endpoint solution capable of preventing ransomware attacks but also by being a thought leader.

 
jfromanskiCommented:
Have you try to Enable NetBIOS over TCP/IP or set it to Default (in Advanced TCP/IP Settings window)? The common reason of your behavior is Netbios over TCP/IP disabled.
0
 
aqtechCommented:
Go to Run --> Services.msc --> Action --> Connect to another computer --> (computer you want to remote into) --> restart Remote Procedure Call (RPC)

make sure this is on automatic
check the log on as for the service (network service)
in properties --> recovery tab and set all to restart service
0
 
JP53Author Commented:
Hi,

The following registry key change worked in the end, but thanks for the help. All good advice

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TerminalServerIgnoreRegUserConfigErrors = Dword:1
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now