• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 20760
  • Last Modified:

How to eliminate Event code 3036 warning

My Windows 7-64-bit machine is reporting an event 3036 warning each time the WSearch service is started.  Although benign, I would like to be able to fix this issue.  I have searched the internet for a solution and have come up empty handed  Here are the details:

Event type:  Application
Source:  Search
Event ID: 3036
Level:  Warning
Event Source:  Windows Search Service
Context:  Application, Systemindex catalog
Details: The object was not found. (HRESULT : 0x80041201) (0x80041201)
The content source csc://s-1-5-21-287814290-815585838-4093042447-1000 cannot be accessed

If anyone knows how to eliminate this event, please let me know.

2
msgexpert
Asked:
msgexpert
  • 8
  • 6
  • 3
  • +3
2 Solutions
 
NeuromCommented:
Try to look this: http://support.microsoft.com/kb/930010/en-us

You installed Outlook 2007 on your PC?
0
 
jcimarronCommented:
I gather this is indeed benign, the PC functions OK and you are only seeing the warning in Event Viewer.  You may have to live with these Event Viewer entries.  
0
 
SONightHawkCommented:
I've seen this before on one of my clients PC's on a jobsite - just imported it from another computer that didn't have the problem and the problem went away. Here's the registry information you need.  Copy the information below and save the text file as a whatevername.reg and import. Reboot your PC and see if you still have the problem. Will be monitoring this thread after update or postings.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\CLSID\{9E175BAF-F52A-11D8-B9A5-505054503030}]
@="Windows Search Service Office Outlook Protocol Handler"

[HKEY_CLASSES_ROOT\CLSID\{9E175BAF-F52A-11D8-B9A5-505054503030}\InprocServer32]
@=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,74,00,25,\
  00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,6d,00,73,00,\
  73,00,70,00,68,00,2e,00,64,00,6c,00,6c,00,00,00
"ThreadingModel"="Both"

[HKEY_CLASSES_ROOT\CLSID\{9E175BAF-F52A-11D8-B9A5-505054503030}\ProgID]
@="Search.MAPI2Handler.1"

[HKEY_CLASSES_ROOT\CLSID\{9E175BAF-F52A-11D8-B9A5-505054503030}\VersionIndependentProgID]
@="Search.MAPI2Handler"
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
msgexpertAuthor Commented:
Unfortunately, the solution from SONightHawk did not seem to resolve the issue.  The CLSID was not present before running the import but my application event log is showing that the search service was started at 7:05 PM and at 7:08 I got the same warning noted above.  Note also that as of this moment I have attempted to fix office 2010 as some other folks have suggested and I have purged the search index and have initiated a index reload.  I did find that within control panel/Programs and features/Turn Features on and Off, that inexecing was not enabled which accoring to the article I read was caused when I upgraded form Office 2003 to 2010 but enabling it didn't change the warning.  I still interested in a solution but again it is a benign warning so If nothing is suggested then I may have to stop worrying about it.
0
 
msgexpertAuthor Commented:
I have posts out on several forums and thought I would update this one.  Accoring to another expert, the "CSC" means client side cache and she suggested that I go into the Indexing Options in Control Panel and turn off indexing on the Offline files and this got rid of the warning.  Not sure if this is just masking the problem or providing a solution as I'm a bit vague on what offline file consist of.  I'm going to do more reasearch to find out.
0
 
jcimarronCommented:
msgexpert--If turning off Indexing of the Offline files got rid of the message, then that would seem to be the solution.  Reboot and turn Indexing back on.  Does the message come back?
If you do not allow indexing of Offline Files, your Searches within Offline files will take longer.  That is not the worst thing.
Do you, in fact, create and use Offline Files?  If not you can delete whatever is in that folder by using Disk Cleanup.

From Explorer Help
"Understanding offline files

If you've ever needed to access important files stored in a shared folder on your network but couldn't because your laptop was disconnected from the network, then you can understand the need for offline files. With offline files, you can access copies of your network files even when your computer isn't connected to the network.

Working with offline files is easy. You just choose the files (or folders) on your network that you want to make available offline. Windows automatically creates a copy of each file on your computer. These copies are called offline files. You can work with these files even when you're not connected to the network, and the next time you connect, Windows will automatically sync your offline files with the original files in the network folder.

For detailed instructions on how to use offline files, see Working with network files when you are offline."

0
 
msgexpertAuthor Commented:
I'm still a bit perplexed by the event and perhaps someone can shed more light on this.  From what I gather if you do want to work on off-line files then a copy of the file would be stored somewhere on my PC which I assume to be the C:\Windows\CSC folder and the way I had it set up before the search service was attempting to index any offline files stored in that folder.  I would also "assume" that it you have never had a need to work with offline files then the CSC folder would be empty therefore nothing to index but the warning was not that there was nothing to index the warning was that something could not be accessed.  What I'm "assuming" is that the underlying problem still exists and that it I found the real cause of the access issue then the step taken to turn off caching of offline files would be unnecessary.  So, even though I have a work around I would really still like to determine what the issue is so if anyone has any next steps I'd appreciate the help.
0
 
SONightHawkCommented:
Definitely a weird issue, no doubt.

The next thing I would do in a case like this would be to install the latest windows search, sometimes a patch from trying to fix something that MS found as a problem inadvertently breaks something else. It happens, software is software after all.

But, here's the link for the latest windows search:

http://www.microsoft.com/windows/products/winfamily/desktopsearch/choose/windowssearch4.mspx?tab=Install%20It
0
 
msgexpertAuthor Commented:
The link you proviided says its for Windows XP, VISTA and several other platforms.  My System is Windows 7 Pro and I assumed that the search waa version 4.  Is this correct or am I off base?
0
 
jcimarronCommented:
msgexpert--"the warning was that something could not be accessed.  "
Perhaps you need to change permission to access the file.  
But where did you get the idea that Offline Files are stored in C:\Windows\CSC folder ?  I do not have any Offline files but if I search for the folder I am told it (they) are in three places all accessed from Offline Files folder window.  This seems to be in C:\Users\Username\Offline Files Folder and is perhaps most easily reached by typing Offline in the Start\Search box, clicking on either of the first two icons at the top of the found items (such as Manage or Encrypt your Offline Files)|General tab and then "View your offline files".
0
 
SONightHawkCommented:
After doing a little bit more digging, ran across an issue where it could be related to a possible corrupted profile issue.

http://windows.microsoft.com/en-US/Windows7/Fix-a-corrupted-user-profile

Have you tried doing a system restore to before the problem began? Or has this problem been consistent since day 1?

Definitely intrigued and glad to help you troubleshoot the problem.
0
 
msgexpertAuthor Commented:
ICImarron:  Please refer to http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_24389397.html.  Evidently this may not be the location where off line files are stored but this is a folder that is used in the caching process.  If you also do a Google search for Windows 7 csc folder you'll also get more hits that may help explain what this folder is.
0
 
msgexpertAuthor Commented:
I have a solution but I''m not sure that I understand why things were the way they were.

To make a long story short I tried drilling down into the CSC folder and in the only subfolder in CSC I was denied access but when I looked at the security it said that there wasn't even an owner of the folder so I took ownership.  I then drilled down into that folder and found 2 more folders that had no owners either so I took ownership of those two.  Note that taking ownership was the only thing I did.  I then when back into the indexing function in control panel, turned on indexing on the off line folders restarted my system and NO Warning.  Seems that no ownership was the issue which I'm not not going to try and figure out because I won't find an answer to that anyway.
0
 
jcimarronCommented:
msgexpert--Well, I guess I got right about permissions.  :)
If you have the time see if you can find the Offline Folders folders per the procedure I suggested earlier.
0
 
jcimarronCommented:
msgexpert--I forgot to add that it is good news you have gotten rid of that message.
0
 
jcimarronCommented:
Lee Tutor--msgexpert says "Seems that no ownership was the issue " and that the warning message has gone after he took ownership of the folder and files.
I suggested he take ownership.
0
 
jcimarronCommented:
Preferred conclusion:  Accept one or more Expert posts as the answer
Justification:
In http:# 33648884 jcimarron suggested taking ownership.
In http:#33650890  OP said the warning message no longer appeared after taking ownership.

0
 
jcimarronCommented:
"Starting auto-close process to implement the recommendations of the participating Expert(s)."

Huh??
0
 
modus_operandiCommented:
Starting auto-close process to implement the recommendations of the participating Expert(s).
 
modus_operandi
EE Admin
0
 
optitechteamCommented:
I found that I also had to perform the accepted solution with taking ownership of the SCS folder data. I also had to go through the registry and delete associated SID's and indexing information that were still stored there. Once I went through the registry and deleted all corresponding SID's, one for a test account and another for an administrative account, and then rebooted all errors disappeared.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 8
  • 6
  • 3
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now