Solved

Ubuntu 34 bit Desktop Edition mounting error

Posted on 2010-09-07
40
688 Views
Last Modified: 2013-12-15
I have just done a fresh install of Ubuntu Desktop edition. But when I go to load it up I get a mounting error.

I ignore it and move on and the system boots up fine.

Why am I getting this mounting error
0
Comment
Question by:sobeservices2
  • 15
  • 10
  • 9
  • +3
40 Comments
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
What mounting error do you get, can you paste it, and we can assist.
0
 
LVL 14

Expert Comment

by:fmarzocca
Comment Utility
are you booting with an external hard drive?
0
 

Author Comment

by:sobeservices2
Comment Utility
I posted screen shot below

Ubuntu-34-bit-Desktop-Edition-20.png
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
Are you running inside a virtual machine or is this a direct install on a piece of hardware ?
0
 
LVL 18

Expert Comment

by:TobiasHolm
Comment Utility
Hi!

Can you show us your /etc/fstab ? It probably contains a line that shoud be removed!

Regards, Tobias
0
 
LVL 20

Accepted Solution

by:
woolnoir earned 250 total points
Comment Utility
If you are running this in a virtual machine check here http://ubuntuforums.org/showthread.php?t=1497219 or here if usual virtualbox http://forums.virtualbox.org/viewtopic.php?f=3&t=15868
0
 
LVL 24

Assisted Solution

by:slyong
slyong earned 167 total points
Comment Utility
Hi,

/mnt/hgfs sounds like a shared folder for virtual machine, it would be just fine to comment it out from /etc/fstab or make it manual mount instead of automount.
0
 

Author Comment

by:sobeservices2
Comment Utility
Yes I am running a virtual machine
so how would I comment it out from /etc/fstab

Don't understand automount and manual mount
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
do a cat /etc/fstab - paste us the output and we can tell you what to edit :)
0
 

Author Comment

by:sobeservices2
Comment Utility
How do I get to a termnal to run this.
I am using desktop version
0
 
LVL 20

Assisted Solution

by:woolnoir
woolnoir earned 250 total points
Comment Utility
In Gnome (Ubuntu)
The terminal can be found at Applications menu -> Accessories -> Terminal.

then cat /etc/fstab
0
 

Author Comment

by:sobeservices2
Comment Utility
administrator@ubuntu:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=3928c209-d891-478b-a5ff-df20204d2eb8 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=c5a25047-61bf-4f2e-95d4-f3c8a991881b none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
# Beginning of the block added by the VMware software
.host:/                 /mnt/hgfs               vmhgfs  defaults,ttl=5     0 0
# End of the block added by the VMware software
administrator@ubuntu:~$
0
 
LVL 18

Expert Comment

by:TobiasHolm
Comment Utility
Then in the terminal you can type:

sudo nano /etc/fstab

and edit the file. Then save with CTRL+O + Enter and exit with CTRL+X

Regards, Tobias
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Change this line:

.host:/                 /mnt/hgfs               vmhgfs  defaults,ttl=5     0 0

to

.host:/                 /mnt/hgfs               vmhgfs  defaults,noauto,ttl=5     0 0
0
 
LVL 18

Expert Comment

by:TobiasHolm
Comment Utility
Just put a # infront of the line:

.host:/                 /mnt/hgfs               vmhgfs  defaults,ttl=5     0 0

and save the fstab file.

Regards, Tobias
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
if you run a sudo pico /etc/fstab or sudo vi /etc/ftsab to edit the file

and then add a # at the start of the ' .host:/                 /mnt/hgfs               vmhgfs  defaults,ttl=5     0 0 ' line

and then save , that should solve the issue.
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
Ensure you either run the GUI editor with root privilages, or run sudo before the editor at the command line, or it wont work.
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
lol, or in the terminal... just do:

sudo sed 's/ttl=5/noauto,ttl=5/' /etc/fstab

*nix is fun!!!
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
@slyong nicely done...
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
oops.. you need in-place editing... so that command should be:

sudo sed -i 's/ttl=5/noauto,ttl=5/' /etc/fstab
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 

Author Comment

by:sobeservices2
Comment Utility
Ok alot of comments here
I open up terminal
now do I type
sudo sed -i 's/ttl=5/noauto,ttl=5/' /etc/fstab
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
yes.. and that will add the 'noauto' to the line, which will stop the error.
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
yeah sobeservices2 you can do and do a "init 6" and see if that solved your problem
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
or if you dont use the mount point at all... you can comment the line out, by editing the file and adding the #, but slyong's method is elegant :)
0
 

Author Comment

by:sobeservices2
Comment Utility
This is what I got after I type
administrator@ubuntu:~$ cat /etc/fstab

# /etc/fstab: static file system information.

#

# Use 'blkid -o value -s UUID' to print the universally unique identifier

# for a device; this may be used with UUID= as a more robust way to name

# devices that works even if disks are added and removed. See fstab(5).

#

# <file system> <mount point>   <type>  <options>       <dump>  <pass>

proc            /proc           proc    nodev,noexec,nosuid 0       0

# / was on /dev/sda1 during installation

UUID=3928c209-d891-478b-a5ff-df20204d2eb8 /               ext4    errors=remount-ro 0       1

# swap was on /dev/sda5 during installation

UUID=c5a25047-61bf-4f2e-95d4-f3c8a991881b none            swap    sw              0       0

/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

# Beginning of the block added by the VMware software

.host:/                 /mnt/hgfs               vmhgfs  defaults,ttl=5     0 0

# End of the block added by the VMware software

administrator@ubuntu:~$ sudo sed -i's/ttl=5/noauto,ttl=5/'/etc/fstab

[sudo] password for administrator: 

Usage: sed [OPTION]... {script-only-if-no-other-script} [input-file]...



  -n, --quiet, --silent

                 suppress automatic printing of pattern space

  -e script, --expression=script

                 add the script to the commands to be executed

  -f script-file, --file=script-file

                 add the contents of script-file to the commands to be executed

  --follow-symlinks

                 follow symlinks when processing in place

  -i[SUFFIX], --in-place[=SUFFIX]

                 edit files in place (makes backup if extension supplied)

  -l N, --line-length=N

                 specify the desired line-wrap length for the `l' command

  --posix

                 disable all GNU extensions.

  -r, --regexp-extended

                 use extended regular expressions in the script.

  -s, --separate

                 consider files as separate rather than as a single continuous

                 long stream.

  -u, --unbuffered

                 load minimal amounts of data from the input files and flush

                 the output buffers more often

      --help     display this help and exit

      --version  output version information and exit



If no -e, --expression, -f, or --file option is given, then the first

non-option argument is taken as the sed script to interpret.  All

remaining arguments are names of input files; if no input files are

specified, then the standard input is read.



GNU sed home page: <http://www.gnu.org/software/sed/>.

General help using GNU software: <http://www.gnu.org/gethelp/>.

administrator@ubuntu:~$ 

Open in new window

0
 

Author Comment

by:sobeservices2
Comment Utility
what is this mount mean anyway?
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
sudo sed -i 's/ttl=5/noauto,ttl=5/'/etc/fstab

notice the space needed inbetween the -i and 's
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
woo! there is a space after -i
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
and the space needed after ttl=5/' and before /etc
0
 
LVL 20

Assisted Solution

by:woolnoir
woolnoir earned 250 total points
Comment Utility
the mount is for shared space, allowing you to communicate with the host machine in a VM environment, its always buggy as hell and i tend not to use it anyways. Enable bridged or private networking and communicate as usual over IP.
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
@woolnoir agree
0
 

Author Comment

by:sobeservices2
Comment Utility
Ok cool checking this out now

I am amazed on the responses this post is getting. Will reward points soon
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
This is the busy time of day, you have the UK people at the end of the day, being lazy and trawling EE, you have some us people on lunch and some just waking up.. perfect time for solutions :)
0
 
LVL 24

Expert Comment

by:slyong
Comment Utility
Jeez... I am half way across the globe in Singapore
0
 

Author Comment

by:sobeservices2
Comment Utility
Issues it didn't work and I tried it again and getting this

administrator@ubuntu:~$ sudo sed -i 's/ttl=5/' /etc/fstab
[sudo] password for administrator:
sed: -e expression #1, char 8: unterminated `s' command
administrator@ubuntu:~$ sudo sed -i 's/ttl=5/' /etc/fstab
sed: -e expression #1, char 8: unterminated `s' command
administrator@ubuntu:~$
0
 
LVL 20

Expert Comment

by:woolnoir
Comment Utility
it needs to be

sudo sed -i 's/ttl=5/noauto,ttl=5/' /etc/fstab
0
 
LVL 24

Assisted Solution

by:slyong
slyong earned 167 total points
Comment Utility
hi sobeservices2,

I am getting a bit worried when you issue wrong commands.  The command is:

sudo sed -i 's/ttl=5/noauto,ttl=5/' /etc/fstab

but I suggest you use a GUI tool to edit it just in case a wrong command might cause some damage.
0
 
LVL 18

Assisted Solution

by:TobiasHolm
TobiasHolm earned 83 total points
Comment Utility
Maybe you should use

sudo nano /etc/fstab

and edit the file. To reduce the risk of mistyping! ;)

Then save with CTRL+O + Enter and exit with CTRL+X

Regards, Tobias
0
 
LVL 3

Expert Comment

by:ssapkota
Comment Utility
I think you need gedit here,

sudo   gedit   /etc/fstab

and convert:
.host:/                 /mnt/hgfs               vmhgfs  defaults,ttl=5     0 0
to:
.host:/                 /mnt/hgfs               vmhgfs  defaults,noauto,ttl=5     0 0

and then save and close.
0
 

Author Comment

by:sobeservices2
Comment Utility
ok
I think the solution I already awarded points to worked as well but thanks for the additional infomation.
0

Featured Post

What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

Join & Write a Comment

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
SSH (Secure Shell) - Tips and Tricks As you all know SSH(Secure Shell) is a network protocol, which we use to access/transfer files securely between two networked devices. SSH was actually designed as a replacement for insecure protocols that sen…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now