We help IT Professionals succeed at work.

How do I share an application through the Citrix web interface while also sharing the desktop?

987 Views
Last Modified: 2013-12-14
I have been assigned to share a single application through the Citrix web interface. I have done this before, but not for an existing installation of Citrix 4.5. After I configure the Web Interface and share the application I am able to connect to the web interface and see the shared application, notepad.

Problem 1 - Extra logon prompt
When I click on Notepad I am presented with a windows server logon prompt. I don't think this should be appearing considering that I already logged in with my domain credentials on the web interface.

Problem 2 - Opens shared desktop, not notepad (My shared app)
For some reason, I am presented with a desktop and not the application that I shared, notepad. Instead I am presented with the error below. I thought that is was being caused by logon scripts, but I created a test user in an OU that doesn't have any group policies running against it. I also denied access to group policies for this user for the domain policy.

Please let me know what information will be helpful to help diagnose this problem!

ICA Seamless Host Agent

You have started Windows Explorer in your ICA Seamless session. This will obscure your local Explorer desktop.

To re-enable this ICA Seamless connection, please logoff and restart the seamless remote application.

Comment
Watch Question

Problem 1: Do you get any other sort of error message before the login prompt?   I would expect that prompt when the user is not part of the remote desktop user group.

Problem 2: Are you certain you are publishing Notepad?  In w2k3 it's located at C:/windows/notepad.exe.  I have published it before as a test application and it has always worked fine.

Author

Commented:
Problem 1: I do not receive any other error message before receiving the Windows Logon Prompt. I am allowed to login and it takes me to the desktop with that error message.

Problem 2: I am certain that I am publishing notepad because it is displayed as an application after logging in through the web portal.

I double checked my group policies by running the group policy resultants wizard, and I'm showing that the default domain policy and a screen saver GPO are still being applied... even though I have this user belonging to a group that has deny read permissions for those GPO's. The frustrating thing is that deny read permission is working correctly on all of the other 10 GPO's. Why is it not working with these two? Am I chasing a dead horse with the group policies... do you even think it is related to my issue?
isn't there another checkbox in the gpo security that's "apply group policy".   without knowing better, that's what i have always used to apply or un-apply gpo's.   that being said, i have had problems with registry tatooing in regards to gpo's so i may not be the one to give out advice.  sounds like a peculiar problem, i'll be curious to know what it is.
There are a 1000 ways to skin the technology cat.
CERTIFIED EXPERT
Commented:
Unlock this solution and get a sample of our free trial.
(No credit card required)
UNLOCK SOLUTION

Author

Commented:
Nappy_d - Thank you for the link! I'm not sure how I missed that before.

I opened Terminal Services Configuration from the Admin Tools on our Citrix server and then opened the properties to ICA-tcp. I then checked the "Run initial program specified by user profile and Remote Desktop Connection or Terminal Services Client.

Well now it is on way or another. With this option selected I am not able to login to the Citrix desktop that our off site users use. I get this message.

to logon to this remote computer, you must have Terminal Server User Access permission..... (image attached)

So once I add the users to the correct group to continue having access to the desktop, problem 1 should be resolved. So what about the extra Windows Logon box that I am receiving... how do I get rid of that?
terminallogon.GIF

Author

Commented:
Oddly enough... I checked the Remote Desktop Users under the user accounts and groups and find all the people there that need to be....

I read article CTX109925 and CTX106920 and those didn't help resolve my issue. I'm sure there is some other setting tucked away that I am missing.

Author

Commented:
I ended up resolvoing the issue by sharing the desktop through Published applications.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a sample view!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.