Solved

Cannot connect to domain server

Posted on 2010-09-07
10
569 Views
Last Modified: 2012-05-10
I have set up a Windows Server 2008 R2 Foundation server and added Active Directory Domain Services role. I have tried joining the domain from a Windows 7 PC but get an error message. The domain name is fulwell.local. If I try joining this domain I get a "cannot find domain" message. If I try "fulwell" I get a log in prompt but then, after logging on I get the error in the attached file.
Does anyone know how to fix this?
Server-domain-error.JPG
0
Comment
Question by:grapey100
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
10 Comments
 
LVL 1

Expert Comment

by:lpelkie
ID: 33622016
The workstation has to be using the same DNS server as the domain controller.  When you set up AD, it created a lot of service addresses.  If your workstation doesnt use the correct DNS server, you will not be able to join the domain
0
 
LVL 5

Expert Comment

by:Anthony1982
ID: 33622031
Check the ipconfig /all of the windows 7 pc. Does it have a the proper DNS server name? Is the Windows Server 2008 R2 Foundation server you DNS server?
0
 

Author Comment

by:grapey100
ID: 33622141
My DNS Server is my router which is 192.168.1.254 and both the server and the laptop have this as the DNS. However, when I installed AD it did want me to install a DNS server. The DNS Server on the server has an error message (event ID 4015) and perhaps this is relevant?
0
The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

 
LVL 1

Expert Comment

by:lpelkie
ID: 33622189
That is what your issue is, the DNS server on the router is not able to handle the record types that AD requires.  You need to have the server run dns and have the workstations refer to it for lookups.  You can also then configure the DNS on the server to use the routers DNS as a rollup address
0
 
LVL 3

Expert Comment

by:civicryan
ID: 33622241
You have to configure IP address on your server right now point to iself and try to add DNS role again ( or assign 127.0.0.1 on Prefered DNS.)
Check this event ID infohttp://technet.microsoft.com/en-us/library/cc735674(WS.10).aspx
0
 

Author Comment

by:grapey100
ID: 33622330
lpelkie: can you explain how I do this please? Thanks
0
 
LVL 5

Expert Comment

by:Anthony1982
ID: 33622579
So I am assuming that your router is also handing out DHCP? Well I would first turn the router's DHCP/DNS off. Much simpler than trying to configure a rollup address. Then add/readd the roles of DHCP/DNS to the server and make sure to choose the option of using itself as the DNS server.
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 300 total points
ID: 33622582
Do not use 127.0.0.1 you need to use.

Go into your TCP\IP settings you should have a static IP address. Your preferred DNS server should point to the server's IP address.

Once you have done this got to command prompt run ipconfig /flushdns, ipconfig /registerdns, and dcdiag /fix.

On your router you need to change the DHCP server settings to make sure to you have it leasing IP address with the Primary DNS server pointing to the DC IP address. I would recommend setting up DHCP on your Windows server though.

Once you have done the above you will be able to add your workstations to  your domain.

0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 33622590
Do not need to readd your DNS service this has already been setup during the dcpromo process you just need to change your TCP\IP settings on your network card.
0
 
LVL 1

Assisted Solution

by:lpelkie
lpelkie earned 200 total points
ID: 33649539
Sorry for the delayed respose:

to configure rollup address:

go into dns manager
right click on the dns server and goto properties
goto the forwarders tab
click edit, and add the IP of your router (or whatever device is currently handing out your DNS)
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

691 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question