Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

disable friendly errors IIS7.5 does not work (bug?)

Posted on 2010-09-07
4
Medium Priority
?
1,257 Views
Last Modified: 2012-05-10
Just moved a site from IIS6 to IIS7.5 (w2K8 server R2) and wnated to be able to debug a bunch of old Classic ASP sites.  I followed the instructions to disable the friendly messages, but these settings have no effect.
I still always get (Internal Server Error... ) friendly messages.
I've restarted the website, the webserver, to no avail.
I've cleared caches, histories, etc on both FF36 and IE8, but it looks like a bug in IIS7.5

Any ideas?
IIS75.gif
0
Comment
Question by:bd9000
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 11

Expert Comment

by:tobzzz
ID: 33625502
You may have to enable non-friendly error messages in your browser too.
0
 

Author Comment

by:bd9000
ID: 33630900
I tried that on IE.  The error message(s) is(are) coming from the server.
This is a Classic ASP app, so no settings for DotNet have any effect.

I set the apppool to 32bit support as well - that solved the specific error, though I still would like to see ANY and ALL errors in the browser just like in Version 6 of IIS.

The following does not work for Classic ASP - not sure why this was a "solution" as this has no effect (been there, done that).
"Make sure you're in Features View (not Content View), then double-click the ASP icon. Expand "Compilation" and then "Debugging Properties".  Set the "Send Errors To Browser" to True.  Now when you browse the ASP page, you should get the underlying script error, instead of the default "An error occurred".  This will help troubleshooting efforts."

Any solutions?
0
 

Accepted Solution

by:
bd9000 earned 0 total points
ID: 33631261
I found the answer:  
You have to go to the Error Pages, then click on "Edit Feature Settings" and select one of the "Detailed errors" options.  Whew!
IIS7settingsErrorMessages.gif
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question