Microsoft Word 2007 Spellcheck fails

If I type "blapify" and spell check (F7) it suggests I capitalize it. If I type "I want to blapify you", Word reports spell check has been completed successfully. I have tried a few suggestions found here and a complete reinstall. Nothing works.
PlatteCityAsked:
Who is Participating?
 
MINDSUPERBConnect With a Mentor Commented:
PlatteCity,

The link below gives insights on how the Spell Check feature works. This might gives you a hint to solve the problem.
 
http://sbarnhill.mvps.org/WordFAQs/MasterSpellCheck.htm

Sincerely,

Ed
0
 
FlysterCommented:
Check your custom dictionary to make sure blapify wasn't accidentally added. To do that, Click the Office button - Word Options - Proofing. Select Custom Dictionaries - Edit Word List. If the word is listed there, delete it.

Flyster
0
 
PlatteCityAuthor Commented:
No, custom dictionary contains no odd words (that I didn't add).
0
 
RartemassService Desk AnalystCommented:
Also check the autocorrect options in the same Options section as above. Doubtful it is there but possible.

If that fails, highlight the entire document (ctrl+a). go to the Review tab on the ribbon. In Proofing group click Set Language.
Ensure the preferred language is selected at the top (above the line). Ensure Do not check spelling or grammar is unchecked. Click the Default button. then click OK.

Run the spell check again.
0
 
PlatteCityAuthor Commented:
I went to the site suggested, looked in the registry as suggested and I found and "override" key in shared tools under proofing. I deleted the key and now I have spell checking.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.