How do I save a document in compatibility mode?

Hi ~

I have a 2003 excel file and just recently upgraded my office suite to 2007.  When I open a 2003 network shared file in 2007 and try to save it back to 2003 version, I get the following error:
"File <xxx> is currently in use.  Try again later."

I know that I'm the only one using the file, so it isn't being locked by another user.  I don't want to save it with the 2007 version because I still have clients that still use the 2003 format.

Any ideas on how to solve this problem?
gcastongAsked:
Who is Participating?
 
patrickabConnect With a Mentor Commented:
gcastong,

>When I open a 2003 network shared file in 2007 and try to save it back to 2003 version, I get the following error:
"File <xxx> is currently in use.  Try again later."

This is such a regular question here on EE that I have a standard text on shared Excel files:

Excel does not handle 'Shared' workbooks reliably. They are often corrupted at random and apparently without cause. Clearly there is a cause but it has not yet been isolated and fixed by MS. There is nothing you can do to avoid shared workbooks corrupting. The ONLY thing that can be done is to make them single user.

To help you with the single user file system try adopting this approach instead. It does work rather well so it's worth doing. First make the file(s) single user. Second edit everyone's user profile in Excel - Tools/Options/General/UserName and in there put the person's name and telephone extension number. Then whenever you attempt to open a file that someone else is using, a dialogue box will pop-up telling you who is the current user - and it tells you their telephone extension number! The new user can opt to either call the current user or open the file as read-only.

I realise it seems odd that MS would have an unreliable feature in Excel but I'm afraid that's the way it is. If you must have simultaneous access then it would be wise to use a proper database.

For Office 2007:  Office Button > Excel Options >Popular tab >User name

Patrick
0
 
thakurdineshCommented:
You just need to change the default file save format to .doc instead of .docx

Open the Option of word 2007, click on the save, then click on the "Word 97-2003 Document .doc" from drop down save file format. apply the changes. close the word, open with any file, it wont ask you to save as xml.. same thing you can apply with excel as well..

Hope this will help you..
0
 
gbanikCommented:
Excel 2003 format = .xls
Excel 2007 format = .xlsx or .xlsm

So when u open a .xls file (2003 format) in Excel 2007 and try to save it, by default it gets saved in 2003 format itself... you dont have to explicitly save it using the 2003 format. Hence the exception, because you are trying to "SaveAs" the same file name (currently open) rather than "Save" onto itself.

In conclusion, if the file extension is .xls, whether you use Excel 2003 or Excel 2007 the saved file will be in Excel 2003 format.

... Enjoy!

0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
Patrick MatthewsConnect With a Mentor Commented:
Amplifying what my colleague Patrick has to say, it is only a small exaggeration to say that there are only two kinds of shared workbooks: those that have become corrupted, and those that soon will be :)

On a more serious note, the only use for shared workbooks that most Experts here will even tentatively endorse is to enable "track changes", but even then none of the top Experts here recommend allowing >1 user at a time into the shared workbook.

Patrick
0
 
gcastongAuthor Commented:
It was great advise and kept me informed.  I only wished that there was a solution to the problem.
0
 
patrickabCommented:
gcastong - Thanks for the grade and points - Patrick
0
All Courses

From novice to tech pro — start learning today.