Windows 2003 Server NIC help

Dell Power Edge T310
windows 2003 R2 Enterprise 64bit edition sp2

Dual network adapters

both internal Broadcom Bcm5716c net xtreme II driver dated 12/28./2009 version 5.2.17.0

 When I set the properties of the ip interface on the network adapter I set the ip address default gateway and sub mask plus DNS and Wins entries, so I set the option to manually define the problem is when I go back to check the settings via the properties the properties window show obtain ip address information and al the entries I entered have disappeared.
If I do an ip config /all all the information I setup is there even after a restart.
I checked the registry and the values are there
So why is the network adapter properties not showing I have several other windows 2003 R2 servers they are standard 32bit and they work fine network adpater driver issue?

Any ideas

thanks

Tom
InserachofAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
PakaConnect With a Mentor Commented:
Are you running NIC Teaming?  If so, you need to change the values on the Virtual NIC - not the physical NICs.
0
 
InserachofAuthor Commented:
I do not know what Nic Teaming is

I would like to use both nics on the same lan to balance the network traffic

How would I know if Windows 2003 server is using nic teaming or where can I find the virtual nics?

Thanks
0
 
h4himanshuConnect With a Mentor Commented:
Right click on the LAN connection having issue, go to 'Status' and click on 'Details..' button. Can you see correct IP addressing information there? Also, Have you tried disabling and enabling the NIC?

0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 
kaskhedikar_tusharConnect With a Mentor Commented:
Hello,

Firstly you will login with administrator account. Then assign a IP address with DNS & click ok & ok.
Then right click on Local Area Connection & select repair option & then check.

Regards,
Tushar Kaskhedikar
 
0
 
omangmehta99Connect With a Mentor Commented:
Dear Tom,

I had faced same issue in my server, its a virus infected, kindly remove virus,
also update latest os patch and antivirus engine,

Regards,

Umang Mehta
0
 
PakaConnect With a Mentor Commented:
Check your network properties.  Does it show two or three network connections?

NIC Teaming is using both NICs for fault tolerance or for 2x the throughput.  When you team the NICs, the teaming application will create a third virtual NIC that combines both NICs.  When it is teamed, you can only enter TCP properties like IP/DNS/DG on the virtual NIC.

As a last ditch effort, you can clear the registry of the TCP/IP settings using:
netsh interface ip reset reset.txt

Just make sure you have the NIC settings fully documented, because this will clean all of that data out and reset the TCP/IP settings to default.
0
 
InserachofAuthor Commented:
It only shows two network connections

So that shows me that I am not doing Nic teaming

since no virtual nic then I might have registry corruption?

Back nic driver?

Thoughts
0
 
PakaConnect With a Mentor Commented:
I would try using: "netsh interface ip reset reset.txt" - just remember to write down all of your TCP/IP settings.
0
 
PakaConnect With a Mentor Commented:
Alternatively, I would try deleting the NICs from Device Manager and rescan for new hardware.  Then, if that's unsuccessful, use the NETSH command above.
0
 
InserachofAuthor Commented:
how does it know which interface to wipe? or does it do all of them?

If I delete them from device manager shoud I try just one at a time to see if that works?

Still trying to find an up to date driver for these nics
0
 
InserachofAuthor Commented:
Ok nothing is working

I have diabled both nics ethen enabled them no change

I have disconnected the cable from both tried to define them no change

I have deleted them both from device manager and rescaned and they added no change

Temp I set up a dhcp reservation so they get the same ip address for my setup stage

I eed to get this resolved  no sure what is wrong may be a daul nic issue

Thanks

Tom
0
 
PakaConnect With a Mentor Commented:
Have you tried the "netsh interface ip reset reset.txt" command?
0
 
InserachofAuthor Commented:
yes i did same results

I read this somewhere

Hi Guys,

I have experienced the above said problem . The solution was to update the tcpip.sys file.

This behavior is specific to the tcpip stack .

 

please use the below registry and check the behavior

on the affected PC, please delete the config key and restart the client

the config key will repopulate the next time.

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network \ config



talking about tcpip.sys and broadcom not sure
0
 
InserachofAuthor Commented:
I got it I found this article and it resolved the issue

http://support.microsoft.com/kb/937056
0
 
InserachofAuthor Commented:
resolved by myself found likn that helped look at my last posting
0
All Courses

From novice to tech pro — start learning today.