Solved

Exchange 2010 - Out of office (OOF) - Your out of office settings cannot be displayed, because the server is currently unavailable

Posted on 2010-09-07
25
10,296 Views
Last Modified: 2012-05-10
Hey guys!
I know that this is a topic that has been covered in several places but none of the fixes seems to apply to me.

Basically, when my client attempts to use the Out of Office assistant, they get an error message:
"Your out of office settings cannot be displayed, because the server is currently unavailable"

Facts:

Server is a 2008 R2 Enterprise Server running Microsoft Exchange 2010 SP1
Client's are running Microsoft Outlook 2007

Running the Test E-mail auto configuration:

It only works if I have Guesssmart ticked, otherwise I get an error message "Autoconfiguration was unable to determine your settings!"

Result are as follow:

Autoconfiguration has started, this may take up to a minute
Autoconfiguration found the following settings:

Protocol: SMTP
server: contoso.com
port: 25
Login name: administrator
TLS: Yes

Their mx is mail.contoso.com

Looking at the logs, there's one sentence that says:

Attempting URL https://server.contoso.com/Autodiscover/Autodiscover.xml found through SCP
Autodiscover to https://server.contoso.com/Autodiscover/Autodiscover.xml starting
Autodiscover request completed with status code 500
Autodiscover to https://server.contoso.com/Autodiscover/Autodiscover.xml FAILED (0x80004005)


If I access the path given (https://server.contoso.com/Autodiscover/Autodiscover.xml)

it asked me for an authentication. After authenticating it brought the XML okay

<?xml version="1.0" encoding="utf-8" ?>
- <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
- <Response>
- <Error Time="13:42:02.2958897" Id="3941439326">
  <ErrorCode>600</ErrorCode>
  <Message>Invalid Request</Message>
  <DebugData />
  </Error>
  </Response>
  </Autodiscover>


If i access https://server/Autodiscover/Autodiscover.xml (without the contoso.com) it access it without asking for authentication

If I change the autodiscover path to https://server/autodiscover/autodiscover.xml it still doesn't work

I tried to set the OOF on OWA but it doesn't work... when I try to save the "automatic replies" page, I get an error message: "Sorry! We're having trouble processing your request right now. Please try again in a few minutes" -> i don't know if it's related

Any clues?

Thanks
0
Comment
Question by:Black-Knight
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 9
  • 2
  • +3
25 Comments
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 33624085
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33624316
OOF not working

Please check the following steps mentioned below:-

Autodiscover = Basic + Windows Integrated + SSL Forced == Disable - Kernel Mode Authentication.
OAB= Windows Integrated = Disable - Kernel Mode Authentication.
EWS= Windows Integrated = Disable - Kernel Mode Authentication + SSL forced.

Follow the kb-940726, and run the following command on the server.

Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUri https://mail.contoso.com/autodiscover/autodiscover.xml 

Set-WebServicesVirtualDirectory -Identity "CAS_Server_Name\EWS (Default Web Site)" -InternalUrl https://mail.contoso.com/ews/exchange.asmx

Set-OABVirtualDirectory -Identity "CAS_Server_name\oab (Default Web Site)" -InternalUrl https://mail.contoso.com/oab

Please run the following command in the management shell:-

test-outlookWebserivces | fl and see the result. If you get 401 Unauthorized please follow the below link and restart the server.

DisableLoopbackcheck registry.
key as per the article <http://support.microsoft.com/kb/896861>.


Then perform "SetSPN -a http/(Exchange server FQDN) (Exchange server name)"

Check the HTTP keep alive in IIS 7 in the following place:-
HTTP response headers on Default WebSite == set common headers.

If still the issue persists, please follow this steps:-

Delete and recreate the Autodiscover/ EWS Virtual Directories.
Remove-AutodiscoverVirtualDirectory -identity "CAS server name\Autodiscover (Default Web Site)"
Remove-WebservicesVirtualDirectory -identity "CAS server name\EWS (Default Web Site)"

new-AutodiscoverVirtualDirectory
new-WebservicesVirtualDirectory
And follow the kb-940726 again to set the InternalUri.
Perform IISreset.

And also please check whether you have 3.5 .netFramework, if yes please download and install the following hotfix.
KB- 958934

And Run Test EmailAutoconfiguration  from outlook 2007 client, and please select only Autodiscover. Remove Guessmart and Secure Guess mart.

Please check out these steps and revert back if the issue persists.

Thanks,
Mohammed:)
0
 

Author Comment

by:Black-Knight
ID: 33624338
Thanks for your reply.

I have already checked the path to my virtual directory, its correct
Certificates are fine
Anonymous is disabled on EWS directory
Tried with several different accounts, same deal
I'm connected using TCP/IP

When performing the e-mail autoconfiguration test, it does not return with an OOF URL, it only returns with protocol, server, port, login name and TLS

But see, although I can access the autodiscover webpage, the Outlook doesn't seem to be able to do so, it comes up with an "Autodiscover to https://server.contoso.com/Autodiscover/Autodiscover.xml FAILED (0x80004005)" error

I've already checked the path, and even Re-added the path by using the command

"Set-ClientAccessServer -Identity SERVER -AutoDiscoverServiceInternalUri https://server.contoso.local/Autodiscover/Autodiscover.xml" and didn't solve the problem


Any ideas?
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 9

Accepted Solution

by:
v_9mhdrf earned 500 total points
ID: 33624343
Please delete and recreate the Virtual directories again and follow the link below.

Delete and recreate the Autodiscover/ EWS Virtual Directories.
Remove-AutodiscoverVirtualDirectory -identity "CAS server name\Autodiscover (Default Web Site)"
Remove-WebservicesVirtualDirectory -identity "CAS server name\EWS (Default Web Site)"

new-AutodiscoverVirtualDirectory
new-WebservicesVirtualDirectory
And follow the kb-940726 again to set the InternalUri.
Perform IISreset.

And also please check whether you have 3.5 .netFramework, if yes please download and install the following hotfix.
KB- 958934
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33624351
Please try this link as well.

http://technet.microsoft.com/en-us/library/bb201695.aspx

And also please verify whether we are using any proxy settings on the Exchange server's IE.
Please return with Test-OutlookWebServices | Fl report so that we can work on the issue.
0
 

Author Comment

by:Black-Knight
ID: 33624368
Will try that. But for the time being, I have just performed a Test-OutlookWebServices | FL and here's the outcome:

[PS] C:\Windows\system32>Test-OutlookWebServices | Fl
WARNING: An unexpected error has occurred and a Watson dump is being generated: Failed to find the mailbox. Mailbox =
'extest_63fcae6c4cb74@thorntons.net.au'.
Failed to find the mailbox. Mailbox = 'extest_63fcae6c4cb74@thorntons.net.au'.
    + CategoryInfo          : NotSpecified: (:) [Test-OutlookWebServices], MailboxNotFoundException
    + FullyQualifiedErrorId : Microsoft.Exchange.Monitoring.MailboxNotFoundException,Microsoft.Exchange.Management.Sys
   temConfigurationTasks.TestOutlookWebServicesTask
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33624373
please check whether you have 3.5 .netFramework, if yes please download and install the following hotfix.
KB- 958934

It is an issue with asmx file. Please install the above mentioned hotfix.
0
 

Author Comment

by:Black-Knight
ID: 33624387
I Had 3.5 .net, now I have the 4.0

The hotfix is not available for direct download, ive submitted a hotfix request, hopefully I should be getting that soon

I'll have to do the virtual directory re-creation some other day as last night's backup failed... once I have a full system backup (hopefully after tonight) I'll try that :-)

Other than that, any other suggestions?

Thanks
0
 

Author Comment

by:Black-Knight
ID: 33624418
I noticed that the default web site on IIS has a question mark on top, could that be related?
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33624434
Are you using SBS server?
Please check the ports on Default Web site. and the above mentioned steps to troubleshoot the issue is quite enough to get rid of the problem.
So please run the hotfix and also please try to delete and recreate the Directories which will probably help you.
Make sure that you have SSL enabled on EWS virtual directory as well.
0
 

Author Comment

by:Black-Knight
ID: 33624459
Ok, Ive just applied hotfix mentioned above (which is no longer KB- 958934, it's now KB976814) and it's coming up as "the update is not applicable to your computer". Probably because i now run .net framework 4.0 instead of 3.5

Any ideas?
0
 

Author Comment

by:Black-Knight
ID: 33624468
No, it's not an SBS, it's a 2008 Enterprise R2 as mentioned in the description... running Exchange 2010

Hotfix does not apply to my case

Ill check the SSL and let you know in a second...
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33624477
ok.
The hotfix is for 3.5 and above versions of .net framework.
0
 

Author Comment

by:Black-Knight
ID: 33624487
Current binding on default website are as follow:

https |  | 443 | 127.0.0.1 |  |
http   |  | 80   | 127.0.0.1 |  |
msmq.formatname  |  |  |  |  localhost
net.msmq  |  |  |  |  localhost
net.pipe  |  |  |  |  *
net.tcp  |  |  |  |  808:*
http | mail.contoso.com | 80 | * |
http | * | 80 | *
https |  |  443 | *
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33624488
It is applicable for both Exchange 2007 and 2010.
0
 

Author Comment

by:Black-Knight
ID: 33624495
yeah, i tried the hotfix, I called MS to get it... but it doesn't install telling me it doesnt apply...

SSL is on
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33624508
Alright then i would go for delete and recreating the Virtual directories and set the InternalUri now, and check for appropriate Authentication settings and Certificate accordingly.
Please try this and revert back if still you face the issue.

Thanks.
0
 

Author Comment

by:Black-Knight
ID: 33624533
Will try that tomorrow then when I have a good backup. Thanks
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33628074
try this again
Test-OutlookWebServices -Identity:cbond@domain.com | fl

Also
start > run > appwiz.cpl

Check windows updates installed.
See if this kb is installed
KB948609

If it is there - uninstall it.
0
 
LVL 7

Expert Comment

by:GridLock137
ID: 33630684
from the exchange shell run the following command to see where your URLs are pointing:

Get-WebServicesVirtualDirectory | fl identity,internalurl,externalurl

yo should see your externalURL and internalURL and where they point to, for example:

webmail.servername.com/EWX/exchange.asmx

i had the same problem, i also ran the follwoing command to fix it:

http://technet.microsoft.com/en-us/library/bb201695.aspx

now this was happening to users connecting from home via VPN, i tested it on two of my machines from home. the machine that was not a domain member was having the problem but the laptop that is a domain member was not. after futher testing i figured out that if the machine is not a domain member it is not going to be able to see OOA due to the nature of how it's communicating with Exchange 2010, which is in an on-line sort of more for lack of a better way of saying it. hope this helps.

0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33630794
0
 
LVL 7

Expert Comment

by:GridLock137
ID: 33631684
i don't know if SP2 will do it. he can try but i think this is more a communication issue between client and server.
0
 

Author Comment

by:Black-Knight
ID: 33633562
Hi guys. I attempted heaps of things, and I fixed a lot of autodiscovery paths that were not correct, as well as binding on IIS... did fix a few things but didn't fix the issue. So i end up following v_9mhdrf's procedure: remove the virtual directories and recreate.

and worked like a charm!!!

I didn't want to do that before just in case if anything went south... but now that i had a good backup, i went through and it's all good.

Thanks mate
0
 
LVL 9

Expert Comment

by:v_9mhdrf
ID: 33633627
You welcome Sir!
Its My pleasure!!!
0
 
LVL 1

Expert Comment

by:nsitsupport
ID: 37504624
I just fixed it, i just edit site binding on the IIS port 443 - SSL Certificate - I have chaged to Microsoft Exchange.

Its working fine now.

Cheers.

0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
Changing a few Outlook Options can help keep you organized!
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question