Link to home
Start Free TrialLog in
Avatar of John-Michael_Davis

asked on

Windows losing program focus and interupting typing in all applications

Recently my new HP laptop has started missing key strokes and I have also noticed that it seems to be losing application focus when it happens. I have attached a quick MP4 video where you can see the focus loss and typing interruption in Notepad ++ at 19 and 29 seconds. it is happening enough to be incredibly irritating. During this question it must have happened more than 10 times.

Any Ideas would be greatly appreciated as this is killing my productivity.
Avatar of rockiroads
Flag of United States of America image

no mp4 vid found but don't worry. it sounds like you might have some background process. Do you have any other windows open?

Perhaps it might be wise to perform your security checks - use something like malwarebytes for spyware checks unless you have your own already plus a antivirus scan

I would then check your startups (running hijack this as this point might help also), you can use a tool like CCleaner to examine the startups or msconfig

Run task manager, look at the processes. Look in particular for anything taking more memory or cpu, it might give you a clue.
Avatar of John-Michael_Davis



I uploaded to

seems it looked inside my zip and since MP4's are not approved file formats yet.

running a full Microsoft security essentials scan now. when that is finished I will run hijack this.
I see you had jng.exe so googled it and looks dodgy. are you familar with it?
let me find out more about it
used to have a game called jets and guns, its not that though right?
see this tool, is there a setting which states stop application from stealing focus? there should to be one in tweakui, this is the closest Ive seen for win7
did you mean the Jing process? that is for Jing, it is the tool I used to capture the screen from techsmith. it is legit.

I tried that Tweak UI utility and it doesn't seem to have the option for stealing focus :(
here is the Hijack this log.

I gave it a quick preview and nothing jumped out at me but I am admittedly not an expert on this subject.
u got a lot of stuff running. how about running with minimal apps running to help identify what might be stealing focus
interesting reading here, your not the only one by the looks of things
try the control panel fix
If it is laptop, could it be possible that you accidentaly touch mouse pad?
If you leave notebook intact, does focus changes? If so, try to disable mouse pad(should be on one of Fn keys).

From a clean start working up I have narrowed it down to being likely one of the following

C:\Program Files (x86)\TechSmith\Jing\Jing.exe
C:\Program Files (x86)\Hp\Digital Imaging\bin\hpqtra08.exe
C:\Program Files (x86)\Hp\HP Software Update\hpwuschd2.exe
C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2-ui.exe
C:\Program Files (x86)\HP\Digital Imaging\bin\hpqSTE08.exe
C:\Program Files (x86)\HP\Digital Imaging\bin\hpqbam08.exe
C:\Program Files (x86)\HP\Digital Imaging\bin\hpqgpc01.exe

since I use Jing and Hamachi on multiple machines with no issue I doubt it is them, However I run the same printer on my home machine without issue so I'm not sure why it would be the printer either.

To Malajlo: yes it is a laptop but it was happening on the laptop keypad as well as a Logitech USB keyboard I use at the office as well.

It would appear that I was unchecked by default. I was so hopeful when they were talking about this only seeming to affect home premium since my home PC (With very similar software set) is ultimate and this laptop is home premium.

it does appear to have stopped for now with the paired down boot set. I appreciate the heads up, I always forget to trim down the crap with MSConfig.
You are using a mouse or the actual Touch Pad of the laptop

If mouse then disregard this.

If Touch Pad, Update to the latest driver (synoptics) and have a look if it still happens.

Also try turning the Touch pad off while you type to see if it has any effects on the loss of focus.
So it seems you had some process, perhaps put in your startups back one by one to determine what is at fault.
this is where ccleaner comes in handy, you can disable startups rather than removing them.
Alrighty the issue has returned and with fewer things running I could clearly identify the process.

wermgr.exe appears to be the culprit.

Any ideas on how to stop this or what might be triggering it??
Avatar of John-Michael_Davis

Link to home
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
interesting, hopefully this does the trick for you.