Solved

Windows losing program focus and interupting typing in all applications

Posted on 2010-09-07
17
1,669 Views
Last Modified: 2013-11-29
Recently my new HP laptop has started missing key strokes and I have also noticed that it seems to be losing application focus when it happens. I have attached a quick MP4 video where you can see the focus loss and typing interruption in Notepad ++ at 19 and 29 seconds. it is happening enough to be incredibly irritating. During this question it must have happened more than 10 times.

Any Ideas would be greatly appreciated as this is killing my productivity.
0
Comment
Question by:John-Michael_Davis
17 Comments
 
LVL 65

Expert Comment

by:rockiroads
ID: 33624126
no mp4 vid found but don't worry. it sounds like you might have some background process. Do you have any other windows open?

Perhaps it might be wise to perform your security checks - use something like malwarebytes for spyware checks unless you have your own already plus a antivirus scan

I would then check your startups (running hijack this as this point might help also), you can use a tool like CCleaner to examine the startups or msconfig

Run task manager, look at the processes. Look in particular for anything taking more memory or cpu, it might give you a clue.
0
 
LVL 1

Author Comment

by:John-Michael_Davis
ID: 33624174
Poop,

I uploaded to screencast.com
http://www.screencast.com/t/YzU0ZmNiYj

seems it looked inside my zip and since MP4's are not approved file formats yet.

running a full Microsoft security essentials scan now. when that is finished I will run hijack this.
0
 
LVL 65

Expert Comment

by:rockiroads
ID: 33624198
I see you had jng.exe so googled it and looks dodgy. are you familar with it? http://www.prevx.com/filenames/2447774850331234717-X1/JNG.EXE.html
let me find out more about it
0
 
LVL 65

Expert Comment

by:rockiroads
ID: 33624206
used to have a game called jets and guns, its not that though right?
0
 
LVL 65

Expert Comment

by:rockiroads
ID: 33624306
see this tool, is there a setting which states stop application from stealing focus? there should to be one in tweakui, this is the closest Ive seen for win7 http://www.thewindowsclub.com/ultimate-windows-tweaker-v2-a-tweak-ui-for-windows-7-vista
0
 
LVL 1

Author Comment

by:John-Michael_Davis
ID: 33624406
did you mean the Jing process? that is for Jing, it is the tool I used to capture the screen from techsmith. it is legit.

I tried that Tweak UI utility and it doesn't seem to have the option for stealing focus :(
0
 
LVL 1

Author Comment

by:John-Michael_Davis
ID: 33624441
here is the Hijack this log.

I gave it a quick preview and nothing jumped out at me but I am admittedly not an expert on this subject.
hijackthis.log
0
 
LVL 65

Expert Comment

by:rockiroads
ID: 33624525
u got a lot of stuff running. how about running with minimal apps running to help identify what might be stealing focus
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 65

Expert Comment

by:rockiroads
ID: 33624536
interesting reading here, your not the only one by the looks of things http://social.answers.microsoft.com/Forums/en-US/w7desktop/thread/4ee5be7d-31ef-493b-b092-f6f6139f99cd
try the control panel fix
0
 
LVL 4

Expert Comment

by:Malajlo
ID: 33624840
If it is laptop, could it be possible that you accidentaly touch mouse pad?
If you leave notebook intact, does focus changes? If so, try to disable mouse pad(should be on one of Fn keys).
0
 
LVL 1

Author Comment

by:John-Michael_Davis
ID: 33624937
Alrighty,

From a clean start working up I have narrowed it down to being likely one of the following

C:\Program Files (x86)\TechSmith\Jing\Jing.exe
C:\Program Files (x86)\Hp\Digital Imaging\bin\hpqtra08.exe
C:\Program Files (x86)\Hp\HP Software Update\hpwuschd2.exe
C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2-ui.exe
C:\Program Files (x86)\HP\Digital Imaging\bin\hpqSTE08.exe
C:\Program Files (x86)\HP\Digital Imaging\bin\hpqbam08.exe
C:\Program Files (x86)\HP\Digital Imaging\bin\hpqgpc01.exe

since I use Jing and Hamachi on multiple machines with no issue I doubt it is them, However I run the same printer on my home machine without issue so I'm not sure why it would be the printer either.

To Malajlo: yes it is a laptop but it was happening on the laptop keypad as well as a Logitech USB keyboard I use at the office as well.
0
 
LVL 1

Author Comment

by:John-Michael_Davis
ID: 33624975
rockiroads,

It would appear that I was unchecked by default. I was so hopeful when they were talking about this only seeming to affect home premium since my home PC (With very similar software set) is ultimate and this laptop is home premium.

it does appear to have stopped for now with the paired down boot set. I appreciate the heads up, I always forget to trim down the crap with MSConfig.
0
 
LVL 3

Expert Comment

by:thetime
ID: 33625063
You are using a mouse or the actual Touch Pad of the laptop

If mouse then disregard this.

If Touch Pad, Update to the latest driver (synoptics) and have a look if it still happens.

Also try turning the Touch pad off while you type to see if it has any effects on the loss of focus.
0
 
LVL 65

Expert Comment

by:rockiroads
ID: 33627983
So it seems you had some process, perhaps put in your startups back one by one to determine what is at fault.
this is where ccleaner comes in handy, you can disable startups rather than removing them.
0
 
LVL 1

Author Comment

by:John-Michael_Davis
ID: 33634145
Alrighty the issue has returned and with fewer things running I could clearly identify the process.

http://www.screencast.com/t/NGFiZmEzYmYt

wermgr.exe appears to be the culprit.

Any ideas on how to stop this or what might be triggering it??
0
 
LVL 1

Accepted Solution

by:
John-Michael_Davis earned 0 total points
ID: 33634209
Well I may have fixed it, though I thought that previously as well.

I followed the steps to disable automatic error reporting from the following thread and so far so good. I'm wondering if I stumbled upon some weird error reporting loop?

http://www.windowsreference.com/windows-vista/windows-problem-reporting-wermgrexe-can-cause-performance-network-issues/
0
 
LVL 65

Expert Comment

by:rockiroads
ID: 33639805
interesting, hopefully this does the trick for you.
0

Featured Post

Want to promote your upcoming event?

Attending an event? Speaking at a conference? Or exhibiting at a tradeshow? Easily inform your contacts by using a promotional banner in your email signature. This will ensure your organization’s most important contacts are in the know.

Join & Write a Comment

Several part series to implement Internet Explorer 11 Enterprise Mode
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now