• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 528
  • Last Modified:

Exclude gem version in update

Hi,

I want to do a full 'gem update' on my system, as there is a log of outdated gems.. but I don't want the rails 3 gem.
Can I exclude rails3 somewhere or somehow?

Andrew
0
Andrew Doades
Asked:
Andrew Doades
1 Solution
 
JESiiCommented:
I don't believe there's an option for gem update to exclude certain gems.  

However, you can put more than one gem on the 'gem update' command line (i.e., sudo gem update money rack rake rspec will update those four gems - sudo is if you're on Mac or Linux systems; not needed on windows).
0
 
Andrew DoadesIT TechnicianAuthor Commented:
I'll have to specify which gems to manually update
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now