• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 488
  • Last Modified:

Exchange 2010 not sending out mail

ok, the environ is a Windows Server 2003 Active Directory Domain.  I have one Exchange 2003 box in the building.  I just added a Server 2008 with Exchange 2010 server and I got it up and playing nicely with the Exchange 2003 box.  During the install, it created a connector and seemed to set up the mail flow nicely.  When I log into the new exchange 2010 server, I see all of my users and their mailboxes.  Of course, their mailboxes are in the exchange 2003 server's database.

I created a local move request for one mailbox and moved it from the 2003 DB to the 2010 DB and it moved fine.  I even changed my outlook to point to the new server and my exchange mailbox is opening fine off the new server.

the problem is I can't send mail from the new mail server, from the one mailbox I moved over.  I feel like I'm missing something but I don't know what.

ideas?  Do I need to go to me exchange 2003 box and add the IP of the new exchange server so that it can send out?  I'm unsure where to start...
0
crp0499
Asked:
crp0499
  • 9
  • 8
  • 4
  • +1
1 Solution
 
Dave StringfellowIT managerCommented:
Go to the new server, under Organization, click Hub Transport, Send connectors, and create a new send connector. You can add either the new server, or Old server depending how you want mail to go out.

Hope this helps :)
0
 
CompanionCubeCommented:
Exchange 2010 transport servers require Send connectors to deliver messages to the next hop on the way to their destination. A Send connector controls outbound connections from the sending server to the receiving server or destination e-mail system. By default, no explicit Send connectors are created when the Hub Transport server role or the Edge Transport server role is installed

http://technet.microsoft.com/en-us/library/aa998662.aspx
0
 
Firmin FrederickSenior IT ConsultantCommented:
Exchange 2010 and (2007) no longer use smtp by default as Microsoft has opted to require a separate box with the role of  "transport" for security reasons.

However you can set up a send connector and if necessary a receive connector that will allow your 2007 exchange to send mail.

Alternatively you can get your 2007 to use your 2003 server as a smart host and forward your mail through it.

Once you have gone through the wizard for the send connector you can return to it to make changes including the DNS of your 2003 box and your ISP DNS.

I'm not going to rant for too much I will wait to see how you get on or if you need more info.

send-connector.jpg
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Firmin FrederickSenior IT ConsultantCommented:
Wow simultaneous answers!
0
 
crp0499CEOAuthor Commented:
added that connector...still no mail going out...
0
 
crp0499CEOAuthor Commented:
all messages sitting in the queue...not going out
0
 
Dave StringfellowIT managerCommented:
What have you set as the Source server? 2003 or 2010? does this have access to the outside world on port 25? Are you using a smart host?
0
 
crp0499CEOAuthor Commented:
source server? does have port 25 access, no smart host
0
 
Dave StringfellowIT managerCommented:
on the last tab of the send connector, you need to specify a sourse server (Exchange2003 or Exchange 2010 for example based on NETBIOS names)
0
 
CompanionCubeCommented:
please also ensure your DNS settings are set so that the Exchange server can resolve external addresses
to test: nslookup <domain> example: nslookup google.com
0
 
crp0499CEOAuthor Commented:
eventually, i only want this server to be my only server
0
 
Firmin FrederickSenior IT ConsultantCommented:
sorry to nbe a pain crp499 but I know where the guys are leading with the questions, would it be possible to get a scren dump of your connector settings? I'll show you mine...so to speak
0
 
Dave StringfellowIT managerCommented:
You can swap the source server at any point, I would just send it via the new server which should just send emails.. at the momment the new server dosnt know what to do with the mail.
0
 
crp0499CEOAuthor Commented:
ok, my source server is my new server, exchange2 to be exact.  I went into nslookup and I can lookup domain names based on IP and vice versa.  if i interpret that information correctly, it appears as though this server is setup to send outbound mail.  I've set up four other exchange 2010 servers successfully, but this is the first with an existing 2003 server in the mix.
0
 
Firmin FrederickSenior IT ConsultantCommented:
0
 
crp0499CEOAuthor Commented:
screen caps of connector settings
screen1.jpg
screen2.jpg
screen3.jpg
screen4.jpg
0
 
Firmin FrederickSenior IT ConsultantCommented:
silly me - what IP address is SMTP set to on your router?  It may be set to your old email server (2003 box)...
0
 
Firmin FrederickSenior IT ConsultantCommented:
and thanks for the screenshots they look correct
0
 
crp0499CEOAuthor Commented:
that's the thing I thought of...but my router outbound is wide open.  it's only my inbound that is set to my old mail server.  i should at least be able to get mail out of the building.
0
 
CompanionCubeCommented:
Probably done, but ensure your transport service is started?
0
 
crp0499CEOAuthor Commented:
i had two rules wriiten.  between the two rules, only ONE ip could send out on 25.  once I opened up the other IP, my mail flowed like mad!
0
 
Firmin FrederickSenior IT ConsultantCommented:
yea unfortunately there are a number of little things that need to be confirmed and double checked to ensure 2007 can send and receive mail it is very frustrating to have to do it without hands on :(  yea after ou've checked mail transport service have a look at your local firewall settings you may have to put an exceptoion for port 25 smtp in your firewall rules.

....it may already be there!

there is also the point of ensuring the dns lookup for resolving mx records is correct and may require you to include your ISP's DNS for accuracy and speed - it may not be enough to just have your router or DNS server's ip address in your connector settings.

In that case you may very well need to have those DNS settings in the 2008 server's LAN dns settings.

  I know I've left something out but we are narrowing it down!
0
 
Firmin FrederickSenior IT ConsultantCommented:
and then there are the tools in the exchange admininstrator console like the mail flow tools give those a qucik spin
0
 
Firmin FrederickSenior IT ConsultantCommented:
I'm happily assuming you managed to resolve the issue? In which case thank you for the points.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 9
  • 8
  • 4
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now