Solved

Exchange 2010, Out of Office Wizzard not working

Posted on 2010-09-08
9
1,428 Views
Last Modified: 2012-05-10
Hello,

I have a Windows 2008 std 64bit server with Exchange 2010 installed on it.

I have clients connecting with Windows xp and Windows 7 machines with Outlook 2003 and 2007.

When we try to start the Out of Office wizzard on a Outlook client we get a error: "Settings for out of office can't be displayed because the server is currently unavailible". I can post a screenshot but it is in Dutch.

We have tryed a solution that we found on the forums to recreate the EWS but that is without result.

We can put in a out of office trough OWA but not all users have OWA access.

I hope you can help me.

Kind Regards,

Wesley van Roekel
0
Comment
Question by:tinus67
9 Comments
 
LVL 6

Accepted Solution

by:
SHIELD1 earned 167 total points
ID: 33627749
Are your Outlook clients using "cached mode"? Sometimes outlook rules and settings fail to propagate because the client is either in or not in cached mode.  Try changing which mode your clients are using to connect.
0
 
LVL 28

Assisted Solution

by:sunnyc7
sunnyc7 earned 167 total points
ID: 33628917
hi wesley

get-webservicesvirtualdirectory | fl

post back

thanks
0
 
LVL 9

Assisted Solution

by:v_9mhdrf
v_9mhdrf earned 166 total points
ID: 33633127
OOF not working

Please check the following steps mentioned below:-

Autodiscover = Basic + Windows Integrated + SSL Forced == Disable - Kernel Mode Authentication.
OAB= Windows Integrated = Disable - Kernel Mode Authentication.
EWS= Windows Integrated = Disable - Kernel Mode Authentication + SSL forced.

Follow the kb-940726, and run the following command on the server.

Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUri https://mail.contoso.com/autodiscover/autodiscover.xml 

Set-WebServicesVirtualDirectory -Identity "CAS_Server_Name\EWS (Default Web Site)" -InternalUrl https://mail.contoso.com/ews/exchange.asmx

Set-OABVirtualDirectory -Identity "CAS_Server_name\oab (Default Web Site)" -InternalUrl https://mail.contoso.com/oab

Please run the following command in the management shell:-

test-outlookWebserivces | fl and see the result. If you get 401 Unauthorized please follow the below link and restart the server.

DisableLoopbackcheck registry.
key as per the article <http://support.microsoft.com/kb/896861>.


Then perform "SetSPN -a http/(Exchange server FQDN) (Exchange server name)"

Check the HTTP keep alive in IIS 7 in the following place:-
HTTP response headers on Default WebSite == set common headers.

If still the issue persists, please follow this steps:-

Delete and recreate the Autodiscover/ EWS Virtual Directories.
Remove-AutodiscoverVirtualDirectory -identity "CAS server name\Autodiscover (Default Web Site)"
Remove-WebservicesVirtualDirectory -identity "CAS server name\EWS (Default Web Site)"

new-AutodiscoverVirtualDirectory
new-WebservicesVirtualDirectory
And follow the kb-940726 again to set the InternalUri.
Perform IISreset.

And also please check whether you have 3.5 .netFramework, if yes please download and install the following hotfix.
KB- 958934

And Run Test EmailAutoconfiguration  from outlook 2007 client, and please select only Autodiscover. Remove Guessmart and Secure Guess mart.

Please check out these steps and revert back if the issue persists.
0
 

Author Comment

by:tinus67
ID: 33821423
SHIELD1: i have tryed to enable and disable the cached modus no luck.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 6

Expert Comment

by:SHIELD1
ID: 33821743
ok tinus, what about the steps laid out above? Did you manage to run through any of them? I will get back to you shortly as I'm playing with a 2010 install now to see what other ideas i can come up with!
0
 
LVL 6

Expert Comment

by:SHIELD1
ID: 33823272
ok I came across a problem with accounts connecting to exchange 2008 64bit with clients running outlook 2003 32 bit that was resolved by installing a 30 day copy of outlook 2010. this wasn't reoslved by DNS or firewall settings as I would normally expect - I suspect the problem may lie with the way (or version) RPC connects to the exchange server.

If you have the time give office/outlook 2010 a quick install just to see if the problem persists.
0
 

Author Comment

by:tinus67
ID: 33965019
It has worked with the current 2003 and 2007 clients but there are some other problems with the server to so we are gonna give it a reinstall when we upgrade the domaincontroler to 2008. Thanks anyway for everyone for the support.
0
 

Author Closing Comment

by:tinus67
ID: 33965026
i've split the points for support.
0
 
LVL 6

Expert Comment

by:SHIELD1
ID: 33971241
I hope the re-install sorts it for you ;)
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
Find out what you should include to make the best professional email signature for your organization.
In this video we show how to create a User Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Mailb…
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now