SCCM Database Log file

I am having an issue with my SCCM SMS_SITE_log.ldf file.

The current SMS_SITE_mdf file is 2.3 gig and the SMS_SITE_log.ldf file is 75 gig.

How do I reduce the SMS_SITE_log.ldf file size?
CMILLERAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
TarekIsmailConnect With a Mentor Commented:
As your  Database Recovery Model is set to FULL , you always need to backup the log  with option to truncate the log file after backup, as in my attached images.

you can switch from full to simple according to your backup stratigies you will use, in simple backup you can restore only the database from last full backup , but if you make it full recovery you can backup the database and the log then you have the option to restore to specific point of time from your log files.

from my side , i like full recovery to be configured for database.

Note: SMS2003/SCCM2007 defualt installtion use SIMPLE Database Recovery Model

after you backup the log file , you can shrink the Database log file , also you can configure the autogrouth.

I hope you find my reply answers all your questions!

Good Luck
Tarek Ismail
1.png
2.png
3.png
0
 
FunkyBrownCommented:
A majority of log file sizes like this have to be changed by the registry. This link should get you in the right track.

http://support.microsoft.com/kb/275742
0
 
CMILLERAuthor Commented:
I dont think that link has anything to do with my issue, why do you think that it does?
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
FunkyBrownCommented:
What that does is allow you to limit the file size on your log file. So what you could do is specify the max size that you want for that particular log file. So for your 70gb log file, lets say you want it down to 2 GB max. You could change the max file size to 2 GB and it will delete all old records up to the point where the file size is 2 GB. Make sense? It definitely does work as I have had to use this method in my site.
0
 
FunkyBrownCommented:
Sorry dude I think I mis understood completely. Your going to need to set the max file size on that in your SQL server.
0
 
FunkyBrownConnect With a Mentor Commented:
What you will want to do is log onto your SQL server. Double click on Databases. Right click your SMS_(three digit site code) and click properties. Then click on files, and change the autogrowth settings for SMS_SITE_LOG. You can set your max file size in there. If you have any questions, please let me know. Sorry again for the confusion.
0
 
FunkyBrownCommented:
0
 
CMILLERAuthor Commented:
Thanks, I will check it out tonight.
0
 
CMILLERAuthor Commented:
could not get it to work, transaction file still 75Gig
0
 
merowingerCommented:
Which Database Recovery Model is configured? Simple?
0
 
TarekIsmailCommented:
HI
If a database uses full or bulk-logged recovery model, you must back up the transaction log regularly enough to protect your data and to keep the transaction log from filling.
to Backup your log use the KB below
http://msdn.microsoft.com/en-us/library/ms179478.aspx

if your batabase configured with simple recovery, you dont have the option to backup the log file and only full backup.

 I recommend to full backup your database then shrik the log file

I have attached images to how to make full backup , then how to shrink your DB log size.

Good Luck!
Tarek Ismail




00.png
1.png
2.png
3.png
5.png
6.png
7.png
8.png
9.png
0
 
CMILLERAuthor Commented:
The Database Recovery Model is set to FULL, does that change how I need to reduce the log file? Do I need to change it to simple?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.