Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Windows 2003 Dc in mixed mode how to change

Posted on 2010-09-08
7
Medium Priority
?
692 Views
Last Modified: 2012-06-27
I have two Windows 2003 R2 Standard DC SP2 and one Windows 2003 R2 Enterprise 64Bit trying to get exchange 2007 entrprise and the install says My network is in mixed mode

I ran LDP.exe and here is the results for both DC;s

ld = ldap_open("tgcs002", 389);
Established connection to tgcs002.
Retrieving base DSA information...
Result <0>: (null)
Matched DNs:
Getting 1 entries:
>> Dn:
      1> currentTime: 09/08/2010 05:51:48 Eastern Standard Time Eastern Daylight Time;
      1> subschemaSubentry: CN=Aggregate,CN=Schema,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> dsServiceName: CN=NTDS Settings,CN=TGCS002,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      5> namingContexts: DC=our,DC=network,DC=tgcsnet,DC=com; CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com; CN=Schema,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com; DC=ForestDnsZones,DC=our,DC=network,DC=tgcsnet,DC=com; DC=DomainDnsZones,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> defaultNamingContext: DC=our,DC=network,DC=tgcsnet,DC=com;
      1> schemaNamingContext: CN=Schema,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> configurationNamingContext: CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> rootDomainNamingContext: DC=our,DC=network,DC=tgcsnet,DC=com;
      23> supportedControl: 1.2.840.113556.1.4.319; 1.2.840.113556.1.4.801; 1.2.840.113556.1.4.473; 1.2.840.113556.1.4.528; 1.2.840.113556.1.4.417; 1.2.840.113556.1.4.619; 1.2.840.113556.1.4.841; 1.2.840.113556.1.4.529; 1.2.840.113556.1.4.805; 1.2.840.113556.1.4.521; 1.2.840.113556.1.4.970; 1.2.840.113556.1.4.1338; 1.2.840.113556.1.4.474; 1.2.840.113556.1.4.1339; 1.2.840.113556.1.4.1340; 1.2.840.113556.1.4.1413; 2.16.840.1.113730.3.4.9; 2.16.840.1.113730.3.4.10; 1.2.840.113556.1.4.1504; 1.2.840.113556.1.4.1852; 1.2.840.113556.1.4.802; 1.2.840.113556.1.4.1907; 1.2.840.113556.1.4.1948;
      2> supportedLDAPVersion: 3; 2;
      12> supportedLDAPPolicies: MaxPoolThreads; MaxDatagramRecv; MaxReceiveBuffer; InitRecvTimeout; MaxConnections; MaxConnIdleTime; MaxPageSize; MaxQueryDuration; MaxTempTableSize; MaxResultSetSize; MaxNotificationPerConn; MaxValRange;
      1> highestCommittedUSN: 916315;
      4> supportedSASLMechanisms: GSSAPI; GSS-SPNEGO; EXTERNAL; DIGEST-MD5;
      1> dnsHostName: tgcs002.our.network.tgcsnet.com;
      1> ldapServiceName: our.network.tgcsnet.com:tgcs002$@OUR.NETWORK.TGCSNET.COM;
      1> serverName: CN=TGCS002,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      3> supportedCapabilities: 1.2.840.113556.1.4.800; 1.2.840.113556.1.4.1670; 1.2.840.113556.1.4.1791;
      1> isSynchronized: TRUE;
      1> isGlobalCatalogReady: TRUE;
      1> domainFunctionality: 2 = ( DS_BEHAVIOR_WIN2003 );
      1> forestFunctionality: 0 = ( DS_BEHAVIOR_WIN2000 );
      1> domainControllerFunctionality: 2 = ( DS_BEHAVIOR_WIN2003 );
-----------
0x0 = ldap_unbind(ld);
ld = ldap_open("tgcs001", 389);
Established connection to tgcs001.
Retrieving base DSA information...
Result <0>: (null)
Matched DNs:
Getting 1 entries:
>> Dn:
      1> currentTime: 09/08/2010 05:53:39 Eastern Standard Time Eastern Daylight Time;
      1> subschemaSubentry: CN=Aggregate,CN=Schema,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> dsServiceName: CN=NTDS Settings,CN=TGCS001,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      5> namingContexts: DC=our,DC=network,DC=tgcsnet,DC=com; CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com; CN=Schema,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com; DC=ForestDnsZones,DC=our,DC=network,DC=tgcsnet,DC=com; DC=DomainDnsZones,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> defaultNamingContext: DC=our,DC=network,DC=tgcsnet,DC=com;
      1> schemaNamingContext: CN=Schema,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> configurationNamingContext: CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      1> rootDomainNamingContext: DC=our,DC=network,DC=tgcsnet,DC=com;
      23> supportedControl: 1.2.840.113556.1.4.319; 1.2.840.113556.1.4.801; 1.2.840.113556.1.4.473; 1.2.840.113556.1.4.528; 1.2.840.113556.1.4.417; 1.2.840.113556.1.4.619; 1.2.840.113556.1.4.841; 1.2.840.113556.1.4.529; 1.2.840.113556.1.4.805; 1.2.840.113556.1.4.521; 1.2.840.113556.1.4.970; 1.2.840.113556.1.4.1338; 1.2.840.113556.1.4.474; 1.2.840.113556.1.4.1339; 1.2.840.113556.1.4.1340; 1.2.840.113556.1.4.1413; 2.16.840.1.113730.3.4.9; 2.16.840.1.113730.3.4.10; 1.2.840.113556.1.4.1504; 1.2.840.113556.1.4.1852; 1.2.840.113556.1.4.802; 1.2.840.113556.1.4.1907; 1.2.840.113556.1.4.1948;
      2> supportedLDAPVersion: 3; 2;
      12> supportedLDAPPolicies: MaxPoolThreads; MaxDatagramRecv; MaxReceiveBuffer; InitRecvTimeout; MaxConnections; MaxConnIdleTime; MaxPageSize; MaxQueryDuration; MaxTempTableSize; MaxResultSetSize; MaxNotificationPerConn; MaxValRange;
      1> highestCommittedUSN: 517039;
      4> supportedSASLMechanisms: GSSAPI; GSS-SPNEGO; EXTERNAL; DIGEST-MD5;
      1> dnsHostName: tgcs001.our.network.tgcsnet.com;
      1> ldapServiceName: our.network.tgcsnet.com:tgcs001$@OUR.NETWORK.TGCSNET.COM;
      1> serverName: CN=TGCS001,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=our,DC=network,DC=tgcsnet,DC=com;
      3> supportedCapabilities: 1.2.840.113556.1.4.800; 1.2.840.113556.1.4.1670; 1.2.840.113556.1.4.1791;
      1> isSynchronized: TRUE;
      1> isGlobalCatalogReady: FALSE;
      1> domainFunctionality: 2 = ( DS_BEHAVIOR_WIN2003 );
      1> forestFunctionality: 0 = ( DS_BEHAVIOR_WIN2000 );
      1> domainControllerFunctionality: 2 = ( DS_BEHAVIOR_WIN2003 );
-----------


Not sure how to change the mode back to native

what util can I do that with?

What line is it in this report the shows that it is in mixed mode?

Thanks

Tom
0
Comment
Question by:Inserachof
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +1
7 Comments
 
LVL 70

Accepted Solution

by:
KCTS earned 800 total points
ID: 33628728
Open ADUC, right click on the domain and select "Raise Domain Functional Level"
0
 
LVL 70

Assisted Solution

by:KCTS
KCTS earned 800 total points
ID: 33628741
... once the level has been raised it cant be lowered...
0
 

Author Comment

by:Inserachof
ID: 33628847
When I opened ADUC and tried to raise the level I got this

Current Domain function level is Windows Server 2003

The doamin is at the hightest level

Am I running native or mixed mode can you tell from my first post? if not what can I do to proove it?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
LVL 5

Assisted Solution

by:Swapnil Prajapati
Swapnil Prajapati earned 800 total points
ID: 33629468
From the LDP result i can see that your Domain level is 2003 but your forest functional level is mixed as it says forestFunctionality: 0 = ( DS_BEHAVIOR_WIN2000 );

I think you need to raise your forest level to Native from Mixed
You need to goto Active Directory Domain and Trust and then you have to raise your forest functional level from mixed to Windows 2003 Native.
0
 

Author Comment

by:Inserachof
ID: 33629524
Thanks

I have one windows 2000 server running exchange serve 2000 on my network once I get exchange 2007 running on my windows 2003 server then I can take the windows 2000 server offline and make that change what you think
0
 
LVL 5

Assisted Solution

by:Swapnil Prajapati
Swapnil Prajapati earned 800 total points
ID: 33629641
Might Be the following link help you for your transition for Exchange from 2000 to 2007

http://technet.microsoft.com/en-us/library/aa996719%28EXCHG.80%29.aspx

Once you successfully Transit your exchange server to 2007 you can Raise your Forest functional level to Windows 2003 Native.
0
 
LVL 11

Assisted Solution

by:Sigurdur Haraldsson
Sigurdur Haraldsson earned 400 total points
ID: 33629954
You don't need to take the Windows 2000 server offline as it is only a member server. But if you're changing the forest functional level, that means that you cannot have or implement (even later on) a DC running Windows 2000 in your forest, assuming that you have more than one domain. Ever! If you're not running any Windows 2000 DCs then go right ahead.
0

Featured Post

Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article provides a convenient collection of links to Microsoft provided Security Patches for operating systems that have reached their End of Life support cycle. Included operating systems covered by this article are Windows XP,  Windows Server…
Let's recap what we learned from yesterday's Skyport Systems webinar.
This tutorial will walk an individual through the steps necessary to join and promote the first Windows Server 2012 domain controller into an Active Directory environment running on Windows Server 2008. Determine the location of the FSMO roles by lo…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question