Solved

SSL Certificate error - Exchange 2010

Posted on 2010-09-08
13
578 Views
Last Modified: 2012-06-27
After our initial migration from 2003 to 2010 everything had been running swimmingly.  The Exchange 2010 server automatically made a default SSL certificate that it was using for everything but for obvious reasons external access to OWA didn't count as secure.

I purchased the appropriate SSL certificate for our OWA server and applied it via the Exchange 2010 management console.  Unfortunately during that process it decided that it would also apply itself to SMTP in addition to the OWA required services.  So *now* when an internal user opens Outlook they are immediately prompted that the SSL certificate is showing the incorrect name (twice).  You can accept it each time and move on, but I need to get back to the point where the internal certificate is assumed valid for SMTP and the purchased one is still used for external connections (which are working atm).
0
Comment
Question by:Loendar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
13 Comments
 
LVL 3

Expert Comment

by:SangramGohil
ID: 33629434
few things to start with

1. Certificate shows correct status on EMC
2. Services assigned correctly to Certificate
3. check certificate by  get-certificate

also check this link if it helps

http://technet.microsoft.com/en-us/library/aa995942.aspx

0
 

Author Comment

by:Loendar
ID: 33629471
I've done those things and they show accurately.  In fact, I exported the purchased OWA certificate and removed it, issued the New-ExchangeCertificate command since the internal certificate that was there originally didn't work and restarted both the 2003 and 2010 servers (seems they don't like to talk over SMTP after these are changed without a restart).

At that point the Outlook clients were happy again presumably using the new SSL cert.  As soon as I re-imported the OWA one (even though SMTP wasn't checked) it was back to square one only now I had TWO self-signed certificates.  It really is pretty odd.
0
 
LVL 3

Expert Comment

by:SangramGohil
ID: 33629547
Did you included Internal host name in certificate ?

& does it give any error when accessing from OWA?
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:Loendar
ID: 33629704
OWA is working flawlessly with the external certificate in place.

The issue is that the internal signed one previously was the server name and it was happy with that... now it is trying to use the certificate for the external name which doesn't match.  Really I just need to figure out how to get it to stop using the SSL certificate for SMTP.
0
 
LVL 3

Expert Comment

by:SangramGohil
ID: 33629829
You can remove service association by going to Server configuration >exchange certificates>select self signed certificate & assign services to certificate
0
 

Author Comment

by:Loendar
ID: 33629885
I shall give that a shot - thanks!
0
 
LVL 3

Expert Comment

by:SangramGohil
ID: 33629898
Once you assign services to self signed you will be able to remove it from other certificate.
0
 

Author Comment

by:Loendar
ID: 33629908
You are correct - it did allow me to remove the old one but sadly didn't stop the error message from happening when starting Outlook.

Really I would prefer to have SMTP not validated at all internally but it seems they force it.
0
 
LVL 3

Expert Comment

by:SangramGohil
ID: 33629983
If you have included your internal host name(FQDN -like mailserver.windowsdns.internal) in certificate it should not ask for certificate prompt.

like your certificate should include as example

mail.externalhost.com
mail.internalhost.com
mailserverhostname(FQDN)

that will prevent error from coming.

0
 

Author Comment

by:Loendar
ID: 33630418
Sadly - I did not.  It was only meant to apply to external names and I didn't think that it would try to apply itself internally as well.  In fact, since it was meant just for OWA and OMA it never occurred to me that it would set itself up on the SMTP port.
0
 
LVL 3

Expert Comment

by:SangramGohil
ID: 33631041
When you run outlook internally it will try to look for the FQDN host name entry in certificate. if it did not find then it will give certificate error as you are receiving.

0
 

Author Comment

by:Loendar
ID: 33647492
Well - i have tried to get the certificate reissued to include the FQDN used for our internal email server in the hopes that it would stop the error message.  Sadly, since we don't own the public version of the domain name they seem unlikely to provide it and I'm back to square one.

Outlook is looking at the external SSL certificate and refusing to acknowledge the internal one for SMTP.
0
 

Accepted Solution

by:
Loendar earned 0 total points
ID: 33824608
This took a bit of work from Microsoft but we managed to pin it down.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Lotus Notes – formerly IBM Notes – is an email client application, while IBM Domino (earlier Lotus Domino) is an email server. The client possesses a set of features that are even more advanced as compared to that of Outlook. Likewise, IBM Domino is…
Read this checklist to learn more about the 15 things you should never include in an email signature.
This video discusses moving either the default database or any database to a new volume.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

710 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question