Solved

Send As not working

Posted on 2010-09-08
17
393 Views
Last Modified: 2012-05-10
Simple situation,

Domain User - A logs into the domain and sets up Domain User B exchange profile in Outlook. Full Access on the mailbox has been granted, and send as right's have been granted.

Whenever trying to send as Domain User - A the following NDR is generated.


The following recipient(s) cannot be reached:

      <REMOVED> on 9/8/2010 1:21 PM
            You do not have permission to send to this recipient.  For assistance, contact your system administrator.
            MSEXCH:MSExchangeIS:/DC=local/DC=domain:SERVER-NAME
0
Comment
Question by:fluk3d
  • 10
  • 4
  • 2
  • +1
17 Comments
 
LVL 5

Expert Comment

by:swap_101982
Comment Utility
Can you please tell me how the send as rights are configured ?
0
 
LVL 5

Expert Comment

by:jhill777
Comment Utility
Are you sending to somebody within your exchange environment?  If so, check the setting for the users that have rights to send to that individual.  It's under Exchange General, Delivery restrictions.
0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
Sure -

Opened ADUC (on the site DC) and also did this on all the DC's in the forest as well as the exchange server, and clicked security on the Domain User A mailbox, clicked advanced then selected Send AS from Domain User B and sub-selected this object only.

0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
jhill777 - I am sending to myself and my delivery restrictions allow everyone
0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
Could it be it needs a couple of hours to update?
0
 
LVL 5

Expert Comment

by:swap_101982
Comment Utility
I think you have to goto security options of User B and there you have to specify Send As rights to User A.
Try that it will work.
0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
OK - I will try that but - that doesn't make very much sense seems a little backwards to me don't you think?
0
 
LVL 10

Expert Comment

by:dhruvarajp
Comment Utility
not really .. this should not take that long .. what you might need to do is recreate user profile or switch to online mode and test

.if it works in online mode and does not in cached mode .. recreate profile
0
Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

 
LVL 5

Expert Comment

by:swap_101982
Comment Utility
If you have opened Security Options for User A and if you are adding User B to Send As then it will give User B to send as User A but not User A to Send As User B
Correct me if i am wrong
0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
When you say switch to online mode simply turn off cached mode in Outlook ?
0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
User B needs to be able to send as User A

So I would need to give Send AS rights to User B  -- UNDER -- Users A profile to USER B
0
 
LVL 5

Expert Comment

by:jhill777
Comment Utility
Yeah, it's confusing.  So user-a is logged into windows but only has User-B profile set up in Outlook?  Sending as User-A will not work unless you allow User-B send-as rights for User-A.
0
 
LVL 6

Accepted Solution

by:
fluk3d earned 0 total points
Comment Utility
OK - looks like I am making some progress.

I disabled cached exchange mode restarted outlook, and tried a test message and got a pop up saying You do not have the permission to send the message on behalf of the specified user. It seems like the permissions on all the DC's are there but exchange hasn't picked them up. I'm looking at this site and towards the bottom of the page it states

http://www.msexchange.org/tutorials/Sending-As.html

" Of course, the key wording above is the line that reads You do not have permission to send to this recipient. Is it possible to speed up this permissions change process? Well, I haven’t been able to get someone from Microsoft to confirm this, but I believe it’s possible via the Mailbox Cache Age Limit registry key documented in KB article 327378. The KB article mentions changing the Mailbox Cache Age Limit registry key, which according to the article is used to re-read logon quota information. In my experience, modifying this key (or creating it if it doesn’t exist) with a suitable value, in minutes, speeds up the permissions change process. Note that you must restart the Information Store service after modifying this registry key. The general consensus of opinion here is not to make this value too low; a sensible value is 15 minutes. The alternative to creating or modifying this registry key is to simply re-start the Information Store service, which appears to make the permissions changes take effect immediately. Of course, restarting the Information Store service is rarely practical during business hours and you may also not prefer to go poking around in the registry, so you can also choose to wait for the permissions to be re-read at the next interval, which, as stated earlier, could be up to 2 hours. "

0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
Sorry I see where this gets confusing I should of states who's logged into what.

USER B is logged into the workstation under the domain
USER B has USER A profile setup in Outlook 2007
USER B needs to send as USER A in Outlook 2007
USER B does not have an exchange mailbox on the domain
0
 
LVL 5

Expert Comment

by:swap_101982
Comment Utility
User B has to have E-mail alias created on Exchange Server, because User B is authenticated in domain but Exchange is going to find SMTP for that user to send Mail on behalf but it is not able to Find SMTP and it is denying.
Try to create SMTP for User B and then Send As User A it will work.
0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
swap_101982 - even tho Outlook is setup under User A profile ?
0
 
LVL 6

Author Comment

by:fluk3d
Comment Utility
Just took a lunch - came back tried it again and it worked.

Keeping in mind the send as is setup as I stated before USER B needs send as permission from USER A

Thanks for your help guys looks like the article was right just wait a bit for things to update
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Disabling the Directory Sync Service Account in Office 365 will stop directory synchronization from working.
Learn to move / copy / export exchange contacts to iPhone without using any software. Also see the issues in configuration of exchange with iPhone to migrate contacts.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
This video discusses moving either the default database or any database to a new volume.

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now