• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 11000
  • Last Modified:

Checking monitor: must be configured to display at least 256 colors

I received following error message during the execution of database 10 g installer script  on Solaris x 86 platforms
-bash-3.00$ ./runInstaller
Starting Oracle Universal Installer...
Checking installer requirements...
Checking operating system version: must be 5.10.    Actual 5.10             Passed
Checking Temp space: must be greater than 250 MB.   Actual 7992 MB    Passed
Checking swap space: must be greater than 500 MB.   Actual 8282 MB    Passed
Checking monitor: must be configured to display at least 256 colors
    >>> Could not execute auto check for display colors using command /usr/openwin/bin/xdpyinfo. Check if the DISPLAY variable is set.    Failed <<<<
Some requirement checks failed. You must fulfill these requirements before
continuing with the installation,at which time they will be rechecked.
Continue? (y/n)  
********************************
Whenever I have executed following command before running script of oracle 10g installer
 
DISPLAY=10.21.5.221:0.0; export DISPLAY

Please help out …………….
0
Netsol-NOS
Asked:
Netsol-NOS
  • 4
  • 4
  • 3
  • +1
2 Solutions
 
sdstuberCommented:
assuming that IP address is the machine on which you are running an xwindows server, then you need to check your xwindows server configuration.

First, is the address of the xwindows server correct?
Can the server  running the installer reach that address? (firewalls)
Is the xwindows server running?
Is it supporting 256 colors?  
0
 
slightwv (䄆 Netminder) Commented:
Also check that XWindows can display on your client machine...

does xclock work?  if not: xhost +
0
 
Netsol-NOSAuthor Commented:
IP address is correct and  firewall is also disabled but i have no idea about xwindows server configuration in Solaris because i am new in Solaris
Can you tell me the command or document for configuring xwindows server.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
slightwv (䄆 Netminder) Commented:
After setting the DISPLAY above from a command prompt type: xclock

If everything is working you should see a clock appear on the monitor.
0
 
sdstuberCommented:
are you working directly on the solaris machine?  or are you telnet/ssh into it from a remote machine?


the "xwindows server" is software that needs to run on whatever machine you are physically looking at, it's the software that puts the windows on your screen.
0
 
Netsol-NOSAuthor Commented:
-bash-3.00$ DISPLAY=10.23.1.9:0.0; export DISPLAY
-bash-3.00$ xclock
-bash: xclock: command not found

I connect with server through putty software. 10.23.1.9 is a remote IP where putty is running.
0
 
slightwv (䄆 Netminder) Commented:
Sorry I've never used putty so I don't think I'll be much more help.  Hopefully sdstuber has.

0
 
Netsol-NOSAuthor Commented:
Dear Thanks for reply,
I have also  performed same command on Solaris Server for runnign xclock without using any software but result is same.
 
0
 
sdstuberCommented:
I have used putty but I'm not an expert and don't currently use it now; but I'll see what I can do.

When you setup your session, you have to authorize agent forwarding under the SSH->Auth option, then under tunnels make sure the X11 box is checked and put your ip (or localhost) followed by :0  in the address box

That "should" do it I think
0
 
johnsoneSenior Oracle DBACommented:
In putty, go to:

Connection -> SSH -> X11

Make sure that you check "Enable X11 forwarding".

That is only part 1 of the puzzle.

You also need to have an X windows emulator running on the Window machine that you are running from.  A common free one is cygwin, but that gives you a lot more than you need.

Also, with a connection running through putty, the DISPLAY variable is usually set to localhost:10.0.  putty handles it from there.  Typically, it is set automatically for you when you log in, however I have seen that not work when it should.

Once you have all of this set up, an easy test is xclock or xterm.  On Solaris, they are typically located in /usr/openwin/bin, but that may not be the case on your system.  If you cannot find xterm on  your system then your system admin needs to get X installed.
0
 
Netsol-NOSAuthor Commented:
Thanks for all,
My issue has been resolved after connecting this server with xManager software
0
 
sdstuberCommented:
you weren't running an xwindows server?

that was the first thing I mentioned,
everything after that (mine and other posts) was based on the "assumption" you had an xwindows server.

sounds like you implemented the solution in the first line of the first post http:#33629497 and repeated again by johnsone in http:#33630153
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now