Starting opensusie

I installed opensuse 11/3 and the install seemed to complete OK.

However when the computer rebooted there is no sign of opensuse.

The computer reboots into windows.

How can I start up the linux please?
johnhardyAsked:
Who is Participating?
 
mccrackyConnect With a Mentor Commented:
try:

find /boot/grub/stage1

that should show you the boot partition, which I would guess would be (hd0,4) and/or (hd1,4). then:

root (hd0,4)               (or whatever came out from the above)

and then

setup (hd0)

And, if that works, as they are RAID mirros, I would also do the other too so it wouldn't matter which disk I booted off of if one of them dies:

root (hd1,4)
setup (hd1)
0
 
Daniel JungesCommented:
boot from cdrom then choose start installed system, goto yast->System->Boot Loader and -> "Boot Loader Installation" let it install GRUB

http://www.dedoimedo.com/computers/grub.html
0
 
johnhardyAuthor Commented:
Thanks junges
When I boot
I get
Boot from Hard Disk
Installation
Rescue
Check Installation Media
Firmware Test
Memory Test
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
Daniel JungesCommented:
when you select "Boot from Hard Disk" the it boot suse or windows ?
0
 
johnhardyAuthor Commented:
windows
0
 
Daniel JungesCommented:
i have forgot the steps and at the moment i cannot restart our server, but i foud this on the web: may be that the options descriptions are not the same, but there is a way to boot it:

Select Rescue and Next to the Repair Method screen.
Select Expert Tools.
You will be presented with the Repair Tool Box screen.
Select to Boot Installed System.
If there are multiple installations on the drive you might be presented with a list of partitions (so select one), otherwise the system should auto-boot.
0
 
johnhardyAuthor Commented:
Thanks junges
No luck yet.
On a Boot with installation disc in DVD drive
From the menu I select Rescue
The Gnome and a small progress bar appears
Then a command line
I login with root and get Rescue:~#
I tried yast which brought nothing  and then grub which brings a few lines of suggested commands some of which do not seem to work.
If I select grub>boot
I get Error8 Kernal must be loaded before booting
0
 
Daniel JungesCommented:
I have the same suse version installed, but today i cannot restart it because it is our net server, tomorrow i can reboot it with the DVD and then i post here again.
0
 
johnhardyAuthor Commented:
Many thanks
0
 
mccrackyCommented:
From the rescue prompts try something like:

Assuming you have only one disk:

grub (enter)
root (hd0,?) (? being where your suse partition is (start counting from 0, not 1))
setup (hd0)
quit
0
 
johnhardyAuthor Commented:
Thanks mccracky
when i type root (hd0,?)
I get Unrecognized device string
0
 
mccrackyCommented:
no, you need to replace the ? with the partition number of the opensuse partition (start counting from zero, not one).  You can also use tab-completion to see what the options are.
0
 
johnhardyAuthor Commented:
Sorry for not understanding, this is my first foray in Linux
I have two discs.

if I enter root (hd0,0) I get Filesystem type unknown, partition type0x?

If I enter root (hd0,1) I get the same
0
 
mccrackyCommented:
ok, I assumed you had only one disk.

the hdX specifies the disk (once again starting from 0), so you may want to try hd1 like:

root (hd1,1)  

(this should tell grub where opensuse is - you need to put in the correct disk and partition)

setup (hd0)  

(this will set up grub on that drive (that may be different from the one suse is on)
0
 
johnhardyAuthor Commented:
Thanks
I tried various
Went into grub
root (hd1,1) brings File systemtype unknown, partion type 0xf

root (hd0,1) brings File systemtype unknown, partion type 0xf

I typed setup (hd0)  brings Error27 unrecognised command
0
 
johnhardyAuthor Commented:
I did a firmware test, whatever that is.. with the following results
OS2 memory hole test
Fail: The memory map has a hole between 15 and 16 Mb

Fail DMI information check
No SMBIOS nor DMI entry point found

Edd Boot disk hinting
Boot device 0x80 does not support EDD

HPET configuration test
Failed to locate  HPET BASE

There are some warnings as well
0
 
Daniel JungesCommented:
hi johnhardy, have you tried with  (hd1,0) ?
0
 
johnhardyAuthor Commented:
Hi junges
have you tried with  (hd1,0) I have now and get
File system type unknown, partion type 0x7

0
 
johnhardyAuthor Commented:
I can now boot onto the PC without the CD
When I switch with no CD on I get a screen which has several selections
Desktop to Opensuse
Failsafe to Opensuse
Windows
Floppy
When I select windows XP opens normally
However If I select Desktop to Opensuse a screen opens with one Gnome and nothing else happens.



0
 
Daniel JungesConnect With a Mentor Commented:
im note sure, but seems that you have to reinstall suse.
if you plan reinstall it, then do not forget to configure the bootmanager during the installation.
0
 
mccrackyCommented:
I don't think you've found the correct partition for opensuse.  According to fdisk, the partition type 7 is an NTFS partition (probably your windows partition) and partition type f is the extended partion.  You probably need to try (hd0,2) or (hd1,2).  From the rescue prompts of the cd, do you have the program fdisk?  give us the listing of:

fdisk -l  

(that's lowercase L, not the number one)
0
 
Daniel JungesCommented:
if you PC has sata disk then the names are sda1, sda2,... OR sdb1,...
0
 
johnhardyAuthor Commented:
root (hd0,2) and (hd1,2).both bring
No such partition

From Rescue I ran fdisk -l
I am attaching an image. I hope it is clear enough.

fdisk1.jpg
0
 
Daniel JungesCommented:
you have sata devide: linux seems installed on  sda5 or sdb5
0
 
Daniel JungesCommented:
try both sda5 and sda7, sdb5 and sdb7
0
 
johnhardyAuthor Commented:
Thanks
Is that good or bad!
0
 
Daniel JungesCommented:
is good, sata is better and faster as IDE harddisk. try it and let us know.
0
 
mccrackyCommented:
try:

root (hd<tab>

which should give you the options you have.  It looks like you have RAID1 mirrors on your machine and sda5 sdb5 are the boot partition for opensuse.  you should probably come up with one of:

root (hd0,4)
root (hd1,4)

which, if they really are RAID1 mirrors shouldn't matter which disk they boot off of.
0
 
johnhardyAuthor Commented:
Thanks

There are definitely mirrors in the machine.

root (hd<tab> brings Possible disks are hd0 hd1 hd2 hd3

root (hd0,4)    File system type is ext2fs, partition type 0x83
root (hd1,4)    File system type is ext2fs, partition type 0x83
0
 
johnhardyAuthor Commented:
Thanks mccracky
That seemed to work completely as you suggest.

I have restarted the machine but after booting I still get the screen with a gnome and nothing else, except the back ground.
0
 
mccrackyCommented:
so you are at least past the grub issue?  You got through the grub boot screen?  Now it's an opensuse issue?  

I'm not completely familiar with OpenSUSE, but can you use Alt+F2 to get to a console and log in there?  If so, it's probably a X11 issue or a Gnome issue.  You can try to fix things through YAST from the console login, but I'm getting out of my knowledge with OpenSUSE.

(it might be better to open another question on opensuse rather than grub if the grub issue is now fixed and we're onto another issue.)
0
 
johnhardyAuthor Commented:
Excellent help.
Thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.