Solved

Cannot open Companyweb - Server Error in '/' Application - runtime error Access is denied

Posted on 2010-09-08
20
753 Views
Last Modified: 2012-05-10
I recently am having issues with opening companyweb on my Server 2008 pc.  it was working fine until this morning and now i receive this error:

Server Error in '/' Application.
--------------------------------------------------------------------------------

Access is denied.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Access is denied.


Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace:


[COMException (0x80070005): Access is denied.
]
   System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) +557
   System.DirectoryServices.DirectoryEntry.Bind() +44
   System.DirectoryServices.DirectoryEntry.get_IsContainer() +42
   System.DirectoryServices.ChildEnumerator..ctor(DirectoryEntry container) +36
   System.DirectoryServices.DirectoryEntries.GetEnumerator() +36
   Microsoft.SharePoint.ApplicationRuntime.SPRequestModule.System.Web.IHttpModule.Init(HttpApplication app) +699
   System.Web.HttpApplication.InitModulesCommon() +124
   System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +1162
   System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +312
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +133
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +196

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.4206; ASP.NET Version:2.0.50727.4205
servererror.jpg
0
Comment
Question by:AxeonTech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 7
  • 2
  • +1
20 Comments
 
LVL 11

Expert Comment

by:mattibutt
ID: 33630670
have you access using different username try to give permission in nt security from website folder properties allow everyone and see
0
 
LVL 38

Expert Comment

by:Justin Smith
ID: 33630703
Are all SharePoint services running on your server?  Did you recently install any updates (SP2?)
0
 

Author Comment

by:AxeonTech
ID: 33630885
All Sharepoint Services are running and I did not install any updates recently, unless the server did it overnight on its own.  Every user account has this issue, it does not matter if your a standard user or administrator, it wont open for anyone.  
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 
LVL 11

Expert Comment

by:mattibutt
ID: 33630893
can you try to add another test application and see what happens
0
 

Author Comment

by:AxeonTech
ID: 33630935
I would need some help in running a test application because I have not set one up before.  
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33630996
alright if you have never setup then i would say do you know how to use mssql server? if not then post back i asked you something a bit earlier did you allowed diretory access to everyone?
if you go in c drive then inetpub folder right click on it and then properties and security give permission to everyone and then see what happens
0
 

Author Comment

by:AxeonTech
ID: 33631042
I am not completely familiar with mssql setup.  But I did what you wanted me to try and gave "everyone" full control to the inetpub folder, and I am still getting the same error.  
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33631062
you know if you go in sbs console and then select one user properties allow him to access company web then try to connect using him
0
 

Author Comment

by:AxeonTech
ID: 33631263
I just tried granting company web access to a user, and then tried accessing it as the user and still received the same error.  I even created a brand new user with company web access and still got the same error.  
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33631337
are you sure you havent installed any updates
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33631344
can you run comapnyweb inside the server or its not running there either sql server is running
0
 
LVL 9

Expert Comment

by:khaledf
ID: 33631350
do you notice any errors related to this in the event log?
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33631359
check security events log as well
0
 

Author Comment

by:AxeonTech
ID: 33631431
no, i can not run companyweb even from the server.  I checked "Installed Updates" under Programs and Features and there was nothing listed since 8-18-10, which this issue just started today, and yes sql server is running.  
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33631442
have you changed password for any admin account or any account which are running services
0
 
LVL 9

Expert Comment

by:khaledf
ID: 33631449
have you checked the event log? it might be another issue preventing access, such as disk is low in space
0
 

Author Comment

by:AxeonTech
ID: 33631482
Ok, when I try to access companyweb i get this error under Application in the Event Viewer with Source ASP.NET 2.0.50727.0 and Event ID 1309:

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 9/8/2010 1:58:25 PM
Event time (UTC): 9/8/2010 8:58:25 PM
Event ID: 32cf7d131b7d4c87a3533fbe62999b83
Event sequence: 7
Event occurrence: 6
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/594812419/ROOT-1-129284524798368802
    Trust level: WSS_Minimal
    Application Virtual Path: /
    Application Path: C:\Program Files\Windows Small Business Server\Bin\WebApp\InternalWebSite\
    Machine name: KEYSTONE
 
Process information:
    Process ID: 4376
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: COMException
    Exception message: Access is denied.
 
 
Request information:
    Request URL: http://companyweb/ 
    Request path: /
    User host address: 192.168.16.10
    User:  
    Is authenticated: False
    Authentication Type:  
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 9
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail)
   at System.DirectoryServices.DirectoryEntry.Bind()
   at System.DirectoryServices.DirectoryEntry.get_IsContainer()
   at System.DirectoryServices.DirectoryEntries.ChildEnumerator..ctor(DirectoryEntry container)
   at System.DirectoryServices.DirectoryEntries.GetEnumerator()
   at Microsoft.SharePoint.ApplicationRuntime.SPRequestModule.System.Web.IHttpModule.Init(HttpApplication app)
   at System.Web.HttpApplication.InitModulesCommon()
   at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers)
   at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context)
   at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
 
 
Custom event details:
0
 
LVL 11

Expert Comment

by:mattibutt
ID: 33631491
this is what i said nt authority account is not getting security pass try to run the service with your admin account and see what happen
0
 
LVL 11

Accepted Solution

by:
mattibutt earned 500 total points
ID: 33631509
is NT AUTHORITY\NETWORK SERVICE  allowed to access the sql
0
 

Author Comment

by:AxeonTech
ID: 33640616
how would I change the service to use a different account or give NT AUTHORITY access?  
0

Featured Post

Edgartown IT Case Study

Learn about Edgartown's quest to ensure the safety and security of the entire town's employee and citizen data. Read the case study!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question