• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1009
  • Last Modified:

Robocopy files not having archive bit set

I setting up a process to move/copy files off of a server with robocopy. Each day I copy files to a remote storage server. To easily and visually keep track of what files have been copied (I also write a log) I change the archive bit on the source files with the /M switch during the copy. Later I want to move the files that don't have the archive bit set to a different folder. Is there a switch or other way to have robocopy "see" the bit is not set and only move those files?
0
LMMS
Asked:
LMMS
1 Solution
 
MarblemanCommented:
Take a look at the /XA Option: /XA[A] could solve the problem because it is supposed to exclude all files with the Archive-Flag set...
0
 
Bryan ButlerCommented:
According to this, the /a should do it:

http://technet.microsoft.com/en-us/library/cc733145(WS.10).aspx

Are you using 2008?
0
 
LMMSAuthor Commented:
Ths /XA:A switch works. I overlooked it when looking at all the possible settings. Thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now