Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6403
  • Last Modified:

VMWare VSphere ESXi and Virtual Center

Issue with Virtual Center adding a VMWare ESXi host

I currently have a single VMWare VSphere ESXi host, version (and build) number 4.1.0, 260247.  This host has a 4 port Ethernet NIC, with one port connected, and a fiber channel HBA to attach to our shared storage.  The host is being utilized for a demo of VMWare View, and won’t be needed for HA, DRS, etc.

I have 2 virtual machines, both Windows server 2003 on the host.  Both are patched and part of a production AD domain and tree.  On one virtual machine, I have installed Virtual Center, and I am utilizing the version of SQL included since our demo will be fairly small scale. The Virtual Center version is 4.0.0.10021.  So, the virtual center server is running as a virtual machine (which I have done before without issue)

The problems center around adding the VMWare host to Virtual Center.  I can add the host successfully.  However, after about a minute, the host goes into a disconnected state.  I can reconnect, and sometimes the reconnect will work, other times, I have to walk through the process of specifying the IP address, root account and password, etc.  And, other times, I have to completely remove the host from Virtual Center, and re-add.  But, the bottom line is once I add the host, it goes into a disconnected state within 2-3 minutes.
The error I receive the majority of the time is:  A general system error occurred:  Internal error: vmodl.fault.hostcommunication.

To troubleshoot, I’ve done the following so far:
1.      Verify I can successfully access the host directly with the VSphere client from several different desktops as well as the virtual center machine.  When doing this, I never lose connectivity with the VMWare host.
2.      Run extended pings.  No packets are lost
3.      Verify no firewalls turned on or between my location and the vmware server
4.      Successfully telnet to port 902 (or whatever the default port is; I can’t recall if it’s 902, 903, etc).  But, whatever it is, when I look it up, I am able to successfully telnet to it.
5.      The VMWare ESXi server is not in any DNS tables, nor are the 2 windows virtual servers.  So, I’ve modified the hosts file on each of them with the appropriate settings.  I can ping to all by name, including just the name as well as the FQDN.  
6.      The 2 virtual machines were not in the AD domain, so I requested one of the AD administrators add these in.  He did, and in the process changed the names of the servers.  So, I updated the hosts file.
7.      In addition to the name change and updating the hosts file, I completely removed virtual center from the VM it was on, including the SQL portion. Basically, my aim was to remove any possible references to the previous VM’s names.  Then, I reinstalled both and attempted to add the ESXi host back in.  Still the same results.
8.      Utilized the SSH and restarted the services on the ESXi host several times.  
9.      When examining the virtual center system logs closer, I observed several SSL certificate errors, including host name could not be verified, etc.  (Unfortunately, I left the exact errors at work; I will post them when I return to work).  This led me to believe I may have a corrupted SSL certificate either on the virtual center or ESXi host, or both.  So, I used openssl to generate a new ssl certificate and imported it.  After doing that, I now get the error: authenticity of hosts ssl certificate is not verified

I can’t get the host to go into Virtual Center now.  So, it comes down to those 2 errors, and the above are the steps I’ve taken so far.  The original error, A general system error occurred:  Internal error: vmodl.fault.hostcommunication seems to be related to the virtual machine renames and a possibly corrupt SSL certificate.  I have modified the hosts files and reinstalled virtual center, so the host renames should be out of the picture.  However, my attempt to generate a new SSL certificate seems to have made things worse.  At this point, I’m not really sure which way to go.  

I’d appreciate any suggestions, etc so I can get back on track with this.  It’s quite frustrating to spend a day and a half on something that usually only takes me a minute or two (literally).  Hopefully, at least I’ll learn something interesting from all this :)
0
rslan
Asked:
rslan
4 Solutions
 
Paul SolovyovskySenior IT AdvisorCommented:
Make sure your ESX host has an A record in DNS and add via FQDN.  Also ensure that vCenter is pointing to the DNS servers.
0
 
rslanAuthor Commented:
Hey Paulsolov,

Thanks for responding.  VCenter is pointing to the DNS servers.  However, I'm pretty sure we don't have the A record in DNS, but I do have a hosts file on the ESXi server and virtual center server so that they can resolve via FQDN or just the simple name.  I would think/hope that the hosts file would be beneficial and be a sufficient substitute for a DNS server entry.
0
 
simonseztechCommented:
Since you use ESXi 4.1 please make sure you use vCenter 4.1

Refer to this compatibility matrix
http://www.vmware.com/pdf/vsphere4/r40/vsp_compatibility_matrix.pdf

vCenter 4.0 doesn't support ESXi 4.1.

You will need 64bits windows to run vCenter 4.1
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
bgoeringCommented:
Check /etc/opt/vmware/vpxa/vpxa.cfg file to make sure the serverIP parameter has the correct IP address for the vCenter server, correct it if it is incorrect and restart the management agents from the DCUI

Good Luck
0
 
rslanAuthor Commented:
thanks all; I have a few things to go on.  Simon, I think you hit the nail on the head. I was so sure of the compatibilities that I didn't check, but the first thing I'm going to do tomorrow is reload virtual center with version 4.1 and go from there.  
0
 
VMwareGuyCommented:
You need to be at the same versions.  Period.  Simonsectech is the first to offer up the correct answer, but since I'm re-affirming it, please don't hesitate to offer me assisted solution.   Take it from a dual certified VCP (VCP in both esx 3.5 and vSPhere)...      
0
 
michelkeusCommented:
I need to make a small correction to VMwareGuy's remark. You don't need to have the same versions, just a higher version of vCenter then ESX/ESXi. You can add a ESX/ESXi 3.5 or 4.0 just fine to a vCenter 4.1 (3.5 does require a seperate License Server which can also be installed on an existing vCenter 4.1).

But yes as said because you are running 4.1 you need either an vCenter 4.1 or if you can get your hands on it a Codename MN-based vCenter (version > 4.1).
0
 
VMwareGuyCommented:
Michelkeus is correct.  You can have older versions of ESX managed by vCenter, just not vice versa.. Thanks Mich...
0
 
rslanAuthor Commented:
ok all, thanks so much for your inputs.  It does look like I lost control of the wheel with those versions, and I appreciate everyone jumping in there and directing me.

I'm not onsite right now, but will be later today and will immediately install the newer version of VCenter.  Assuming that works, I will award points and include assisted solutions to give credit for everyone.  

Thanks again, and I'll update later today or tomorrow.  
0
 
VMwareGuyCommented:
VMware has these strange version #s and they make it difficult to track them.. they need to get a handle on it and put up a website that translates the build #s to the versions.  
0
 
rslanAuthor Commented:
I agree with that VMWareGuy.  Of course, in all honesty, my mistake was just rushing to get started with the project.  The old saying my Mom and Dad always told me was "haste makes waste" and in this case they're correct.  
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now