• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 752
  • Last Modified:

mobile device trying to sync with exchange server shows # of items in each folder but then does not receive data

Microsoft Exchange Server 2003 on a Windows 2003 Enterprise Server - SP2 on both.  Configured Samsung Jack for syncronization with the exchange server and device connects and shows me that it checks folders and reports the number of items in each folder but does not sync any of them onto the device.  Tested creating an outbound email in the device under that profile and it works fine.  Having trouble figuring out how to troubleshoot or find logs in the server.  Any help greatly appreciated.
0
eldtech
Asked:
eldtech
  • 7
  • 5
  • 2
1 Solution
 
Alan HardistyCo-OwnerCommented:
Please have a read through my Exchange 2003 / Activesync article and make sure al your IIS settings are correct.
Once checked, run the test on the test site and report back any errors not handled by my article:
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html 
0
 
sunnyc7Commented:
Test site is
www.testexchangeconnectivity.com

Can you create a test mailbox , send receive about 4/5 emails and then try to sync it with samsung

See if it works

Thanks

0
 
Alan HardistyCo-OwnerCommented:
All yours for a few hours Sunny - Bed time!!
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
eldtechAuthor Commented:
Followed the article mentioned and configured everything accordingly.  Problem still exists and the symptom is the same even after some adjustments to configure as recommended.  It seems that ActiveSync sees and shows the estimate correctly but does not sync anything.  Here are the last few lines from the Exchange Connectivity Analyzer:
 ExRCA is attempting to test the GetItemEstimate command for the Inbox folder.
  Successfully received GetItemEstimate Response from Server
   Additional Details
  Estimate: 420 messages
 
 ExRCA is attempting to test synchronization of the Inbox folder.
  The Sync command completed successfully.
   Additional Details
  Number of items synchronized: 0
 
Thanks for your help.
0
 
eldtechAuthor Commented:
Forgot to mention.  I did create a new mailbox and put 3 items in the inbox, created an appointment, and a contact.  The behavior is the same, I see the estimate but no items sync'd.

Thanks.
0
 
Alan HardistyCo-OwnerCommented:
Okay - all sounds well on the configuration front.
Can you test your new account on a different phone to see if that works.
It may be mailstore issues (eseutil /p, /d and isinteg may resolve those), or Anti-Virus interference in which case the registry addition in my article might resolve that.
0
 
eldtechAuthor Commented:
Tested on two different phones and three different accounts - two existing and one new just for testing.  All combinations give the same result, seems to communicate just fine.  Shows connected and reports number of emails - it just doesn't think they need to be sync'd I guess.  Tried the ProactiveScanning registry entry and when that didn't change anything I ran eseutil /p and then /d on the priv1 file and then isinteg on the server with testallfolders option.  Restarted the server and I still have the same - communication tests ok with comm analyzer and seems to be working with phone but items not syncing.
0
 
eldtechAuthor Commented:
thought I'd tickle the thread and see if anybody else has any ideas?
0
 
Alan HardistyCo-OwnerCommented:
Sorry - thanks for the tickle!

Best bet now is to dismount the store and repair, defragment it and then integrity check it.

eseutil /p
eseutil /d
isinteg -s servername -fix -test alltests

Run isinteg as many times as it takes to see 0 errors and 0 fixes in the last line.

Your users will not be able to access their emails whilst this is happening and it takes about 1 hour to process 4-6gb of mailstore, so if you have a large store, get lots of coffee!
0
 
eldtechAuthor Commented:
Sorry, wasn't able to perform these procedures for a while there but I finally was able to take care of it.  All came back seemingly normal but when I run the tests again I still get the same thing.  I also saw another article mentioning to reapply SP2 and I went ahead and did that but it had no effect either.  Here is the result I get from ERCA.  You can see that the estimate from the Inbox is 214 items but the  Number of items synchronized = 0.  This seems to mimic the behavior on the mobile devices.  I also did check that the devices trying to sync are using Windows Mobile 6.0 or later as there is a mention of it in a warning.  Any more ideas?

ExRCA is testing Exchange ActiveSync.
 Exchange ActiveSync was tested successfully.
 Test Steps
 Attempting to resolve the host name mailmia.mahudi.com in DNS.
 The host name resolved successfully.
 Additional Details
 IP addresses returned: 12.199.111.99

Testing TCP port 443 on host mailmia.mahudi.com to ensure it's listening and open.
 The port was opened successfully.
Testing the SSL certificate to make sure it's valid.
 The certificate passed all validation requirements.
 Test Steps
 Validating the certificate name.
 The certificate name was validated successfully.
 Additional Details
 Host name mailmia.mahudi.com was found in the Certificate Subject Common name.

Validating certificate trust for Windows Mobile devices.
 The test passed with some warnings encountered. Please expand the additional details.
 Additional Details
 The certificate is only trusted on Windows Mobile 6.0 and later versions. Devices running Windows Mobile 5.0 and 5.0 with the Messaging and Security Feature Pack won't be able to sync. Root = OU=Go Daddy Class 2 Certification Authority, O="The Go Daddy Group, Inc.", C=US.

Testing the certificate date to confirm the certificate is valid.
 Date validation passed. The certificate hasn't expired.
 Additional Details
 The certificate is valid. NotBefore = 9/9/2010 1:23:38 AM, NotAfter = 9/9/2011 1:23:38 AM



Checking the IIS configuration for client certificate authentication.
 Client certificate authentication wasn't detected.
 Additional Details
 Accept/Require Client Certificates isn't configured.

Testing HTTP Authentication Methods for URL https://mailmia.mahudi.com/Microsoft-Server-Activesync/.
 The HTTP authentication methods are correct.
 Additional Details
 ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic

An ActiveSync session is being attempted with the server.
 Testing of an Exchange ActiveSync session completed successfully.
 Test Steps
 Attempting to send the OPTIONS command to the server.
 The OPTIONS response was successfully received and is valid.
 Additional Details
 Headers received: Pragma: no-cache
Public: OPTIONS, POST
Allow: OPTIONS, POST
MS-Server-ActiveSync: 6.5.7638.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,ResolveRecipients,ValidateCert,Provision,Search,Notify,Ping
Content-Length: 0
Date: Mon, 15 Nov 2010 22:40:55 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET



Attempting the FolderSync command on the Exchange ActiveSync session.
 The FolderSync command completed successfully.
 Additional Details
 Number of folders: 44

Attempting the initial sync to the Inbox folder. This initial sync won't return any data.
 The Sync command completed successfully.
 Additional Details
 Status: 1

Attempting to test the GetItemEstimate command for the Inbox folder.
 ExRCA successfully received the GetItemEstimate response from the server.
 Additional Details
 Estimate: 214 messages

Attempting to test synchronization of the Inbox folder.
 The Sync command completed successfully.
 Additional Details
 Number of items synchronized: 0
0
 
eldtechAuthor Commented:
I worked with Microsoft and they had me going in circles for two weeks but they did recommend the final solution.  The server is using Sophos for antivirus and Sophos PureMessage for antispam.  The article that finally did it was the following:  
Title: Synchronization with PDAs fails when using ActiveSync
URL: http://www.sophos.com/support/knowledgebase/article/13186.html
Although the instructions in the article didn't match exactly step by step, the general idea is that you need to turn on Proactive and Background scanning.  Once I put checks in the two boxes to activate these features activesync started working.
0
 
Alan HardistyCo-OwnerCommented:
The background scanning is detailed in my article under inconsistent Sync.

Unfortunately - I don't know the Sophos Products - so was not aware they had the tick boxes.  I'll try and remember that for next time.

Glad you got it solved.

Alan
0
 
sunnyc7Commented:
thanks for posting back the solution here.
0
 
eldtechAuthor Commented:
Found the solution outside of EE but wanted to add so that others could benefit.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 7
  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now