Solved

The Following URL is not valid :

Posted on 2010-09-08
6
548 Views
Last Modified: 2012-05-10
I am trying publish infopath form but i get a error saying The Following URL is not valid :  any soultion for this ?
I use to publish infopath forms before with out any problem,
0
Comment
Question by:msk_1227
  • 3
  • 3
6 Comments
 
LVL 2

Expert Comment

by:bureshd
ID: 33632503
Have you verified all permissions on the site are correct? If so, I would recreate the Forms Library and try publishing again.
0
 
LVL 2

Expert Comment

by:bureshd
ID: 33632512
Also, at what step does this message appear in the publishing tool in Infopath? Does it allow you to select the Forms Library to publish to or does it not even connect to the site?
0
 
LVL 2

Author Comment

by:msk_1227
ID: 33637191
bureshd,
thanks for reply
it doesnt even connect the site.
the permission are correct & i also tried different forms library & new library it doent even try to connect to the site.
0
Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

 
LVL 2

Expert Comment

by:bureshd
ID: 33640459
I am still leaning towards a permissions issue, specifically in the site that contains your forms library. I am assuming Infopath services is running? Also, have you published forms to this site before or other location within Sharepoint?
0
 
LVL 2

Author Comment

by:msk_1227
ID: 33643435
i have published many infopath before to this site before & i am the farm administrator.
last week while working with MS on other issue, we extended the webapplication on port 81,th
 e URl of port 81 worked for the infopath publishing,instead of actual port site 80 . so i deleted the port81 site from IIS but still i see this error on actual site saying "Following URl is not valid url" & site works fine with out any problem

while testing we also created site collection under sites, i deleted that testing site collection too, but i still see the error.

so any clue ?
0
 
LVL 2

Accepted Solution

by:
msk_1227 earned 0 total points
ID: 33650804
1. Open regedit.exe, go to "HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Internet\Server Cache"
2. Delete all subkeys of "Server Cache" key, they are in form of http://xxxxxxx
3. Update "Count" value of "Server Cache", setting it to 0.
4. Close regedit.
5. Close and reopen InfoPath and try publishing the form now.

deleteing the cache made the trick , I found that in this link http://serena-yeoh.blogspot.com/2006/08/infopathformurlnotvalid.html
 any how thanks ! for all your help
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I recently came across an issue with a MOSS 2007 deployment where access into some sub-sites were denied, even for the MOSS farm administrators. A bit of background to the setup of this MOSS farm; this was a three server setup, consisting of a fr…
For SharePoint sites, particularly public-facing ones, there are times when adding JavaScript, Meta Tags, CSS Styles or other content to the page <head> section is more practical than modifying master pages.  For instance, you could add the jQuery l…
The Email Laundry PDF encryption service allows companies to send confidential encrypted  emails to anybody. The PDF document can also contain attachments that are embedded in the encrypted PDF. The password is randomly generated by The Email Laundr…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question