requirments sql server 2008 install

what are the software requirements for installing SQL Server 2008 or 2008 R2.
I am aware of the link from MS.
I know we need .net framework 3.5 with SP1 and windows installer 4.5
internet explorer 6 with sp1 or greater
While installing SQL Server, service pack 1 if it is SQL 2008
but,
1. MS have not mentioned anything about IIS. Is IIS required, if so what version?
2. Is there anything else that is required in order to install SQL Server 2008/R2
LVL 1
sqlserverdbaAsked:
Who is Participating?
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
>> " Windows Powershell 1.0 is required.."
The link shows that it is only for Express Edition, that we need to manually install components including Powershell

Yes, but we can have it installed as Powershell has numerous features in it..

>> So do I ask them to install IIS?  I thought IIS was no longer required for SQL 2008 and is not listed in the prerequisites now. If it is required, which version?.

By default, IIS would be installed in a machine as part of OS features. If uninstalled by any chance, then it is required only if you are going to install SSRS in that machine. Else it is not required.
And you can ignore the IIS warning message that comes during installation of SQL Server.
0
 
dsackerContract ERP Admin/ConsultantCommented:
You'll need IIS 7. The installation is pretty easy.

If you're installing on Win Server 2008, if you are using ASP.NET and SQL Server, it's advised to install PowerShell, install Windows Installer 4.5, and the ASP.NET AJAX Extensions 1.0 .
0
 
Raja Jegan RSQL Server DBA & ArchitectCommented:
>> While installing SQL Server, service pack 1 if it is SQL 2008

small correction, you need to apply SP1 after installing SQL 2008.

>> 1. MS have not mentioned anything about IIS. Is IIS required, if so what version?

No need to worry about that..
Make sure that IIS service is running and not blocked in Vista or Windows 7.

>> 2. Is there anything else that is required in order to install SQL Server 2008/R2

Windows Powershell 1.0 is required..

http://msdn.microsoft.com/en-us/library/ms143506.aspx
0
 
sqlserverdbaAuthor Commented:
Thank you for the response
Dsacker,
yes this will be Windows 2008 R2

Hi RRJegan,
I always install the service pack after the SQL Server install. Actually, I was first trying to get the pre requisites installed by the Windows Team. I had only specified to them that I need .net Framework 3.5 with SP1, Windows installer 4.5 , internet explorer.

" Windows Powershell 1.0 is required.."
The link shows that it is only for Express Edition, that we need to manually install components including Powershell

So do I ask them to install IIS?  I thought IIS was no longer required for SQL 2008 and is not listed in the prerequisites now. If it is required, which version?.
0
 
sqlserverdbaAuthor Commented:
doesn't require IIS
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.