Solved

Slow access to network drives on 2003 server from XP desktops

Posted on 2010-09-09
8
369 Views
Last Modified: 2012-05-10
Having an issue with windows XP desktops accessing shared drives on a 2003 SBS

For example \\servername takes about 30-40sec to display the list of shared drives. After the initial connection its fast for all the directories.
The same access from an attached 2008 server is instant when viewing the 2003 shares.

Its also effecting a network application which again takes 30-40sec for the first command but then works fine for subsequent commands until its left unused for a while

All information i have seen on this so far is to do with netware clients etc but thats not the case here.
Any help to point me in the right direction is appreciated

 
0
Comment
Question by:trippa666au
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
  • 2
  • +2
8 Comments
 
LVL 4

Accepted Solution

by:
vickzz earned 167 total points
ID: 33634748
Update NIC Drivers on SBS Server and also disable TCP Features and see if it makes it better..
http://support.microsoft.com/kb/948496
0
 
LVL 3

Assisted Solution

by:Willy Van den Houten
Willy Van den Houten earned 167 total points
ID: 33634989
on the server - stop the sharing with the managment console and restart it.

I saw another solution on Experts exchange :


Windows 2003 SP2 has some new network features that may not be supported by  network devices. Lets perform these steps to disable them:

1. Click  Start, click Run, type regedit , and then click OK.
2. Locate and then click  the following registry subkey:  
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters  

3. On the Edit menu, point to New, click DWORD Value, and then type  EnableRSS .
4. Double-click EnableRSS, type 0 , and then click OK.
5.  Exit Registry Editor.

If you are still experiencing problems (like slow  file copying), you should also disable Offloading support:
=========
1.  Click Start, click Run, type regedit, and then click OK.
2. Locate and then  click the following registry subkey:  
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters  

3. In the right pane, make sure that the DisableTaskOffload registry  entry exists. If this entry does not exist, follow these steps to add the entry:  
a. On the Edit menu, point to New, and then click DWORD Value, and then type  DisableTaskOffload .
4. Double-Click DisableTaskOffload, type 1, and then  click OK.  
5. Exit Registry Editor.

(Reboot to make both changes  effective)

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22832995.html


0
 
LVL 5

Assisted Solution

by:AC_Nova
AC_Nova earned 166 total points
ID: 33636938
Ive seen this beofre on shared folders that have thousands of files in.  Split up the folders so they have fewer files within the folders, also goto my computer, tools, folder options and untick 'automatically search for network folders and printers'  I have seen this improve things a tad also.
2010-09-09-150051.jpg
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 5

Expert Comment

by:AC_Nova
ID: 33636958
Also is your anti-virus software scanning network drives or anything like that?  try disabling AV, see if that has an impact.
0
 
LVL 4

Expert Comment

by:vickzz
ID: 33637349
Yes I agree with AC_Nova try spliting the folders and AV realtime scan should also be disabled.

0
 

Author Comment

by:trippa666au
ID: 33655704
Thanks everyone for comments so far. I will be trying these over the next few days and will see what works.
0
 
LVL 8

Expert Comment

by:psychogr
ID: 33715667
also try changing 'view' in windows explorer. Use 'list view' instead of thumbnails because the process of creating a thumbnail for each of your files (specially image files) will decrease your bandwidth.

You might also want to make it permanent..
When you are on shared folder, go to 'View -> Customize this Folder'
Then choose as a template for the folder 'Documents (for any file type)' and make sure you have checked the box below saying 'Also apply this template for all subfolders'

Good luck :)
0
 

Author Closing Comment

by:trippa666au
ID: 33750468
Not sure exactly which solution sorted it out in the end but thanks for all the suggestions
0

Featured Post

Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Last week, our Skyport webinar on “How to secure your Active Directory” (https://www.experts-exchange.com/videos/5810/Webinar-Is-Your-Active-Directory-as-Secure-as-You-Think.html?cid=Gene_Skyport) provided 218 attendees with a step-by-step guide for…
In-place Upgrading Dirsync to Azure AD Connect
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question