[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 742
  • Last Modified:

screen running shell with another rc file

Hi, I have special configuration file for bash in some cases.

bash --noprofile --rc-file .mybashrc (I don't want to load the default one)

So I have s script where I run the command above.
But when I run a screen, it runs bash with default rc files and profile one.

so i tried to pass to screen as -s the script calling bash with rc file, but screen terminates immediately, no error thrown.

One last idea I have is merge my configs and direct loding based on some environment variable or so.

Are there other options?
0
DalHorinek
Asked:
DalHorinek
  • 2
  • 2
1 Solution
 
gremwellCommented:
One problem with your setup is that you have an unnecessary dash in 'rc-file' option, it should be:
 bash --noprofile --rcfile .mybashrc

When passing a value of -s parameter you have to specify a _path_ to a shell program, you cannot specify shell command there. Consider the following setup:

1. Your alternative Bash RC script:
abb@d820:~$ cat .bashrc_alt
echo Hi from .bashrc_alt
2. A wrapper around bash which will configure it as needed:
abb@d820:~$ cat bash_altrc
#!/bin/bash
exec bash --rcfile "$HOME/.bashrc_alt" $*

abb@d820:~$ ls -l bash_altrc
-rwxr-xr-x 1 abb abb 54 2010-09-09 13:49 bash_altrc
Now:

abb@d820:~$ bash
Hi from .bashrc
abb@d820:~$ exit

abb@d820:~$ ./bash_altrc
Hi from .bashrc_alt
abb@d820:~$ exit
After that

abb@d820:~$ screen -s /home/abb/bash_altrc
should invoke screen with alternative Bash rc script.
0
 
pvzwedenCommented:
You can use the -s option, however you need to tell screen that you are giving extra options to the shell.

Try: screen -s -- bash --noprofile  --rc-file .mybashrc

You need to place the -s option last. The "--" tells the command line it's the last option that is being given to the "screen" command.

Other option would indeed be to edit the default bashrc that get's called from your homedir to make a choice based on a profile option.

Patrick
0
 
gremwellCommented:
I stand corrected, -s does not take an argument. Still, it should be --rcfile, not --rc-file.
0
 
pvzwedenCommented:
Gremwell, the --rc-file option is indeed incorrect.

From the man page:
 --rcfile file
              Execute commands from file instead of the standard personal initialization file ~/.bashrc if the shell is interactive (see INVOCATION below).
0
 
DalHorinekAuthor Commented:
I'm sorry for confusing by rc-file, sure it's rcfile.

gremwell, thanks, your way is working ok, that's what I tried, but I had an error somewhere, don't know where, and screen immediately terminated.

Now it's ok.

pvzweden

screen -s -- /bin/bash --noprofile --rcfile .mybashrc
Actually doesn't work, cuz it says Cannot exec '-': No such file or directory, because -s needs an argument, so it takes the following - (i don't know what it does with the other one - ) :)

Anyway thank you.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now