unable to send emails on Blackberry

Ok I am stumped, hence the reason for asking this question.

We had issues with our BES, I checked and the ESM wasn't updated to match exchange server.  I updated the BES to match.

Then we start getting one of these two errors:

Desktop Program Unable to Submit Message  or
Unlisted Message Error

I did research and found this article  http://na.blackberry.com/eng/support/software/sendas.jsp

I followed the tree they provide and it resolved our issue, it was the "set send as" tool that fixed the issue.

Now for some reason my blackberry started giving me this error again (unlisted message error).  I can receive emails fine, send emails using my hotmail acct.  BB works fine except can't send emails from BES acct.  I checked the send as permission for me and it was missing so I added it, still same result.  I deleted my acct from BES and readded and reactivated, still same result.

Does anybody know of something I'm missing?
LVL 1
DRSLTAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
mattclarifiedConnect With a Mentor Commented:
Hi,

Is your account a Domain Admin account? As if it is your domain schema will automatically remove any send as and receive as properties from your account for security. The best option in this case is to setup a seperate 'Admin' account for yourself and use runas, and then remove domain admins from your account and you will be able to use your BB properly again :0)

M@
0
 
dax_badCommented:
Does the the BES application account have send/receive as checked on your mailbox?
0
 
DRSLTAuthor Commented:
matt

i removed domain admin from my acct (i've had it there for awhile and had NO problems with my BB)

i removed it and then reapplied send as permissions and still get same error.  it looks just like everybody elses that works fine, thats why it has me stumped.

one stupid question (might be it) i did download a new theme the other day for my BB.  it had the issue, then when i resolved it yesterday for everybody mine worked fine, then last night is when it started acting up.

hope that all makes sense
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
mattclarifiedCommented:
The domain admin will deffo have been causing you problems since you updated BES, It may take a while to replicate to your account that you are not domain admin (or any kind of admin for that matter, enterprise, etc) I would recommend removing the admins from your account, wait 30 mins to an hour, restart the blackberry services on the BES then delete your account from the BES (and purge it) then try activating the BB again.
I cant see why the theme would make any difference to activating your BB, might be worth wiping the BB and starting from scratch though

M@
0
 
DRSLTAuthor Commented:
k thanks i'll try those working my way down.
0
 
DRSLTAuthor Commented:
ok i didn't try anything you suggested that second time.  i did remove domain admins and it still didn't work, so i just rebooted my DC and when it came back up it was working.  so you were probably right on the replication part.

thanks for your help, i never would have though of that.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.