• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1564
  • Last Modified:

web.comfig getting an error

I tried 3.51 and 4.0 but I keep getting this error

Server Error in '/ATech' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

Source Error:


Line 19:     </customErrors>
Line 20:
Line 21:     <compilation debug="false" targetFramework="3.5"/>
Line 22:    
Line 23:     <!-- Web.Config Configuration File -->
 

Source File: \\nawinfs02\home\users\web\b393\rh.kbhatti\ATech\web.config    Line: 21


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.3615; ASP.NET Version:2.0.50727.3082
0
goodk
Asked:
goodk
2 Solutions
 
antonybrahinCommented:
you are not required to mention -- targetFramework="3.5"
0
 
ayan2010Commented:
You can try with the following code in webconfig.

<compilation debug="true" defaultLanguage="c#">

<customErrors mode="Off" defaultRedirect="yourerrorpagename.aspx">
      <error statusCode="404" redirect="yourerrorpagename.aspx?code=404"/>
</customErrors>

0
 
goodkAuthor Commented:
ok, thanks seems like the website provider www.readyhosting.com is not willing to upgrade to newer version of compilation.  
So I am confuse what to do?
 
I am up for a renewal.  May be I have to find a better service provider??
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now