set .cfm as default in apache/coldfusion/ on an Ubuntu system

For some reason, my browser will not default to a index.cfm file. I have no index.html file in that directory and am getting "File not found" when pointing to that directory i.e. "www.mysite.com/users/".

If I include the index.cfm file ("www.mysite.com/users/index.cfm") in the path it comes up fine. Also, if I put an index.html file in the directory and again pointing to www.mysite.com/users/, it navigates fine to the index.html file.

Either something in apache or coldfusion server is not handling .cfm files by default.

Any help would be greatly appreciated.
sultanofshredAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
godd31Connect With a Mentor Commented:
Check out this Thread, sounds like there may be a new config file that you need to check.

http://ubuntuforums.org/showthread.php?t=1239133 

Another:
http://ubuntuforums.org/showthread.php?t=243804
0
 
godd31Commented:
Hi,
Under your Apache configuration you need to set it as a default file for viewing. I assume index.html is currently set. If you look at your config file you should find a line stating which file is the default file. Change it to index.chm and that should fix it..
0
 
sultanofshredAuthor Commented:
I believe that would be the httpd.conf file and it already contains the .cfm extension.

here is the file content:

# JRun Settings
LoadModule jrun_module /opt/coldfusion9/runtime/lib/wsconfig/1/mod_jrun22.so
<IfModule mod_jrun22.c>
    JRunConfig Verbose false
    JRunConfig Apialloc false
    JRunConfig Ignoresuffixmap false
    JRunConfig Serverstore /opt/coldfusion9/runtime/lib/wsconfig/1/jrunserver.store
    JRunConfig Bootstrap 127.0.0.1:51800
    AddHandler jrun-handler .jsp .jws .cfm .cfml .cfc .cfr .cfswf
</IfModule>
<Files ~ ".hbmxml$">
Order allow,deny
Deny from all
</Files>

I have already restarted both cf and apache... still not working
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
godd31Commented:
Hmm look for directoryIndex:

Edit httpd.conf

Open your Apache configuration file httpd.conf
# vi httpd.conf

Find out line that read as follows:
DirectoryIndex

Now set it as per your requirements:
DirectoryIndex index.html index.htm default.htm index.php index.pl

Save and close the file. Restart the Apache web server:

If that doesn't come up with anything let me know which version of Apache server you are running and on what OS etc..
0
 
sultanofshredAuthor Commented:
I could not file that line in either httpd.conf or apache2.conf
0
 
sultanofshredAuthor Commented:
I'm running apache2 on Ubuntu 10.04 and Coldfusion 9
0
All Courses

From novice to tech pro — start learning today.