Solved

Why did my 32-bit internet connections quit working on Windows 7?

Posted on 2010-09-09
17
558 Views
Last Modified: 2013-11-29
This is one of the most frustrating things I've seen.  I've seen several similar posts, but none has the answer.  My internet connection is fine: 64-bit browsers work, and other computers on the same router also can connect to the internet just fine.  I've tried all the firewall, winsock, browser add-on, ipconfig solutions and more, and my 32-bit browser still will not find the internet connection on my Windows 7 computer.  It did work briefly when I first got the computer, but then stopped.  There was no anti-virus or firewall installed at the time it stopped working.  Has anyone seen anything like this?
0
Comment
Question by:jma_gwn
  • 8
  • 7
17 Comments
 
LVL 3

Expert Comment

by:thetime
ID: 33637247
Which Browser are you using?

Firefox
Chrome
IE7 or 8
Opera
Netscape
0
 

Author Comment

by:jma_gwn
ID: 33637290
IE8 64-bit (working).
iE8, IE7, Firefox - all 32-bit (not working)
0
 
LVL 3

Expert Comment

by:thetime
ID: 33637354
Thank you,

Just for me to get my nuts screwed on properly, when you say it does not connect to the internet, you mean you can open the browser but you cannot display any specific web pages inside it?
0
 

Author Comment

by:jma_gwn
ID: 33637420
Correct.  It displays "Internet explorer cannot display the webpage".   Running "Diagnose Connection Problems" comes up with nothing.
0
 
LVL 3

Expert Comment

by:thetime
ID: 33637682
Thank you,

Please check that there is no proxy defined.

Lets start with one browser and focus on getting that one to work, the fix should be the same for all of them.

IE 8 - Got to>> Tools >> Internet options >> Connections >> LAN Settings

Please make sure "Use a proxy server for you LAN" is unchecked.

Also Set your IE 8 32 bit to be your default browser:

This is located under: Tools >> Internet Options >> Programs >> Click "Make Default"

Also Make sure that there are no Dial-up Connections defined By specifying that the browser should never dial a connection:

Got to>> Tools >> Internet options >> Connections -- Radial button set to "Never dial a connection"

Click Apply >> Click OK >> Close IE8 32bit and open it again to see if it works.

I am heading home quickly will continue support from there: Takes about 1 hour +- to get home.

Regards,

TT



0
 

Author Comment

by:jma_gwn
ID: 33638209
Done. Unforturnately, no change.  You did give me an idea, though.  If I make my 64-bit browser the default browser then I might not have to leave it open for other internet-using programs (such as update, Mozy) to work.  But I do want to get my 32-bit browser to work because there is no Flash player for 64-bit browsers.
0
 
LVL 3

Expert Comment

by:thetime
ID: 33638789
Thank you,

Can you do me a favor and head over to http://www.techspot.com/downloads/4716-malwarebytes-anti-malware.html and download malwarebytes?

Make sure it updates properly and run it, please post back if it detected anything.

Regards,

TT
0
 

Author Comment

by:jma_gwn
ID: 33638800
Thanks TT.  I'll have to wait until after work to give it a try (about 7 hours from now).
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 3

Expert Comment

by:thetime
ID: 33639190
From South Africa, so will be sleeping in 7 hours =)

I'll check back first thing in the morning to see the results.
0
 

Author Comment

by:jma_gwn
ID: 33646713
I did a full scan with Anti-Malware and it found nothing.
I'm pretty sure this has to do with some setting that is not part of the normal internet settings/firewall settings.  I am thinking I can't be the only one that has this problem -- I've seen on several forums the same problem, but never a solution!  (Oh-by the way, you cannot set a 64-bit browser to be the default browser).  I wonder if the problem has something to do with IPv6, but I can't figure out how to test that theory.
0
 
LVL 3

Expert Comment

by:thetime
ID: 33653024
Thanks for the response,

Let me have a look through a few more things, I'll get back to you with some more information.

TT
0
 
LVL 3

Expert Comment

by:thetime
ID: 33669710
Had a bit of a look at the IPv6 you mentioned, Cannot see that it would create any problems specific to these you are experiencing.

You can however disable it if you would like to test:

Open network connections >> Properties on local area connection >> un tick IPv6 >> apply/ok al lthe way out.

Remember that this does not completely disable IPv6 on your machine, you need to disable it in the registry to completely disable it. you can do that by reading this link:

http://support.microsoft.com/kb/929852
0
 

Author Comment

by:jma_gwn
ID: 33703609
Still waiting for someone who has successfully dealt with this problem.
0
 
LVL 3

Expert Comment

by:thetime
ID: 33714169
Hi,

Using IE8, Please try the following for me:

Tools >> Advanced >> Reset

Please make sure that you you tick reset personal settings.

Let me know if you can browse or not.

Sorry for the long silence, things are a bit crazy at work.

TT
0
 

Author Comment

by:jma_gwn
ID: 33716611
HI TT,
I really appreciate all your help; at least you are responding!  And I thank you.

The reset I have tried several times, and it hasn't worked (all it accomplished was wiping out all my personal settings).

I've seen this problem with several solutions in several forums, but none was quite this same problem, and it seems like I can't find someone who has seen it and solved it.
0
 
LVL 7

Accepted Solution

by:
blue-screen earned 500 total points
ID: 33921099
Try a "Winsock reset."

Copied from:
http://www.vistaheads.com/forums/windows-vista-home-premium/320642-running-32-bit-browser-64-bit-os.html

My problem was that I couldn't run a 32-bit browser at all, including IE7 and Mozilla, and couldn't connect to the internet with 32-bit apps.

But Dave's instructions to reset winsock fixed it.

Open a command prompt as an administrator

Type the following commands without the quotes:

"Ipconfig /flushdns" and press Enter.

"Netsh int ip reset" and press Enter

Vista will then want to be rebooted. Go ahead and reboot.

When it starts back up, again open command prompt as administrator.

Type the following commands without the quotes:

"Netsh winsock reset"

Vista will then want to be rebooted. Go ahead and reboot.
0

Featured Post

Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

Join & Write a Comment

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup". After a while, you have entered a loop for Auto repair which does not fix anything and you will be in a  panic as all your work w…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now