how do i stop text overlapping in Internet Explorer 8

I have designed a website which looks great everywhere except in IE 8. I have adjusted the CSS on one piece of overlapping text (on my front page) but it has no effect in Explorer. I can see the changes in Firefox on my mac but not in IE on the PC....  arrgh - Internet Explorer - can't say I like it!
TheCommanderAsked:
Who is Participating?
 
MarblemanConnect With a Mentor Commented:
@justinyeung: you cannot tell customers to put their browser into to comp.mode... ;-)

So try to put the browser into strict mode with a doc type on top of the page:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"  "http://www.w3.org/TR/html4/strict.dtd">

Then IE8 bevaves much more like Firefox. But be aware of IE7... strict mode can lead to some strange behaviour here... But I say it is better to make some extra styles for IE7 and have the rest straight forward than the other way round!
0
 
Justin YeungConnect With a Mentor Senior Systems EngineerCommented:
try compatibitliy mode on IE8 and see if you see the change


Tools-->Compatibility View Settings-->add your address to it.
0
 
TheCommanderAuthor Commented:
figured it out!
0
 
TheCommanderAuthor Commented:
Helped me on my way
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.