Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 836
  • Last Modified:

windows 7 sound lagging

Hello,

New Windows 7 32bit Home, Dual-core E5400 3gb ram
New Creative X-Fi Xtreme Audio PCI-e card

Sound is delayed by 100 or so miliseconds, I have installed latest drivers from Creative and also let Windows install drivers from microsoft but still get this audio lag.

Any help much appreciated.

Thanks,

Ash
0
ash-2plus1
Asked:
ash-2plus1
  • 14
  • 8
1 Solution
 
gikkelCommented:
What are your system specs?  What other cards do you have in your pcie slots?  Try updating your system bios.  Uninstall driver and audio pack, restart.  If Windows tries to use a built in driver for the card when it finds it, let it.  Test.  If that doesn't work, reinstall driver and audio pack.
0
 
ash-2plus1Author Commented:
Its a Biostar G31D-M7 board with E5400 and 2 x 2gb corsair value 800mhz DDR2 sticks, 250gb WD Caviar Blue Windows 7 Home Premium 32bit

Have tried so far:
Drivers from Creative
Drivers from Microsoft (auto installl when card detected)
0
 
ash-2plus1Author Commented:
No other PCI-e or PCI slots in use.

No newer update to BIOS
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
ash-2plus1Author Commented:
oh, also experience the audio lag with the on-board sound hence the Sound Blaster X-Fi
0
 
gikkelCommented:
Enter system bios.  Go to advanced -> Power Configuration (ACPI Settings).  Go down to "High Performance Event Timer" and change to enabled.  While you're there, take note of your ide settings...how are they configured?  Go to South Bridge Configuration -> Audio Controller.  Set to Disabled.  Save and reset.  Test.
Also ensure your chipset drivers are current:
http://www.biostar.com.tw/app/en/mb/driver.php?S_ID=386
0
 
ash-2plus1Author Commented:
I will check this and come back to you.
0
 
ash-2plus1Author Commented:
Enabled HPET and disabled onboard sound -  no change i'm afraid, also updated chipset drivers - nothing strange in IDE settings.
0
 
gikkelCommented:
What exactly are the ide settings?  Are you using sata or ide?
I guess the question I should have originally asked is when does this occur?  During games? During movies? During everything? If its occurring with both cards, it may be a software issue...or a video issue.
0
 
ash-2plus1Author Commented:
Both drives HDD and CD/RW are Sata

The issue occurs while playing audio through the line in and listening to the output on headphones plugged in to the speakers socket.

We use this setup to record DJ sets for a friend.
0
 
gikkelCommented:
Ahhhh, I see.  That makes a big difference.  
Right click on the speaker on taskbar and go to recording devices.  Click on the microphone and then properties.  Uncheck  "Listen to this device".  You'll then need to use creative's audio console to enable playback for the microphone.
0
 
ash-2plus1Author Commented:
These are the only tabs / options i have on the audio console.

There are no options for making the line-in or microphone pass through.
audio-console.png
0
 
ash-2plus1Author Commented:
0
 
gikkelCommented:
Take a look at ASIO and Audio Creation Mode. You should be able to enable playback with Audio Creation Mode.  ASIO should further reduce your latency issues.  If you can't playback with Audio Creation Mode, restore it from sound recorder.  
 http://www.asio4all.com/
0
 
ash-2plus1Author Commented:
I have installed the beta drivers from the creative site, and ticked the monitor check box on the creative console - feeling positive about this one :-)

If this does not work i will try asio4all but i have tried this previously without much luck - this entire problem has eluded me for over 6 months on and off.
0
 
ash-2plus1Author Commented:
The beta drivers did not make much difference to the delay.

How easy is asio4all to setup?

Could you recommend a good setup guide?
0
 
fireguy1125Commented:
Uninstall the existing audio driver through device manager.  Install the XFXA_PCDRV_LB_1_04_0000.exe driver from the Creative website. For the additoinal controls, you will also need the X-Fi extreme audio pack XFXA_PCDRV_LB_1_03_02.exe. You can put those executable names in the search on the website, it will take you right to the download.
0
 
ash-2plus1Author Commented:
I have already installed both of those packs and do not see the pass through option / Music creation mode settings - and i still receive a delay with 'listen to this device' ticked.
0
 
gikkelCommented:
Switch to a mac.  Any luck with ASIO?
0
 
ash-2plus1Author Commented:
"Switch to a Mac" is not really of any help...

After selling a computer over double the spec of the previous Windows XP machine and investing in Windows 7 for the customer I am re-paid with this rubbish - the customer summed this up best with the comment "This just worked on XP"

ASIO does not seem to do what i want it to do - [Line in -> Speakers] without delay.
0
 
gikkelCommented:
I think I may have found it...
Go back into Windows sound and go to the recording tab.  Right-click in the window and show disabled devices.  An additional device should show up...you can then disable the listen to this device in the other, and enable it in that.  I think the major issue is feedback, and the reason why Microsoft has it set the way it does.  Upon my test, I had immediate playback, unfortunately with my current set there was also immediate feedback...
On a side note, I don't really like mac - and my comment was a joke - but they do work good for music.  
Let me know if this works for you.
0
 
ash-2plus1Author Commented:
Hi,

Thanks to everyone who helped, I managed to sort this problem out.

Can you guess what I did?

RELOADED WITH WINDOWS XP!

gikkel: your last comment about the hidden device - there was no hidden device :-(

Very annoyed by the whole thing really - but not the first time Microsoft have caused problems and I am sure it won't be the last.

Thanks,

Ash
0
 
ash-2plus1Author Commented:
Although everyone was very helpful with this problem, after spending hours trying to solve it i decided the best way was to just reload the machine with Windows XP.
0
 
gikkelCommented:
Update:
I'm unsure what software was actually being used to test the delay...but I noticed I had the same issue when using Cubase.  If you change from the direct X asio driver to the generic asio driver, the latency issue dissapears - and this is with professional audio software. input is 20ms, output is 20ms.  With direct x it was 220 ms and 30 ms.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 14
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now