Link to home
Start Free TrialLog in
Avatar of SeaSenor
SeaSenorFlag for United States of America

asked on

Issues after installing exchange 2010

HI,
I'm currently running exchange server 2003 standard on a windows server 2003 box.

I also have another box with exchange 2010 on windows server 2008R2.

I joined the domain (member server) and installed exchange 2010 without too much trouble.
Added the server to the site, and for a while was able to test/coexist.

A student i had, ran a command (not sure which one) that reset the permissions in AD for these servers.
I re-ran DomainPrep for the exchange 2003 server and all is well with it.
However, I cannot get any domain prep to re-run for 2010.
A DOS window opens and says copying files, then it just goes away.
I need to get the permissions reset and cannot seem to do so.

any suggestions?
Avatar of endital1097
endital1097
Flag of United States of America image

open a command prompt and run
setup /PrepareAD

the command prompt should stay open and display any errors
make sure the account used has the required permissions
Avatar of SeaSenor

ASKER

the command prompt opens, but says "copying files" and then give the percent... but then rapidly disappears. I cannot see the error it gives.

HI,
please check Prepare Legacy Exchange 2003 Permissions
 http://technet.microsoft.com/en-us/library/aa997914.aspx
it seems you need to run the command again (setup /PrepareLegacyExchangePermissions)
for more details read Prepare Active Directory and Domains
http://technet.microsoft.com/en-us/library/bb125224.aspx
c:\exchangesetuplogs should have logs to review for errors
none of the error logs are dated recently.
Avatar of George Sas
are you running the command on a DC or on the exchange server ?
Is the user logged in an enterprise admin ?
I'm running the command on the 2010 exchange server from the setup disk.
Yes the user is me, logged it. I ran it before during the initial install.
from command prompet , go to the exchnage 2010 installtion cd and run setup /pl using a member of the Enterprise Admins group
You must run this command on a computer in the same domain and in the same Active Directory site as the schema master.
You can run this command from any Windows Server 2008 server in the forest
There must be a log file updated and the setup /PrepareAD should give you an error , not just disappear in thin air.
Did you run the setup /PrepareAD in a command prompt as suggested ?
did you run setup.com/ /PrepareAD or setup.exe/ /PrepareAD?
use setup.com/ /PrepareAD
TarekIsmail: :) good point there ... didn't thought of that :)
i have tried both  setup.com and setup.exe


you did that from a command prompt and the window just disappears ??
Could you please post a copy of the code that appears when you run the command ?
the window closes and i can't see what is showing up.  I've tried hitting pause to stop the window from closing, but i can't catch it.

ok.
Can you do it like this :
Go to START.
RUN
Type in : cmd
hit enter
a black window will open (called a command prompt)
(check your DVD driver letter (D: or E: or let's say X:)
on the command prompt type :
X:  
then enter
your prompt will look something like :
X:\
then write :
setup.com/ /PrepareAD
hit enter.

let me know how it went.

(I copied the files to the C: drive in a folder "EXsetupfiles" to make it faster)

its just sitting there like this:

C:\EXsetupfiles\setup.com /PrepareAD
_
If i want to completely remove this server from exchange org/site without affecting my 2003 server, what's the best way to go about it?

as much as I don't want to do this, I may need to.

just uninstall it from the setup.
run setup.exe and choose uninstall. If you did not moved any maiboxes on it nor done other changes to your existing exchange you should be fine.
Btw , how many users you have on your 2003 environment ?
Just under 200.  

can you upload the file from here

c:\exchangesetup\exchangesetup.log

setup /prepareAd
or setup /prepareschema should have done it (as endital suggested first and other experts repeated after that..)

There might be something else going on here which we will know from the logs.
hey all
thanks for the suggestions.

here is where it stands:

no matter what i try,  it says copying files, counts the percentage copied, then goes away. It does display a line of text before disappearing, but i cannot read it.
I tried to put the command in a batch file with 'pause' at the end, but it didn't help. The cmd window stayed open, but it didn't list the text i was looking for.
I can read one word before it disappears.  "roles"

the setup logs are all dated to the installation of the initial setup which was working fine.

I tried the /prepare schema also, and it had the exact same results.

ugh i'm tired....
can you upload the log file from here
c:\exchangesetup\exchangesetup.log


it will be couple of mb's - so you can zip it and then upload.
the setup logs are not being modified.
It doesn't begin the setup process.. it starts copying files and stops.

 
lets try something more explicit

Create a subfolder called log under this
c:\exchangesetup\

Setup.com /PrepareTopology /LogFolderPath:"c:\exchangesetup\log\"
i booted to safe mode and i finally got to see the error code.

it says: error code 5

(thats after it copies approx. 23% of the files while trying to run setup)

I am logged in as administrator
SeaSenor where did you get the installer from ?
on a DVD media
or did you download it ?

The setup files are probably corrupted / damanged if they are not running.
if you downloaded it - can you redownload and try again.
Use some download manager to do it this time.
it is on DVD.

I can run setup.exe from the DVD but all options are grayed out except to add the check to the checkbox for Unified Messaging system.

i really think this is permissions related.

isn't error code 5 an access denied error?

and you are logging on the DOMAIN and not as a local user ?
Do you have any kind of events in the eventlogs ?

Are they marked as installed and grayed out or just grayed out ?
exchange1.png
Try and run it from a command prompt :
Setup.com /mode:Uninstall
ASKER CERTIFIED SOLUTION
Avatar of SeaSenor
SeaSenor
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial

Whats the permission error your getting are you able to create mailbox or is it given permission error also