Link to home
Create AccountLog in
Avatar of Sean Rhudy
Sean RhudyFlag for United States of America

asked on

You do not have permission to send to this recipient - Send As

Hi, I have 1 user that can send his own email, but I also added 2 other users mailboxes to his Outlook.  I delegated each to the first user.  I went into mailbox rights and and gave full mailbox access.  I also went to the security tab and grandted send as.  I also tried taking off the send as permission, but same result.  They also have the send on behalf permission.  The second user works fine, but if I try to send as user 3, I get the above error.
Avatar of gcolquhoun
gcolquhoun
Flag of United Kingdom of Great Britain and Northern Ireland image

Since you applied the settings on exchange have you restarted (or ran a gpupdate) on the users machine? Just to ensure the permissions have applied properly. You shouldn't need the send as permission unless you want it to show that they are sending on behalf of as opposed to sending from.
run this from exchange shell

Add-ADPermission -Identity "Ellen Adams" -User TedBrem -AccessRights extendedright -ExtendedRights "send as"

This will grant send as rights to TedBrem for Ellen Adams mailbox.
http://technet.microsoft.com/en-us/library/bb124403(v=EXCHG.80).aspx

repeat it for the other mailbox.
Avatar of Sean Rhudy

ASKER

Yes, I've restarted the PC as well.

This is Exchange 2003.
Mail is coming in for the same account into the correct mailbox, but when I use that users email address in the from field to send an email, that's when I get the error.  The other user is setup the same way, and everything works.
Oops. Will post back
open aduc from exchange server 2003.
Go to View > Advanced
Go to appropriate container and then right click on the user for which you want to grant send as permissions.
go to security tab
click add

add the name of the user who will be "sending as"
scroll down to the bottom - check send as
click close.

repeat this for the second user too.

test it by logging in as the user - and FROM address as the other one.

thanks
That's already been done.
if that is done, then restart information store service and try again. it should work.

it maybe related to this.

start > run > regedit
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
Value name: Mailbox Cache Age Limit

default value is 15 mins, you can lower it to 5

After you change the registry, you need to restart info. store service for this to take effect

see this kb too.
http://support.microsoft.com/?kbid=327378

Try restarting the info. store and see if it works. It should.
Did that, same result.
ok this is weird.
Let me come up with some powershell thing to test this. will post back tomorrow.
It's late here..
Ok, When I type the email address in the from field, it fails.  But If I click FROM and choose the mailbox from the GAL, then it works fine....how do I fix it so the user can just type the email address.
ASKER CERTIFIED SOLUTION
Avatar of sunnyc7
sunnyc7
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
thanks for the points sean