Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

You do not have permission to send to this recipient - Send As

Posted on 2010-09-09
13
Medium Priority
?
397 Views
Last Modified: 2012-05-10
Hi, I have 1 user that can send his own email, but I also added 2 other users mailboxes to his Outlook.  I delegated each to the first user.  I went into mailbox rights and and gave full mailbox access.  I also went to the security tab and grandted send as.  I also tried taking off the send as permission, but same result.  They also have the send on behalf permission.  The second user works fine, but if I try to send as user 3, I get the above error.
0
Comment
Question by:Sean Rhudy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
13 Comments
 
LVL 3

Expert Comment

by:gcolquhoun
ID: 33642441
Since you applied the settings on exchange have you restarted (or ran a gpupdate) on the users machine? Just to ensure the permissions have applied properly. You shouldn't need the send as permission unless you want it to show that they are sending on behalf of as opposed to sending from.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33642459
run this from exchange shell

Add-ADPermission -Identity "Ellen Adams" -User TedBrem -AccessRights extendedright -ExtendedRights "send as"

This will grant send as rights to TedBrem for Ellen Adams mailbox.
http://technet.microsoft.com/en-us/library/bb124403(v=EXCHG.80).aspx

repeat it for the other mailbox.
0
 

Author Comment

by:Sean Rhudy
ID: 33642520
Yes, I've restarted the PC as well.

This is Exchange 2003.
0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 

Author Comment

by:Sean Rhudy
ID: 33642556
Mail is coming in for the same account into the correct mailbox, but when I use that users email address in the from field to send an email, that's when I get the error.  The other user is setup the same way, and everything works.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33642726
Oops. Will post back
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33642766
open aduc from exchange server 2003.
Go to View > Advanced
Go to appropriate container and then right click on the user for which you want to grant send as permissions.
go to security tab
click add

add the name of the user who will be "sending as"
scroll down to the bottom - check send as
click close.

repeat this for the second user too.

test it by logging in as the user - and FROM address as the other one.

thanks
0
 

Author Comment

by:Sean Rhudy
ID: 33642812
That's already been done.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33642844
if that is done, then restart information store service and try again. it should work.

it maybe related to this.

start > run > regedit
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
Value name: Mailbox Cache Age Limit

default value is 15 mins, you can lower it to 5

After you change the registry, you need to restart info. store service for this to take effect

see this kb too.
http://support.microsoft.com/?kbid=327378

Try restarting the info. store and see if it works. It should.
0
 

Author Comment

by:Sean Rhudy
ID: 33642947
Did that, same result.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33643004
ok this is weird.
Let me come up with some powershell thing to test this. will post back tomorrow.
It's late here..
0
 

Author Comment

by:Sean Rhudy
ID: 33643014
Ok, When I type the email address in the from field, it fails.  But If I click FROM and choose the mailbox from the GAL, then it works fine....how do I fix it so the user can just type the email address.
0
 
LVL 28

Accepted Solution

by:
sunnyc7 earned 1000 total points
ID: 33643027
maybe its taking the entries from some nk2 files or so.

try this

start typing the email address - and when the auto-complete drop down pops - select it and press delete.

then try it just with the email address - email@domain.com
--
I think the settings kicked in after the restart.
0
 
LVL 28

Expert Comment

by:sunnyc7
ID: 33643068
thanks for the points sean
0

Featured Post

Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question