Solved

Windows 2008 Server second intranet NIC causes first NIC Internet to disconnect

Posted on 2010-09-09
3
2,025 Views
Last Modified: 2012-05-10
I have two NIC connections on IBM server running Windows 2008 Server w/ SQL 2008. The first NIC has been running great for the first month while in production at client site. We have now moved the CISCO ASA 5500 from the old 2003 server second intranet NIC to this new 2008 Server on its second NIC card.

The config on the first NIC for Internet is ip 192.168.2.7 / sm 255.255.255.0 / gw 192.168.2.10 / dns 192.168.2.10. .10 is our ZyWALL firewall device.

The config on the second NIC for CISCO is ip 192.168.3.2 / sm 255.255.255.0. No gw or dns.

When I enable the second NIC - its cause all the clients to lose connection to the server. They can't ping 192.168.2.7 anymore. However I can still get out on Internet from the server console. If I disable the 2nd NIC - the clients can ping the server again.

What is causing this? It worked fine on the 2003 server. Thanks.
0
Comment
Question by:interc3905
3 Comments
 
LVL 57

Expert Comment

by:giltjr
Comment Utility
Are all of the clients in the 192.168.2.0/24 subnet?  
If not, do they have a specific route to get to 192.168.2.0/24 or do they use their default route/gw?

Have you displayed the routing table on the server?

netstat -rn

What does it look like before you enable NIC2 and after you enable NIC2?

0
 
LVL 59

Expert Comment

by:Darius Ghassem
Comment Utility
If you have a internal DNS server then point the server to this DNS server in your TCP\IP properties.

Go to your Network Connections click Advance Settings check your binding order to make sure your primary NIC is listed first.
0
 

Accepted Solution

by:
interc3905 earned 0 total points
Comment Utility
I reversed the settings on the two NIC cards and now it works. Also found this TIP from Microsoft:

Windows 2008 introduces a "strong host model" that doesn't allow the different NICs to talk to each other.  For example, if a request comes in on the 2nd NIC and there's no default gateway setup, then the NIC will not use the 1st NIC to reply to the requests.  (even though there's a default gateway setup on that 1st NIC).  

In order to change that behaviour and go back to a 2003 model, you go to the command prompt and then you type:

netsh interface ipv4 set interface NLB weakhostreceive=enable
netsh interface ipv4 set interface NLB weakhostsend=enable

(where NLB is the name of the network interface... default is Local Area Connection)

 - Jim
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Join & Write a Comment

I was asked if I could set up a fax machine so that incoming faxes were delivered to people's Exchange inboxes and so that they could send faxes from their desktops without needing to print the document first.  I knew it was possible but I had no id…
Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now