Link to home
Start Free TrialLog in
Avatar of farzanj
farzanjFlag for Canada

asked on

tftp server timeout problem CentOS5.5 Linux

I want to setup PXE boot using tftp.  Well, TFTP never worked.  There are two computer connected by a switch.  DHCP seems to be working fine.  I used 192.168.0.0/24 net.  Server has IP 192.168.0.254 and client has IP of 192.168.0.10.  I was constantly getting TFTP TIMEOUT error message.  I started looking at /var/log/messages and found the following:

Sep  9 18:24:59 localhost in.tftpd[6372]: tftpd: read(ack): No route to host
Sep  9 18:25:04 localhost in.tftpd[6373]: tftpd: read(ack): No route to host

I added the following route
route -add 192.168.0.0 netmask 255.255.255.0 gw 192.168.0.10

Noting works for me
Here is the routing table.

[root@localhost ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     192.168.0.10    255.255.255.0   UG    0      0        0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth0


What do I need to do?  I thought that if you were in the same subnet you didn't need a gateway.  What am I not thinking right?
ASKER CERTIFIED SOLUTION
Avatar of WizRd-Linux
WizRd-Linux
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of farzanj

ASKER

Sorry, forgot to tell you that I disabled IPTABLES AND SELINUX.
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of farzanj

ASKER

Dear WizRd-Linux:
FOR TFTP SERVER
# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0C:F1:FB:83:E1  
          inet addr:192.168.0.254  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:f1ff:fefb:83e1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:7924 (7.7 KiB)

# netstat -al | grep tftp
udp        0      0 *:tftp                      *:*

=================
FOR TFTP CLIENT

ifconfig
eth0      Link encap:Ethernet  HWaddr F4:CE:46:84:3C:D0  
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::f6ce:46ff:fe84:3cd0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:64 (64.0 b)
          Interrupt:138 Memory:f8000000-f8012800
netstat -al | grep tftp
NO OUTPUT
Avatar of farzanj

ASKER

Hi arnold:

I have not set bootp at all, just trying DHCP.

There is not file /etc/tftpboot. However I do have the following
# ls -ld /tftpboot/
drwxr-xr-x 4 root root 4096 Sep  9 10:13 /tftpboot

# ls -l /tftpboot/
total 40
-rw-r--r-- 1 root root     0 Sep  9 17:20 boot.msg
drwxr-xr-x 2 root root  4096 Sep  9 12:21 centos5.5
-rw-r--r-- 1 root root 13148 Sep  8 16:00 pxelinux.0
drwxr-xr-x 2 root root  4096 Sep  9 12:51 pxelinux.cfg


When I did
tftp localhost -c get boot.msg

It worked fine and I received the file without a problem

SOLUTION
Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of farzanj

ASKER

Thank you guys.  I think I figured it out.  I had multiple problem, I did have client firewall enabled after reboot.  DHCP had an error in it too.

I appreciate your time.  I passed this phase but still have problems that I would post shortly.