How do I include information about the error on the 500.shtml page on an apache server so I can see what the error is?

I have a cgi script that has vbeen running just fine on my client's apache server. I am a developer working on the scripts. today the script is erroring out with a standard error page and I can't tell why. I restored a formerly working backup copy, and it does not work. I then delteted everything except Print "Hello World", and that doesn't work!\

So, something is going on with the server, I guess, or I triggered some anti-malware code and all my scripts are disabled. I don't know.

What i would like is to know what the error actually is. When I access the error log in cPanel, I get nothing. Well, this is what I get:L

[Thu Sep 09 20:37:56 2010] [client 74.76.45.211] File does not exist: /home/healsrev/public_html/500.shtml, referer: http://www.healsreview.com/NewAuthTest.html

I think the file that didn't exist was 500.shtml. But now that I have created that file, I get that page when I run the script, as expected.

So, my question is: How do I get the error page to include the error information? Is this possible? What other error log could I look at?
jkurantAsked:
Who is Participating?
 
Dave BaldwinConnect With a Mentor Fixer of ProblemsCommented:
I not surprised that VS and FP can't change permissions since you can't do that 'remotely' on Microsoft IIS.  I use CuteFTP for file transfer and setting permissions on Linux/Unix servers.  Some Control Panels have a File Manager or Web-based FTP in them.
0
 
jkurantAuthor Commented:
I now know that the file that didn't exist, as shown in the error log, was a file linked on the error page. with that fixed, the scripts still do not run and do not write anything to the log. i think my scripts are just disabled somehow, but i can't find anything in cPanel to change that might fix it.
0
 
Dave BaldwinFixer of ProblemsCommented:
I don't think it's possible.  I went looking all thru the Apache docs online today for another question and all they say about errors is that you can change the error message page.  I don't have a site with Cpanel right now so I can't check.  Are you able to set or check permissions for the 'cgi' directory from cpanel?
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
DalHorinekCommented:
Check how your LogLevel is set, it should be at least

LogLevel error

If it won't do anything, try the debug one
http://httpd.apache.org/docs/2.2/mod/core.html#loglevel
0
 
jkurantAuthor Commented:
I was afraid it might not be possible, DaveBaldwin. The only access I have to the server is via cPanel.

In fact, I have found out what was the problem. The scrips lost their execute permissions and I had to have the server admins use "chmod 755" the scripts. The problem is that I am using Microsoft Visual Studio 2010 or even FrontPage to edit the website and these tools don't seem to know anything about file permissions. I cannot set the execute permission, as with chmod, from these tools.

Does anyone know of a good tool for editing files on an apache server with the ability to set the unix permissions? Really, all I need is to be able to set the permissions of the files on the server when they somehow get changed. I wonder if I could ftp into the server and change the permissions using WinFTP? (I am running Windows 7). Does anyone know how to set these permissions using cPanel or any other way?
0
 
Dave BaldwinFixer of ProblemsCommented:
Sorry, that should have been CoreFTP.  Filezilla is another popular FTP program.
0
 
jkurantAuthor Commented:
Ah ha! So that's what cPanel means: Control Panel.  I will get CuteFTP and use that to change the permissions. Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.