Solved

Unable to connect to Windows from Mac via SMB

Posted on 2010-09-10
5
833 Views
Last Modified: 2012-08-13
Unable to connect to a Windows SBS 2003 server from Mac (10.6.4)

The error pop-up says: connection failed. check the server name or IP address. -i have as i can connect to OWA with this address.

Attached is a screen cap of the error message and a cap of the terminal. Can someone help?
ubiq-hani-01.PNG
ubiq-hani-03.PNG
0
Comment
Question by:Luxtech
  • 2
  • 2
5 Comments
 

Expert Comment

by:lejim
ID: 33644982
What is your Windows version ?
If it's a Vista or 7 or Server 2008 This Windows uses NTLMv2 only protocol for authentication.
MacOsX relie on Samba for susch connection and Samba can't handle NTLMv2.

Their is a trick to force Windows to accept either NTLMv1 or NTLMv2

Try this in registry ( Widnows Menu / Run / regedit )

1. Run the registry editor and open this key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

1. If it doesn't already exist, create a DWORD value named
LmCompatibilityLevel

3. Set the value to 1

4. Reboot
0
 
LVL 1

Author Comment

by:Luxtech
ID: 33645038
this is sbs 2003 sp2. i found the key and it was set to (2). i have changed this and will schedule a reboot tonight.
0
 
LVL 7

Expert Comment

by:njxbean
ID: 33668063
Is it prompting you to authenticate at all during this process?  Are you able to browse to the share and connect or are you using connect to server?  What is the syntax you are using? Im assuming you can ping it?  might also check the firewall on the server to see if it might be blocking access.  
0
 
LVL 1

Author Comment

by:Luxtech
ID: 33669913
I am using finder/connect computer with the following syntax smb://servername (have also tried smb://serverIP)I I can definately pint it. I can also telnet on port 445. It asks for username and password. I am using the correct credentials because if i get them wrong i get a bad username/password error instead.
0
 
LVL 7

Accepted Solution

by:
njxbean earned 250 total points
ID: 33671296
Im curious.  Try changing the TCP acknowledgment.  

Easiest way to do it is the use this startup item.

http://systemsboy.com/2006/02/delayed-ack-startup-item-for-intel-macs.html

If that has no effect, just uninstall it.  You can also try making the change on the server.

http://support.microsoft.com/kb/328890/

I have seen this change make a dramatic difference in speed from Mac clients to Windows servers.  
0

Featured Post

Zoho SalesIQ

Hassle-free live chat software re-imagined for business growth. 2 users, always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Connectivity using SMB Symptoms When connecting to Windows Server shares from a Mac you receive an error similar to "Connection failed because the original item could not be found"Authentication persistently fails to a Windows Server from a Mac wi…
The /etc/authorization file in Mac OS X 10.x can be used to control access to the various panes of the System Preferences amongst other things. It’s used by some of us Mac Sys Admin’s to give Standard Users access to System Prefs panes that only adm…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now