• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1107
  • Last Modified:

The system cannot log you on due to the following error: The RPC Server is unavailable

Hello,

I´ve got the following problem:

One of our Terminal Server 2003 from two days ago to this day on each morning i´ve received the following error from all users:

The system cannot log you on due to the following error:
The RPC Server is unavailable

When i´ve tried to access remotely (RDP) with the domain administrator account i also get this message.

I was looking at the knowledge base and verified what are the common solutions:

1) The firewall is disabled
2) The DNS are from primary and secondary DCs (and i can connect them by IP or Name)
3) The IP Address and Subnet mask is configured correctly.
4) The DNS entry of the Terminal Servers are correct.
5) I´ve verified the RPC services and its running

If i restart the terminal server the problem is solved until the next morning...

So i dont have many clues here and thats why i´m asking to the Experts :)

Thanks,
Paulo
0
pmaribeiro
Asked:
pmaribeiro
1 Solution
 
ArneLoviusCommented:
Is there anything in the event logs ?

0
 
pmaribeiroAuthor Commented:
I didnt found anything related to this issue.
0
 
goyal_251Commented:
try "Disable NetBIOS over TCP/IP" option
refer below link more detail it may help:-
 http://www.eggheadcafe.com/software/aspnet/30294878/rpc-server-unavailable.aspx
0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
abhijitwaikarCommented:
Yes, agree with goyal_251, if you have DHCP enabled then try "Default" option or if you have static IP then try "Enable NetBIOS over TCP/IP".

1. Also verity correct DNS settings.
Troubleshooting "RPC Server is Unavailable" in Windows -   http://support.microsoft.com/kb/224370
 
2. Verity correct Time and Time Zone settings.
 
3. Verity that "TCP/IP NetBIOS Helper" is running and set to auto start after restart.
 
 4. Verity that "Remote Registry" is running and set to auto start after restart.
 
Its recommended to reboot the computer after changing the required settings.
0
 
pmaribeiroAuthor Commented:
goyal_251,

Well since this Server has a static IP Address the Netbios over TCP/IP shall be disabled automatically , but eventhough i´ve disabled it. Tomorrow i´ll verify if this works.

abhijitwaikar:,

All the solutions pointed are correctly configured or working.

thanks,
0
 
pmaribeiroAuthor Commented:
Since this solutions was the only different from the setting in my scenario, i´ll assume that Disabling the Netbios over TCP/IP was the solution. At least for the last 3 days everything is fine.

Beeing so i´ll accept this solution as the correct one.

0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now