Solved

IE "Auto Detect Settings" lagging initial internet connection, why?

Posted on 2010-09-10
9
1,901 Views
Last Modified: 2013-12-08
Currently for all users within my organization when the "Auto Detect Settings" check box is selected under LAN Settings in IE Options the intial loading of a new page is extremely slow.

If Auto Detect Settings is turned on when a new browser window is opened or a new tab it takes about 30 seconds before the users browser connects to their home page or any webpage. Once the home page is loaded up the internet is very fast though. Its like it is trying to auto detect a proxy and timing out before it finds one then defaulting to the DNS or something.

This is occuring on all PC's running Windows XP IE 7 or IE 8 and Windows 7 PC's running IE 8.

Our PC's are on the 10.30.1.xxx subnet and have this problem. Our servers running on the 10.10.1.xxx and 10.20.1.xxx subets have the same Auto Detect Setting enabled in IE but do not experience this lag when initially loading a website.

Can anyone explain what the Auto Detect Settings function does or why it may be lagging the initial internet connection on our 10.30.1.xxx subnet? I am just looking for clues at this point since I dont even know where to begin. Should I look at Wireshark packet captures to look for a certain communication that may be timing out?

Thanks in advance
0
Comment
Question by:AIC-Admin
  • 5
  • 4
9 Comments
 
LVL 2

Expert Comment

by:jtokarchuk
ID: 33646118
You are exactly rioght. When auto detect settings are on, every time you open a new connection (tab, browser, etc) your machine will actively search for a proxy server.

Resolution: uncheck everything in the LAN settings box. Even uncheck auto detect settings. You will notice that lag dissapear.
0
 
LVL 2

Expert Comment

by:jtokarchuk
ID: 33646136
As far as to why on one subnet and not the other, not too sure. That's an odd one. Are you NAT ing over multiple subnets? Or are they comlpetely segregated?

Perhaps the DNS is not as snappy on the one subnet.
0
 
LVL 3

Author Comment

by:AIC-Admin
ID: 33647174
Yes we do use NAT since we have multiple VLANS in place. We are using Juniper firewalls and Procurve switches. Whats ever more odd is that we have a Cymphonix Proxy device that we using but it does not sit in line between our user network switch and the firewall. I didnt mention that in the initial problem because with or without pushing traffic through our Cymphonix proxy we have this lag IF auto detect settings are turned on. So even when we specify a proxy with Auto Detect turned on the browser still sits and wait to auto detect a proxy before going through the designated Cymphnix proxy.
We used to have an ISA server that we have gotten rid of. I wonder if somewhere there is a residual configuration where the desktops are trying to locate our ISA server that no longer exists.  Any idea how I could tell if that is occuring?
0
 
LVL 2

Expert Comment

by:jtokarchuk
ID: 33647239
ruin - cmd - proxycfg.exe -- does this show anything?

If not, try a netsh winsock reset, perhaps that will flush out any residual crap laying around.

Does a manual entry of proxy server with automatic discovery turned off work?
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 3

Author Comment

by:AIC-Admin
ID: 33648438
when I run the proxycfg.exe command it just brings up Internet Options to the connections tab (which I have my Cymphonix proxy turned off right now).
I ran the netsh winsock reset command and rebooted my PC but that didnt help
If Automatically Detect Settings is turned off my internet runs fine whether I go through our Cymphonix proxy or not. If I am going through my Cymphonix Proxy with Automatically Detect Settings turned on it still lags when I first open a new IE window or tab.  
The PC I am running now is a realiively new PC and was not around when we were using the ISA server so this PC never used that configuration. I assume it must be a routing issue on this VLAN / subnet or a misconfiguration in my DNS.
0
 
LVL 2

Expert Comment

by:jtokarchuk
ID: 33648475
I would check your VLAN over. I tend to agree that it is a routing issue.

I wouldn't say DNS because when IE is automatically detecting, it tends not to care if there are forward/reverse lookups for your proxy server. And if it were the case, (assuming you have one DC) it would be happening on all of your machines.
0
 
LVL 3

Author Comment

by:AIC-Admin
ID: 33666455
After digging through some Wireshark packet captures I can see that my browser is sending out TCP Packets to "isa.ahc.net" which is our old ISA server / proxy which is no longer on the network.
My system is sending a TCP protocol with the following info "59782 > http [SYN] Seq=0 Win=8192 Len=0 MSS=1460 WS=2]".
Somewhere on my network my PC is being told to send standard query requests to ISA.ahc.net instead of DC.ahc.net. After retrying about a dozen times to send requests to ISA.ahc.net my system finally sends its dns request to my domain controller which processes the request.
Any idea's where I can look to see where my PC is picking up the setting to send queries to my no existent ISA server? Also its worth noting that we got rid of our ISA server month before I purchased my current PC so my PC that is sending requests to ISA has never had any direct communication with that device.
0
 
LVL 3

Accepted Solution

by:
AIC-Admin earned 0 total points
ID: 33683412
Okay I think I found my own solution but it will be a few days before I can test.
Within my DNS server in my forward lookup zone there is a record for WPAD which has the setting "Full qualified domain name [FQDN] for target host: isa.ahc.net".
As well within our DHCP configurationunder Predefined Options we have an Option 252 WPAD created that points to String: http://ISA.ahc.net:80/wpad.dat.
I believe removing these two entries will correct my IE lag problems when establishing a new connection. Thanks to jtokarchuk for his assistance.
0
 
LVL 3

Author Closing Comment

by:AIC-Admin
ID: 33683428
after researching I found the solution
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
Several part series to implement Internet Explorer 11 Enterprise Mode
Google currently has a new report that is in beta and coming soon to Webmaster Tool accounts. This Micro Tutorial will highlight new features for Google Webmaster Tools.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

937 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

4 Experts available now in Live!

Get 1:1 Help Now